- Update MASTER_SITES

PR:		175596
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2013-02-04 14:28:34 +00:00
parent 6e00b2437a
commit 9fe54c4293
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=311620
2 changed files with 80 additions and 4 deletions

View File

@ -9,17 +9,19 @@ PORTNAME= xcoloredit
PORTVERSION= 1.2
PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= ftp://ftp.x.org/R5contrib/
MASTER_SITES= XCONTRIB/../R5contrib
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Find colour values by graphical colour mixing
USE_IMAKE= yes
USE_XORG= ice sm x11 xaw xext xmu xpm xt
MAN1= xcoloredit.1
USE_IMAKE= yes
MAKE_JOBS_SAFE= yes
MANCOMPRESSED= yes
MAN1= xcoloredit.1
PLIST_FILES= bin/xcoloredit
.include <bsd.port.mk>

View File

@ -1,6 +1,22 @@
--- xcoloredit.c.orig Wed May 30 22:10:09 2007
+++ xcoloredit.c Wed May 30 22:10:57 2007
@@ -85,6 +85,7 @@
@@ -38,6 +38,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include <X11/Xatom.h>
#include <X11/X.h>
#include <X11/Intrinsic.h>
@@ -50,6 +51,7 @@
#include <X11/Xaw/Form.h>
#include <X11/Xaw/Box.h>
#include <X11/Xmu/Atoms.h>
+#include <X11/Xmu/StdSel.h>
#include "Xcoloredit.h"
#include "color.h"
@@ -85,6 +87,7 @@
static void move_scroll();
static void change_text_colour();
@ -8,3 +24,61 @@
#define MEMORY_OFFSET 8
#define NUM_MEMORIES 36
@@ -182,8 +185,8 @@
#undef offset
-void main(argc, argv)
-unsigned int argc;
+int main(argc, argv)
+int argc;
char **argv;
{
Status ok;
@@ -696,7 +699,7 @@
(float)0.025);
XawScrollbarSetThumb(valScroll, (float)(1.0 - hsv_values.v),
(float)0.025);
-#endif SOLID_THUMB
+#endif /* SOLID_THUMB */
}
@@ -878,7 +881,7 @@
XawScrollbarSetThumb(w, top, (float)(1.0 - top));
#else
XawScrollbarSetThumb(w, top, (float)0.025);
-#endif SOLID_THUMB
+#endif /* SOLID_THUMB */
do_change = FALSE;
pass_value = 1.0 - rgb_values.r/65536.0;
@@ -941,7 +944,7 @@
XawScrollbarSetThumb(w, top, (float)(1.0 - top));
#else
XawScrollbarSetThumb(w, top, (float)0.025);
-#endif SOLID_THUMB
+#endif /* SOLID_THUMB */
move_lock();
}
@@ -960,7 +963,7 @@
(float)(1.0 - locked_top));
#else
XawScrollbarSetThumb(lockedScroll, locked_top, (float)0.025);
-#endif SOLID_THUMB
+#endif /* SOLID_THUMB */
}
@@ -986,8 +989,8 @@
unsigned long *length;
int *format;
{
- if (XmuConvertStandardSelection(w, selection, target, type, value,
- length, format))
+ if (XmuConvertStandardSelection(w, (Time)0, selection, target, type,
+ (XPointer *)value, length, format))
return TRUE;
if (*target == XA_STRING) {