Add xgobi 2001.09, graphical data visualisation tool.

PR:		32994
Submitted by:	Tony Maher <tonym@biolateral.com.au>
This commit is contained in:
Pete Fritchman 2001-12-19 04:06:09 +00:00
parent ae7cc0cc5c
commit 9fbddc5395
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51784
7 changed files with 208 additions and 0 deletions

View File

@ -137,6 +137,7 @@
SUBDIR += wingz3
SUBDIR += wmcalc
SUBDIR += xgfe
SUBDIR += xgobi
SUBDIR += xgraph
SUBDIR += xldlas
SUBDIR += xlispstat

66
math/xgobi/Makefile Normal file
View File

@ -0,0 +1,66 @@
# New ports collection makefile for: xgobi
# Date created: 5 December 2001
# Whom: Tony Maher <tonym@biolateral.com.au>
#
# $FreeBSD$
#
PORTNAME= xgobi
PORTVERSION= 2001.09
CATEGORIES= math graphics
MASTER_SITES= http://www.research.att.com/areas/stat/xgobi/
DISTNAME= xgobi
EXTRACT_SUFX= .sh.gz
MAINTAINER= tonym@biolateral.com.au
NO_CDROM= "Restrictive copyright (do not sell for profit)"
PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}/src
CONFIGURE_WRKSRC= ${PATCH_WRKSRC}
BUILD_WRKSRC= ${PATCH_WRKSRC}
USE_IMAKE= true
USE_XPM= yes
XFREE86_HTML_MAN= no
MANCOMPRESSED= no
MAN1= xgvis.1 xgobi.1
PROGRAMS= xgvis xgobi
MANDIR= ${WRKSRC}/manpages
# The distfile is a shar file. It also does not extract cleanly.
# 3 files extract to current directory so use post-extract to move
# them to proper locations.
do-extract:
@${MKDIR} ${WRKDIR}
@for file in ${EXTRACT_ONLY}; do \
cd ${WRKDIR} && \
${GZCAT} ${DISTDIR}/$${file} | ${SH} > /dev/null 2>&1; \
done
@${MV} ${WRKDIR}/aclocal.m4 ${WRKSRC}
@${MV} ${WRKDIR}/make.out ${WRKSRC}
@${MV} ${WRKDIR}/xgobi.html ${MANDIR}
do-install:
.for file in ${PROGRAMS}
${INSTALL_PROGRAM} ${WRKSRC}/src/${file} ${PREFIX}/bin
${STRIP_CMD} ${PREFIX}/bin/${file}
${INSTALL_MAN} ${MANDIR}/${file}.1 ${PREFIX}/man/man1
.endfor
${INSTALL_DATA} ${WRKSRC}/XGobi.ex ${PREFIX}/lib/X11/app-defaults
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
@ cd ${WRKSRC}; \
for dir in data_*; do \
${MKDIR} ${EXAMPLESDIR}/$${dir}; \
cd ${WRKSRC}/$${dir}; \
for file in *; do \
${INSTALL_DATA} $${file} ${EXAMPLESDIR}/$${dir}; \
done \
done
.endif
.include <bsd.port.mk>

1
math/xgobi/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (xgobi.sh.gz) = ecce1eec28931e8e7e433b86f97675fe

View File

@ -0,0 +1,20 @@
$FreeBSD$
--- Imakefile.orig Wed Dec 5 08:01:33 2001
+++ Imakefile Wed Dec 5 08:01:51 2001
@@ -12,11 +12,11 @@
/**/# the xgobi directories src, help, ps, etc.
XGOBID = $(PWD)/..
- CC = cc
- CCOPTIONS = -xansi -n32
+# CC = cc
+# CCOPTIONS = -xansi -n32
-# CC = gcc
-# CCOPTIONS = -ansi -w
+ CC ?= gcc
+ CCOPTIONS = -ansi -w
LD =
CDEBUGFLAGS = -g

1
math/xgobi/pkg-comment Normal file
View File

@ -0,0 +1 @@
Graphical data visualisation tool

12
math/xgobi/pkg-descr Normal file
View File

@ -0,0 +1,12 @@
An interactive dynamic graphics program for data visualization
in the X Window System. It is especially designed for the exploration
of multivariate data. Its basic plot is a scatterplot and there are
a number of the tools available for scatterplot display and manipulation.
It has a direct manipulation interface, and all the manipulations
are performed using the mouse.
It can be used in conjunction with the S language for scientific
computing and data analysis. (Or R language).
Also it can be programmed using RPC to communicate with other software.
--
Tony Maher <tonym@biolateral.com.au>

107
math/xgobi/pkg-plist Normal file
View File

@ -0,0 +1,107 @@
bin/xgobi
bin/xgvis
lib/X11/app-defaults/XGobi.ex
%%PORTDOCS%%share/examples/xgobi/data_xgobi/c60
%%PORTDOCS%%share/examples/xgobi/data_xgobi/c60.linecolors
%%PORTDOCS%%share/examples/xgobi/data_xgobi/c60.lines
%%PORTDOCS%%share/examples/xgobi/data_xgobi/cube6
%%PORTDOCS%%share/examples/xgobi/data_xgobi/cube6.lines
%%PORTDOCS%%share/examples/xgobi/data_xgobi/death1987
%%PORTDOCS%%share/examples/xgobi/data_xgobi/death1987.col
%%PORTDOCS%%share/examples/xgobi/data_xgobi/death1987.lines
%%PORTDOCS%%share/examples/xgobi/data_xgobi/death1987.resources
%%PORTDOCS%%share/examples/xgobi/data_xgobi/death1987.row
%%PORTDOCS%%share/examples/xgobi/data_xgobi/flea.col
%%PORTDOCS%%share/examples/xgobi/data_xgobi/flea.colors
%%PORTDOCS%%share/examples/xgobi/data_xgobi/flea.dat
%%PORTDOCS%%share/examples/xgobi/data_xgobi/flea.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/flea.glyphs
%%PORTDOCS%%share/examples/xgobi/data_xgobi/flea.row
%%PORTDOCS%%share/examples/xgobi/data_xgobi/kai.dat
%%PORTDOCS%%share/examples/xgobi/data_xgobi/kai.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/kai.lines
%%PORTDOCS%%share/examples/xgobi/data_xgobi/kai.resources
%%PORTDOCS%%share/examples/xgobi/data_xgobi/kai.row
%%PORTDOCS%%share/examples/xgobi/data_xgobi/laser
%%PORTDOCS%%share/examples/xgobi/data_xgobi/laser.col
%%PORTDOCS%%share/examples/xgobi/data_xgobi/laser.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/laser.resources
%%PORTDOCS%%share/examples/xgobi/data_xgobi/laser.vgroups
%%PORTDOCS%%share/examples/xgobi/data_xgobi/olive
%%PORTDOCS%%share/examples/xgobi/data_xgobi/olive.col
%%PORTDOCS%%share/examples/xgobi/data_xgobi/olive.colors
%%PORTDOCS%%share/examples/xgobi/data_xgobi/olive.glyphs
%%PORTDOCS%%share/examples/xgobi/data_xgobi/olive.resources
%%PORTDOCS%%share/examples/xgobi/data_xgobi/olive.row
%%PORTDOCS%%share/examples/xgobi/data_xgobi/places
%%PORTDOCS%%share/examples/xgobi/data_xgobi/places.col
%%PORTDOCS%%share/examples/xgobi/data_xgobi/places.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/places.resources
%%PORTDOCS%%share/examples/xgobi/data_xgobi/places.row
%%PORTDOCS%%share/examples/xgobi/data_xgobi/prim7
%%PORTDOCS%%share/examples/xgobi/data_xgobi/prim7.colors
%%PORTDOCS%%share/examples/xgobi/data_xgobi/prim7.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/prim7.glyphs
%%PORTDOCS%%share/examples/xgobi/data_xgobi/prim7.lines
%%PORTDOCS%%share/examples/xgobi/data_xgobi/prim7.res
%%PORTDOCS%%share/examples/xgobi/data_xgobi/prim7.resources
%%PORTDOCS%%share/examples/xgobi/data_xgobi/randu
%%PORTDOCS%%share/examples/xgobi/data_xgobi/randu.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/river
%%PORTDOCS%%share/examples/xgobi/data_xgobi/river.col
%%PORTDOCS%%share/examples/xgobi/data_xgobi/river.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sleep.col
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sleep.dat
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sleep.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sleep.missing
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sleep.row
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sleep.table
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sphere1.dat
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sphere1.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sphere1.resources
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sphere2.dat
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sphere2.doc
%%PORTDOCS%%share/examples/xgobi/data_xgobi/sphere2.resources
%%PORTDOCS%%share/examples/xgobi/data_xgobi/tips.col
%%PORTDOCS%%share/examples/xgobi/data_xgobi/tips.dat
%%PORTDOCS%%share/examples/xgobi/data_xgobi/tips.doc
%%PORTDOCS%%share/examples/xgobi/data_xgvis/basket.edges
%%PORTDOCS%%share/examples/xgobi/data_xgvis/basket.pos
%%PORTDOCS%%share/examples/xgobi/data_xgvis/buckyball.dat
%%PORTDOCS%%share/examples/xgobi/data_xgvis/buckyball.linecolors
%%PORTDOCS%%share/examples/xgobi/data_xgvis/buckyball.lines
%%PORTDOCS%%share/examples/xgobi/data_xgvis/buckyball.resources
%%PORTDOCS%%share/examples/xgobi/data_xgvis/grid5.edges
%%PORTDOCS%%share/examples/xgobi/data_xgvis/grid5.pos
%%PORTDOCS%%share/examples/xgobi/data_xgvis/hyper8.edges
%%PORTDOCS%%share/examples/xgobi/data_xgvis/hyper8.pos
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.R
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.col
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.colors
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.dat
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.dist
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.doc
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.glyphs
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.linecolors
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.lines
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.pos
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.raw
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.row
%%PORTDOCS%%share/examples/xgobi/data_xgvis/morsecodes.sim
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm4.edges
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm4.linecolors
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm4.pos
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm4.row
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm5.edges
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm5.labels
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm5.pos
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm6.edges
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm6.labels
%%PORTDOCS%%share/examples/xgobi/data_xgvis/perm6.pos
%%PORTDOCS%%share/examples/xgobi/data_xgvis/torus1.edges
%%PORTDOCS%%share/examples/xgobi/data_xgvis/torus1.pos
%%PORTDOCS%%share/examples/xgobi/data_xgvis/torus2.edges
%%PORTDOCS%%share/examples/xgobi/data_xgvis/torus2.pos
%%PORTDOCS%%@dirrm share/examples/xgobi/data_xgvis
%%PORTDOCS%%@dirrm share/examples/xgobi/data_xgobi
%%PORTDOCS%%@dirrm share/examples/xgobi