misc/{,py-}tvm: Update 0.9.0 -> 0.10.0

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2022-10-19 00:14:59 -07:00
parent a32d25b1c1
commit 9effd49f06
6 changed files with 31 additions and 22 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= tvm
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.0
DISTVERSION= 0.10.0
CATEGORIES= misc # machine-learning
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}tornado>0:www/py-tornado@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= distutils noegginfo
USE_PYTHON= distutils noegginfo pytest # tests fail, see https://github.com/apache/tvm/issues/13132
USE_GITHUB= yes
GH_ACCOUNT= apache
@ -33,7 +33,11 @@ GH_TUPLE= dmlc:dlpack:ddeb264:dlpack/3rdparty/dlpack \
BUILD_WRKSRC= ${WRKSRC}/python
INSTALL_WRKSRC= ${WRKSRC}/python
LLVM_VERSION= ${LLVM_DEFAULT} # same as in misc/tvm
RUN_DEPENDS= llvm-config${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
MAKE_ENV+= FREEBSD_LIBRARY_PATH=${LOCALBASE}/lib
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
BINARY_ALIAS= git=false

View File

@ -1,6 +1,6 @@
TIMESTAMP = 1658465287
SHA256 (apache-tvm-v0.9.0_GH0.tar.gz) = bb6de5645095a7f7e2b2551f6dff8d1ca80f095852a6e1c2deeea569a7eb8816
SIZE (apache-tvm-v0.9.0_GH0.tar.gz) = 7017289
TIMESTAMP = 1666161174
SHA256 (apache-tvm-v0.10.0_GH0.tar.gz) = c51e0336fdc86b05a60598afc695eb41aef243c1be12ca25088372d001848a24
SIZE (apache-tvm-v0.10.0_GH0.tar.gz) = 7601014
SHA256 (dmlc-dlpack-ddeb264_GH0.tar.gz) = 87e45c7141f8af012cf4e9829072342df2b568def3ed65f1c9bc5fa4b986e3c8
SIZE (dmlc-dlpack-ddeb264_GH0.tar.gz) = 39502
SHA256 (dmlc-dmlc-core-09511cf_GH0.tar.gz) = 8b7ba0e19a9f2c5d65d49758ab14631e99c4f501b689842fa6535fc44a05c46f

View File

@ -1,6 +1,6 @@
PORTNAME= tvm
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.0
DISTVERSION= 0.10.0
CATEGORIES= misc # machine-learning
MAINTAINER= yuri@FreeBSD.org
@ -43,7 +43,7 @@ LLVM_RUN_DEPENDS= llvm-config${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
CMAKE_ARGS+= -DUSE_RPC:BOOL=OFF
.endif
post-test:
post-test: # 1 test fails, see https://github.com/apache/tvm/issues/13131
@cd ${TEST_WRKSRC} && ./cpptest
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1658387958
SHA256 (apache-tvm-v0.9.0_GH0.tar.gz) = bb6de5645095a7f7e2b2551f6dff8d1ca80f095852a6e1c2deeea569a7eb8816
SIZE (apache-tvm-v0.9.0_GH0.tar.gz) = 7017289
TIMESTAMP = 1666152866
SHA256 (apache-tvm-v0.10.0_GH0.tar.gz) = c51e0336fdc86b05a60598afc695eb41aef243c1be12ca25088372d001848a24
SIZE (apache-tvm-v0.10.0_GH0.tar.gz) = 7601014
SHA256 (dmlc-dlpack-ddeb264_GH0.tar.gz) = 87e45c7141f8af012cf4e9829072342df2b568def3ed65f1c9bc5fa4b986e3c8
SIZE (dmlc-dlpack-ddeb264_GH0.tar.gz) = 39502

View File

@ -1,11 +0,0 @@
--- src/tir/transforms/common_subexpr_elim_tools.h.orig 2022-07-21 17:19:38 UTC
+++ src/tir/transforms/common_subexpr_elim_tools.h
@@ -37,7 +37,7 @@
#include <utility> // For pairs datatype
#include <vector>
-#include "../../../3rdparty/dmlc-core/include/dmlc/optional.h"
+#include <dmlc/optional.h>
namespace tvm {
namespace tir {

View File

@ -24,9 +24,11 @@ include/tvm/ir/env_func.h
include/tvm/ir/error.h
include/tvm/ir/expr.h
include/tvm/ir/function.h
include/tvm/ir/global_var_supply.h
include/tvm/ir/instrument.h
include/tvm/ir/memory_pools.h
include/tvm/ir/module.h
include/tvm/ir/name_supply.h
include/tvm/ir/op.h
include/tvm/ir/span.h
include/tvm/ir/tensor_type.h
@ -34,7 +36,6 @@ include/tvm/ir/transform.h
include/tvm/ir/type.h
include/tvm/ir/type_functor.h
include/tvm/ir/type_relation.h
include/tvm/meta_schedule/apply_history_best.h
include/tvm/meta_schedule/arg_info.h
include/tvm/meta_schedule/builder.h
include/tvm/meta_schedule/cost_model.h
@ -55,6 +56,7 @@ include/tvm/meta_schedule/tune_context.h
include/tvm/node/attr_registry_map.h
include/tvm/node/functor.h
include/tvm/node/node.h
include/tvm/node/object_path.h
include/tvm/node/reflection.h
include/tvm/node/repr_printer.h
include/tvm/node/serialization.h
@ -133,6 +135,7 @@ include/tvm/runtime/data_type.h
include/tvm/runtime/debug.h
include/tvm/runtime/device_api.h
include/tvm/runtime/executor_info.h
include/tvm/runtime/hexagon/ops/conv2d.h
include/tvm/runtime/logging.h
include/tvm/runtime/memory.h
include/tvm/runtime/metadata.h
@ -151,6 +154,19 @@ include/tvm/runtime/vm/bytecode.h
include/tvm/runtime/vm/executable.h
include/tvm/runtime/vm/memory_manager.h
include/tvm/runtime/vm/vm.h
include/tvm/script/ir_builder/base.h
include/tvm/script/ir_builder/ir/frame.h
include/tvm/script/ir_builder/ir/ir.h
include/tvm/script/ir_builder/tir/frame.h
include/tvm/script/ir_builder/tir/ir.h
include/tvm/script/printer.h
include/tvm/script/printer/doc.h
include/tvm/script/printer/doc_printer.h
include/tvm/script/printer/frame.h
include/tvm/script/printer/ir_docsifier.h
include/tvm/script/printer/traced_object.h
include/tvm/script/printer/traced_object_functor.h
include/tvm/script/printer/var_table.h
include/tvm/support/parallel_for.h
include/tvm/support/random_engine.h
include/tvm/support/span.h