Import teapot port. teapot is a curses-based spreadsheet.

PR:		5461
Submitted by:	Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
Thomas Gellekum 1998-03-27 10:31:48 +00:00
parent 3752d107f1
commit 9ef2f57675
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10323
6 changed files with 109 additions and 0 deletions

32
deskutils/teapot/Makefile Normal file
View File

@ -0,0 +1,32 @@
# New ports collection makefile for: teapot
# Version required: 1.01
# Date created: 7 January 1998
# Whom: Andrey Zakhvatov
#
# $Id$
#
DISTNAME= teapot-1.01
CATEGORIES= misc
MASTER_SITES= ftp://cantor.informatik.rwth-aachen.de/pub/unix/
MAINTAINER= andy@icc.surw.chel.su
ALL_TARGET=
MAN1= teapot.1
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/teapot ${PREFIX}/bin
@ cd ${WRKSRC}/doc; make teapot.doc teapot.html teapot.ps
@ ${INSTALL_MAN} ${WRKSRC}/teapot.1.en ${PREFIX}/man/man1/teapot.1
@ ${MKDIR} ${PREFIX}/share/examples/teapot
.for file in asqrt asqrt.README counter counter.README life life.README sqrt sqrt.README
@ ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${PREFIX}/share/examples/teapot
.endfor
@ ${MKDIR} ${PREFIX}/share/doc/teapot
@ ${INSTALL_DATA} ${WRKSRC}/README-en.html ${PREFIX}/share/doc/teapot/README.html
.for file in teapot.doc teapot.html teapot.ps
@ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/teapot
.endfor
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (teapot-1.01.tar.gz) = 7a5191788f86d3df5d589a7efde714c3

View File

@ -0,0 +1,37 @@
--- Makefile.orig Wed Mar 18 19:12:56 1998
+++ Makefile Fri Mar 27 11:22:13 1998
@@ -1,16 +1,16 @@
#{{{script}}}#{{{ Linux, moria machines, gcc
-CFLAGS= -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
+#CFLAGS= -g -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
# The XDR library needs _BSD_SOURCE :(
CPPFLAGS= -D_BSD_SOURCE
#CPPFLAGS= -DTHE_ELECTRIC_FENCE
#CPPFLAGS= -I/usr/dmalloc/include -DDMALLOC
-LDFLAGS= -g
+#LDFLAGS= -g
#LDFLAGS= -g -L/usr/efence/lib
#LDFLAGS= -g -L/usr/dmalloc/lib
-LIBS= -lcurses -lm
+#LIBS= -lcurses -lm
#LIBS= -lcurses -lm -lefence
#LIBS= -lcurses -lm -ldmalloc
-MAKEDEPEND= mkdep -d
+#MAKEDEPEND= mkdep -d
#}}}
#{{{ Linux, Slackware/Redhat/Debian Distribution, gcc
#CC= gcc
@@ -22,10 +22,9 @@
#MAKEDEPEND= gcc -MM
#}}}
#{{{ FreeBSD 2.x, gcc
-#CC= gcc
-#CFLAGS= -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common
-#CPPFLAGS= -I./.curses.h -DNO_POSIX_SOURCE
-#LIBS= -lncurses -lmytinfo -lm
+CC= gcc
+CFLAGS= -pipe -O2 -Wall -Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common -I./.curses.h -DNO_POSIX_SOURCE
+LIBS= -lncurses -lmytinfo -lm
#LDFLAGS=
#MAKEDEPEND= gcc -MM
#}}}

View File

@ -0,0 +1 @@
Full-screen curses based spread sheet program

View File

@ -0,0 +1,22 @@
This is release 0.9 beta of teapot (Table Editor And Planner, Or:
Teapot), a new spread sheet program for UNIX.
The current release has the following features:
o curses based user interface with easy to understand menues
o portable sheet file format uses XDR or ASCII format
o tbl, LaTeX, HTML, CSV or formatted text files can be generated and
simple SC and WK1 sheets can be imported
o typed expression evaluator with the types int, float, string, error,
pointer to cell and empty
o iterative expressions
o powerful cell addressing
o three-dimensional sheets
o new expression evaluator functions can be added very easy
o English, Dutch or German builtin messages or X/OPEN message catalogues
o a user guide, available as troff -mm, PostScript and ASCII
o It is still a small and simple program!
The following URLs tell you a little more about it:
http://cantor.informatik.rwth-aachen.de/~michael/projects/teapot-en.html

View File

@ -0,0 +1,16 @@
bin/teapot
man/man1/teapot.1.gz
share/doc/teapot/README.html
share/doc/teapot/teapot.doc
share/doc/teapot/teapot.html
share/doc/teapot/teapot.ps
share/examples/teapot/asqrt
share/examples/teapot/asqrt.README
share/examples/teapot/counter
share/examples/teapot/counter.README
share/examples/teapot/life
share/examples/teapot/life.README
share/examples/teapot/sqrt
share/examples/teapot/sqrt.README
@dirrm share/doc/teapot
@dirrm share/examples/teapot