Add envelope 1.0.0, command-line Postscript envelope printer.

PR:		38214
Submitted by:	Alan Eldridge ports@geeksrus.net
This commit is contained in:
Alan Eldridge 2002-06-13 02:53:52 +00:00
parent 505cfb9b43
commit 9ed6650539
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61186
8 changed files with 102 additions and 0 deletions

View File

@ -50,6 +50,7 @@
SUBDIR += enscript-letter
SUBDIR += enscript-letterdj
SUBDIR += enscriptfonts
SUBDIR += envelope
SUBDIR += freetype
SUBDIR += freetype2
SUBDIR += ft2demos

46
print/envelope/Makefile Normal file
View File

@ -0,0 +1,46 @@
# ex:ts=8
#
# New ports collection makefile for: envelope
# Date created: 2002/03/24
# Whom: Alan Eldridge ports@geeksrus.net
#
# $FreeBSD$
#
PORTNAME= envelope
PORTVERSION= 1.0.0
CATEGORIES= print
MASTER_SITES= http://freefall.homeip.net/code/envelope/
DISTNAME= ${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@geeksrus.net
NO_BUILD= yes
USE_PERL5= yes
NO_WRKSUBDIR= yes
PLIST_SUB+= DOCSDIR=${DOCSDIR:S@^${PREFIX}/@@}
PLIST_SUB+= EXAMPLESDIR=${EXAMPLESDIR:S@^${PREFIX}/@@}
post-patch:
@${PERL} -pi -e 's@/usr/bin/perl@${PERL}@' ${WRKDIR}/envelope
do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/envelope ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR} ${EXAMPLESDIR} ${EXAMPLESDIR}/config
@cd ${WRKDIR}; ${INSTALL_DATA} samplerc INSTALL ReadMe ${DOCSDIR}
@cd ${WRKDIR}/examples; \
${INSTALL_DATA} normal returnaddress shipping_label \
simple with_config with_font_info with_options \
${EXAMPLESDIR}
@cd ${WRKDIR}/examples; ${INSTALL_DATA} config/* ${EXAMPLESDIR}/config
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
#EOF

1
print/envelope/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (envelope_1.0.0.tgz) = f02702b7958db2035beeb42a8f2b155e

View File

@ -0,0 +1,12 @@
--- samplerc.orig Mon Jan 29 22:20:06 2001
+++ samplerc Sat May 18 00:33:08 2002
@@ -25,6 +25,9 @@
$feedcenter = $normalwidth/2 - $eheight/2
$leftmargin = 0.25
+# if you use a program (like kprinter) that tells the printer
+# to expect an envelope of the correct size, do not add the $feed*
+# offset to $topmargin.
$topmargin = 0.30 + $feedcenter

View File

@ -0,0 +1 @@
Command-line Postscript envelope printer

1
print/envelope/pkg-descr Normal file
View File

@ -0,0 +1 @@
Configurable command-line envelope printer which outputs Postscript.

View File

@ -0,0 +1,10 @@
======================================================================
NOTE: In order to use this program, you will need to copy the
file ${PREFIX}/share/doc/envelope/samplerc to ~/.enveloperc.
You may then modify ~/.enveloperc according to the instructions in
the file.
Additional configuration examples can be found in the directory
${PREFIX}/share/examples/envelope.
======================================================================

30
print/envelope/pkg-plist Normal file
View File

@ -0,0 +1,30 @@
bin/envelope
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/ReadMe
%%PORTDOCS%%%%DOCSDIR%%/samplerc
%%PORTDOCS%%%%EXAMPLESDIR%%/config/8.625
%%PORTDOCS%%%%EXAMPLESDIR%%/config/datacard
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number10
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number10.5
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number11
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number12
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number14
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number5
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number6
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number6.25
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number6.75
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number7
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number7.5
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number7.75
%%PORTDOCS%%%%EXAMPLESDIR%%/config/number9
%%PORTDOCS%%%%EXAMPLESDIR%%/normal
%%PORTDOCS%%%%EXAMPLESDIR%%/returnaddress
%%PORTDOCS%%%%EXAMPLESDIR%%/shipping_label
%%PORTDOCS%%%%EXAMPLESDIR%%/simple
%%PORTDOCS%%%%EXAMPLESDIR%%/with_config
%%PORTDOCS%%%%EXAMPLESDIR%%/with_font_info
%%PORTDOCS%%%%EXAMPLESDIR%%/with_options
@comment dirs
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/config
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%