MFH: r470051 r470052 r470053 r470054 r470055 r470056
math/ceres-solver: fix LAPACK options after r465552/r465553 - NETLIB used wrong library - OPENBLAS was nop - ATLAS didn't build Approved by: ports-secteam blanket
This commit is contained in:
parent
25a83dbca9
commit
9ebefb9782
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=470058
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= ceres-solver
|
||||
DISTVERSION= 1.14.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= math
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
@ -69,19 +70,24 @@ TEST_IMPLIES= GFLAGS
|
||||
LAPACK_DESC= Linear Algebra PACKage
|
||||
LAPACK_USES= fortran # LDFLAGS
|
||||
LAPACK_CMAKE_BOOL= LAPACK
|
||||
LAPACK_CMAKE_ON= -DCMAKE_POLICY_DEFAULT_CMP0056:STRING=NEW # USES=fortran
|
||||
# Avoid conflict with Ceres threading by using single-threaded BLAS library.
|
||||
# BLASLIB from USES=blaslapack cannot be used as it's multi-threaded.
|
||||
# https://github.com/xianyi/OpenBLAS/wiki/faq#multi-threaded
|
||||
ATLAS_USES= blaslapack:atlas
|
||||
ATLAS_MAKE_ENV= BLA_VENDOR=ATLAS
|
||||
ATLAS_CMAKE_ON= -DLAPACK_LIBRARIES:STRING=alapack
|
||||
ATLAS_CMAKE_ON= -DBLA_VENDOR:STRING="ATLAS" \
|
||||
-DBLAS_LIBRARIES:FILEPATH="${LOCALBASE}/lib/libcblas.so" \
|
||||
-DLAPACK_LIBRARIES:FILEPATH="${LOCALBASE}/lib/libalapack.so"
|
||||
ATLAS_IMPLIES= LAPACK
|
||||
GOTOBLAS_DESC= Goto blas implementation
|
||||
GOTOBLAS_USES= blaslapack:gotoblas
|
||||
GOTOBLAS_MAKE_ENV= BLA_VENDOR=Goto
|
||||
GOTOBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="Goto"
|
||||
GOTOBLAS_IMPLIES= LAPACK
|
||||
NETLIB_USES= blaslapack:netlib
|
||||
NETLIB_MAKE_ENV= BLA_VENDOR=Generic
|
||||
NETLIB_CMAKE_ON= -DBLA_VENDOR:STRING="Generic"
|
||||
NETLIB_IMPLIES= LAPACK
|
||||
OPENBLAS_USES= blaslapack:openblas
|
||||
OPENBLAS_MAKE_ENV= BLA_VENDOR=OpenBLAS
|
||||
OPENBLAS_CMAKE_ON= -DBLA_VENDOR:STRING="OpenBLAS"
|
||||
OPENBLAS_IMPLIES= LAPACK
|
||||
|
||||
SPARSE_DESC= Sparse linear algebra library
|
||||
|
13
math/ceres-solver/files/patch-CMakeLists.txt
Normal file
13
math/ceres-solver/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,13 @@
|
||||
https://github.com/ceres-solver/ceres-solver/issues/355
|
||||
|
||||
--- CMakeLists.txt.orig 2018-03-22 04:00:14 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -435,7 +435,7 @@ if (CXX11 AND COMPILER_HAS_CXX11_FLAG)
|
||||
# Update CMAKE_REQUIRED_FLAGS used by CheckCXXSourceCompiles to include
|
||||
# -std=c++11 s/t we will detect the C++11 versions of unordered_map &
|
||||
# shared_ptr if they exist.
|
||||
- set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -std=c++11")
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
|
||||
endif (CXX11 AND COMPILER_HAS_CXX11_FLAG)
|
||||
|
||||
# Set the Ceres compile definitions for the unordered_map configuration.
|
Loading…
Reference in New Issue
Block a user