- Add LICENSE

- Fix install wrt PREFIX/LOCALBASE
- Fix build on >= 10.0
- Strip library
This commit is contained in:
Dmitry Marakasov 2015-04-16 06:17:58 +00:00
parent 1b64f33f35
commit 9eae07b3d5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=384082
3 changed files with 32 additions and 5 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= gracetmpl
PORTVERSION= 0.3.2
PORTREVISION= 1
CATEGORIES= math print
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@ -12,6 +13,9 @@ COMMENT= Provide an easy way to use existing grace-files as a template
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake python tar:bzip2
MAKE_ARGS= PREFIX="${PREFIX}" \
BIN_PREFIX="${PREFIX}/bin" \
@ -25,6 +29,7 @@ MAKE_ARGS= PREFIX="${PREFIX}" \
PYTHON="${PYTHON_CMD}"
ALL_TARGET= all pythonwrap
INSTALL_TARGET= install
USE_GCC= yes
PLIST_SUB+= PYTHON_VER=${PYTHON_VER}
@ -36,7 +41,8 @@ post-patch:
post-install:
@(cd ${INSTALL_WRKSRC}/python; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py \
install --root=${STAGEDIR} --prefix=${LOCALBASE} -c -O1)
install --root=${STAGEDIR} --prefix=${PREFIX} -c -O1)
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/graceTMPL/graceTMPL.so
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/html/* ${STAGEDIR}${DOCSDIR}

View File

@ -1,6 +1,11 @@
--- gracetmpl.cpp.bak Fri Sep 24 21:56:02 2004
+++ gracetmpl.cpp Sat Jun 18 00:18:52 2005
@@ -24,7 +24,7 @@
--- gracetmpl.cpp.orig 2004-09-24 16:56:02.000000000 +0400
+++ gracetmpl.cpp
@@ -21,10 +21,12 @@
#include <vector>
#include <map>
#include <iostream>
+#include <cstring>
+#include <cstdlib>
extern "C" {
#include <math.h>
@ -9,7 +14,7 @@
#include <ctype.h>
#include <time.h>
#include <sys/time.h>
@@ -981,7 +981,7 @@
@@ -981,7 +983,7 @@ string time2string (const string &format
gettimeofday(&tv,0);
size= (tm==0) ?

View File

@ -0,0 +1,16 @@
--- gracetmpldemo.cpp.orig 2003-03-04 10:32:45 UTC
+++ gracetmpldemo.cpp
@@ -3,11 +3,13 @@ extern "C" {
#include <stdlib.h>
#include <stdio.h>
#include <getopt.h>
+#include <sys/syslimits.h>
}
#include <iostream>
#include <string>
#include <vector>
#include <map>
+#include <cstring>
#include "gracetmpl.h"