Wired Tracker is the Wired tracker server. Wired servers can register

with the tracker with their name, URL and some other vitals, and
clients connecting to the tracker will be able to retrieve a listing
of all online servers.

WWW:	http://www.zankasoftware.com/wired/tracker/

PR:		ports/106169
Submitted by:	trasz <trasz at pin.if.uz.zgora.pl>
This commit is contained in:
Martin Wilke 2006-12-04 21:58:42 +00:00
parent 885e98d61c
commit 9ea22cc9bf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=178882
9 changed files with 203 additions and 0 deletions

View File

@ -851,6 +851,7 @@
SUBDIR += widentd
SUBDIR += wire
SUBDIR += wired
SUBDIR += wired-tracker
SUBDIR += wireshark
SUBDIR += wireshark-lite
SUBDIR += wistumbler2

View File

@ -0,0 +1,36 @@
# New ports collection makefile for: wired-tracker
# Date created: 2006-12-02
# Whom: trasz <trasz@pin.if.uz.zgora.pl>
#
# $FreeBSD$
#
PORTNAME= wired-tracker
PORTVERSION= 1.0
CATEGORIES= net
MASTER_SITES= http://www.zankasoftware.com/dist/
MAINTAINER= trasz@pin.if.uz.zgora.pl
COMMENT= Wired tracker
# This is an artificial dependancy - net/wired and net/wired-tracker
# use some common files, like wired/etc/resolv.conf.
RUN_DEPENDS= ${LOCALBASE}/sbin/wired:${PORTSDIR}/net/wired
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_RC_SUBR= trackerd.sh
MAN1= trackerdctl.1
MAN5= trackerd.conf.5
MAN8= trackerd.8
post-install:
@if [ ! -f ${PREFIX}/wired/etc/trackerd.conf ]; then \
${CP} -p ${PREFIX}/wired/etc/trackerd.conf.sample ${PREFIX}/wired/etc/trackerd.conf ; \
fi
@if [ ! -f ${PREFIX}/wired/categories ]; then \
${CP} -p ${PREFIX}/wired/categories.sample ${PREFIX}/wired/categories ; \
fi
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (wired-tracker-1.0.tar.gz) = 27969fd4cb94ab9d8a019d28be17a9ee
SHA256 (wired-tracker-1.0.tar.gz) = 6c85894395e4a8a4c4a6e792b55283032fe8cb37d6822d2777ddfc478eafad5b
SIZE (wired-tracker-1.0.tar.gz) = 225072

View File

@ -0,0 +1,91 @@
--- Makefile.in.orig Wed May 31 22:24:23 2006
+++ Makefile.in Sun Dec 3 21:19:20 2006
@@ -12,8 +12,8 @@
WT_VERSION = @WT_VERSION@
WT_MAINTAINER = @WT_MAINTAINER@
-WT_USER = @WT_USER@
-WT_GROUP = @WT_GROUP@
+WT_USER = wired
+WT_GROUP = wired
DISTFILES = INSTALL LICENSE NEWS README Makefile Makefile.in \
config.guess config.status config.h.in config.sub configure \
@@ -74,7 +74,7 @@
$(LINK) $(TRACKERDOBJECTS) $(LIBS)
$(rundir)/trackerdctl: trackerd/trackerdctl.in
- sed -e 's,@trackerddir\@,$(fake_prefix)/$(trackerddir),g' $< > $@
+ sed -e 's,@trackerddir\@,$(fake_prefix)/$(trackerddir),g' -e 's,@prefix\@,$(prefix),g' $< > $@
chmod +x $@
$(rundir)/etc/trackerd.conf: trackerd/trackerd.conf.in
@@ -97,61 +97,15 @@
touch .update; \
fi
- $(INSTALL) -m 755 -o $(WT_USER) -g $(WT_GROUP) -d $(installdir)/
- $(INSTALL) -m 755 -o $(WT_USER) -g $(WT_GROUP) -d $(installdir)/etc/
- $(INSTALL) -m 755 -o $(WT_USER) -g $(WT_GROUP) -d $(installdir)/tmp/
-
- if [ ! -f $(installdir)/banlist ]; then \
- $(INSTALL) -m 644 -o $(WT_USER) -g $(WT_GROUP) run/banlist $(installdir)/; \
- fi
-
- if [ ! -f $(installdir)/categories ]; then \
- $(INSTALL) -m 644 -o $(WT_USER) -g $(WT_GROUP) run/categories $(installdir)/; \
- fi
-
- if [ ! -f $(installdir)/etc/trackerd.conf ]; then \
- $(INSTALL) -m 644 -o $(WT_USER) -g $(WT_GROUP) run/etc/trackerd.conf $(installdir)/etc/; \
- fi
-
- $(INSTALL) -m 755 -o $(WT_USER) -g $(WT_GROUP) run/trackerd $(installdir)/
- $(INSTALL) -m 755 -o $(WT_USER) -g $(WT_GROUP) run/trackerdctl $(installdir)/
-
- if [ -f /etc/resolv.conf ]; then \
- $(INSTALL) -m 644 -o $(WT_USER) -g $(WT_GROUP) /etc/resolv.conf $(installdir)/etc/; \
- fi
-
- @if [ -f .update ]; then \
- echo ""; \
- echo "Update complete!"; \
- echo ""; \
- echo "You should now run:"; \
- echo " $(installdir)/trackerdctl restart"; \
- echo "to restart a running tracker."; \
- else \
- if [ ! -f $(installdir)/etc/certificate.pem ]; then \
- $(installdir)/trackerdctl certificate.pem; \
- fi; \
- \
- echo ""; \
- echo "Installation complete!"; \
- echo ""; \
- echo "Remember to edit $(installdir)/etc/trackerd.conf if you want to make any changes before starting the tracker."; \
- echo ""; \
- echo "When you are done, run:"; \
- echo " $(installdir)/trackerdctl start"; \
- echo "to start the tracker."; \
- fi
-
- @rm -f .update
+ $(INSTALL) -m 644 -o $(WT_USER) -g $(WT_GROUP) run/categories $(installdir)/categories.sample
+ $(INSTALL) -m 644 -o $(WT_USER) -g $(WT_GROUP) run/etc/trackerd.conf $(installdir)/etc/trackerd.conf.sample
+ $(INSTALL) -m 755 -o 0 -g 0 run/trackerd $(prefix)/sbin
+ $(INSTALL) -m 755 -o 0 -g 0 run/trackerdctl $(prefix)/bin
install-man:
- $(INSTALL) -m 755 -o root -g bin -d $(mandir)/man1/
- $(INSTALL) -m 755 -o root -g bin -d $(mandir)/man5/
- $(INSTALL) -m 755 -o root -g bin -d $(mandir)/man8/
-
- $(INSTALL) -m 644 -o root -g bin man/trackerdctl.1 $(mandir)/man1/
- $(INSTALL) -m 644 -o root -g bin man/trackerd.conf.5 $(mandir)/man5/
- $(INSTALL) -m 644 -o root -g bin man/trackerd.8 $(mandir)/man8/
+ $(INSTALL) -m 644 -o root -g wheel man/trackerdctl.1 $(mandir)/man1/
+ $(INSTALL) -m 644 -o root -g wheel man/trackerd.conf.5 $(mandir)/man5/
+ $(INSTALL) -m 644 -o root -g wheel man/trackerd.8 $(mandir)/man8/
dist:
rm -rf wired-tracker-$(WT_VERSION)

View File

@ -0,0 +1,20 @@
--- configure.orig Sat Dec 2 01:33:02 2006
+++ configure Sat Dec 2 01:33:12 2006
@@ -4945,7 +4945,7 @@
if test "$wt_pthreads_found" != yes ; then
# Save libs
OLD_LIBS="$LIBS"
- LIBS="-lpthread $LIBS"
+ LIBS="-pthread $LIBS"
# Try to run it
if test "$cross_compiling" = yes; then
@@ -5077,7 +5077,7 @@
# Did we find something?
if test "$wt_pthreads_test" = yes ; then
wt_pthreads_found=yes
- wt_pthreads_libs="-lpthread"
+ wt_pthreads_libs="-pthread"
fi
fi

View File

@ -0,0 +1,11 @@
--- trackerd/trackerdctl.in.orig Sat Dec 2 01:27:04 2006
+++ trackerd/trackerdctl.in Sat Dec 2 01:27:49 2006
@@ -13,7 +13,7 @@
CERTIFICATE="@trackerddir@/etc/certificate.pem"
# The path to your trackerd binary
-TRACKERD="@trackerddir@/trackerd"
+TRACKERD="@prefix@/sbin/trackerd"
# Flags to pass to trackerd
TRACKERDFLAGS="-d @trackerddir@ -ll -u"

View File

@ -0,0 +1,27 @@
#!/bin/sh
# PROVIDE: trackerd
# REQUIRE:
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
# to enable this service:
#
# trackerd_enable (bool): Set to NO by default.
# Set it to YES to enable trackerd.
#
. %%RC_SUBR%%
name="trackerd"
rcvar=${name}_enable
pidfile=%%PREFIX%%/wired/trackerd.pid
command=%%PREFIX%%/sbin/${name}
load_rc_config $name
: ${trackerd_enable="NO"}
command_args=""
run_rc_command "$1"

View File

@ -0,0 +1,6 @@
Wired Tracker is the Wired tracker server. Wired servers can register
with the tracker with their name, URL and some other vitals, and
clients connecting to the tracker will be able to retrieve a listing
of all online servers.
WWW: http://www.zankasoftware.com/wired/tracker/

View File

@ -0,0 +1,8 @@
@unexec if cmp -s %D/wired/etc/trackerd.conf.sample %D/wired/etc/trackerd.conf; then rm -f %D/wired/etc/trackerd.conf; fi
wired/etc/trackerd.conf.sample
@exec if [ ! -f %D/wired/etc/trackerd.conf ] ; then cp -p %D/%F %B/trackerd.conf; fi
@unexec if cmp -s %D/wired/categories.sample %D/wired/categories; then rm -f %D/wired/categories; fi
wired/categories.sample
@exec if [ ! -f %D/wired/categories ] ; then cp -p %D/%F %B/categories; fi
sbin/trackerd
bin/trackerdctl