Update to 2.0.2

PR:		20416
Submitted by:	Ports Fury
This commit is contained in:
Ade Lovett 2000-09-16 18:38:55 +00:00
parent d63ba47bd2
commit 9e9828d767
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32719
10 changed files with 121 additions and 64 deletions

View File

@ -6,22 +6,24 @@
#
PORTNAME= xmp
PORTVERSION= 2.0.1
PORTVERSION= 2.0.2
CATEGORIES= audio
MASTER_SITES= http://xmp.helllabs.org/pkg/2.0.1/ \
http://xmp.linuxbox.com/pkg/2.0.1/
MASTER_SITES= http://xmp.helllabs.org/pkg/%SUBDIR%/ \
http://xmp.linuxave.net/pkg/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= anders@fix.no
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-alsa
USE_BZIP2= yes
USE_XLIB= yes
USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa
CFLAGS+= -DHAVE_SYS_RTPRIO_H
MAN1= xmp.1
MLINKS= xmp.1 xxmp.1
MAN1= xmp.1 xxmp.1
post-patch:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/docs/xmp.1
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (xmp-2.0.1.tar.bz2) = c0ba87184feea1202ed1ec5fe02e4f9e
MD5 (xmp-2.0.2.tar.bz2) = 4680cdf3de9482b42055807f64b99e13

View File

@ -1,20 +1,20 @@
--- src/player/readrc.c.orig Sat Jul 3 17:13:04 1999
+++ src/player/readrc.c Sat Sep 18 13:11:48 1999
@@ -49,7 +49,7 @@
--- src/player/readrc.c.orig Wed Mar 1 09:42:44 2000
+++ src/player/readrc.c Fri Aug 4 23:24:03 2000
@@ -56,7 +56,7 @@
if ((rc = fopen (myrc2, "r")) == NULL) {
if ((rc = fopen (myrc, "r")) == NULL) {
#ifndef __EMX__
- if ((rc = fopen ("/etc/xmp.conf", "r")) == NULL) {
+ if ((rc = fopen ("/usr/local/etc/xmp.conf", "r")) == NULL) {
free (myrc);
return -1;
}
@@ -191,7 +191,7 @@
+ if ((rc = fopen (ETC_DIR "/xmp.conf", "r")) == NULL) {
#else
if ((rc = fopen ("xmp.conf", "r")) == NULL) {
#endif
@@ -202,7 +202,7 @@
myrc = malloc ((home ? strlen (home) : 0) + 20);
#ifndef __EMX__
sprintf (myrc, "%s/.xmp/modules.conf", home);
- parse_modconf (ctl, "/etc/xmp-modules.conf", crc, size);
+ parse_modconf (ctl, "/usr/local/etc/xmp-modules.conf", crc, size);
parse_modconf (ctl, myrc, crc, size);
free (myrc);
}
+ parse_modconf (ctl, ETC_DIR "/xmp-modules.conf", crc, size);
#else
sprintf (myrc, "%s\\.xmp\\modules.conf", home);
parse_modconf (ctl, "xmp-modules.conf", crc, size);

View File

@ -1,19 +1,11 @@
*** etc/Makefile.orig Sat Sep 18 14:29:28 1999
--- etc/Makefile Sat Sep 18 14:29:39 1999
***************
*** 21,27 ****
@if [ -f /etc/xmp-modules.conf]; then \
mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
fi
! $(INSTALL) -m644 xmp.conf xmp-modules.conf /etc
xmp.spec: xmp.spec.in ../Makefile.rules
cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@
--- 21,27 ----
@if [ -f /etc/xmp-modules.conf]; then \
mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
fi
! $(INSTALL) -m644 xmp.conf xmp-modules.conf $(PREFIX)/etc
xmp.spec: xmp.spec.in ../Makefile.rules
cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@
--- etc/Makefile.orig Wed Feb 2 22:20:34 2000
+++ etc/Makefile Fri Aug 4 23:49:51 2000
@@ -21,7 +21,7 @@
@if [ -f /etc/xmp-modules.conf ]; then \
mv -f /etc/xmp-modules.conf /etc/xmp-modules.conf.old; \
fi
- $(INSTALL) -m644 xmp.conf xmp-modules.conf /etc
+ $(INSTALL_DATA) xmp.conf xmp-modules.conf $(ETC_DIR)
xmp.spec: xmp.spec.in ../Makefile.rules
cat $@.in | sed 's/@VERSION@/$(VERSION)/g' > $@

View File

@ -1,21 +1,13 @@
*** Makefile.orig Sat Sep 18 15:34:54 1999
--- Makefile Sat Sep 18 15:35:29 1999
***************
*** 39,46 ****
install::
@echo
! @echo " Installation complete. To customize, copy /etc/xmp.conf to"
! @echo " \$$HOME/.xmp/xmp.conf and /etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
@echo
uninstall:
--- 39,46 ----
install::
@echo
! @echo " Installation complete. To customize, copy ${PREFIX}/etc/xmp.conf to"
! @echo " \$$HOME/.xmp/xmp.conf and ${PREFIX}/etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
@echo
uninstall:
--- Makefile.orig Sun May 7 03:41:24 2000
+++ Makefile Fri Aug 4 23:48:52 2000
@@ -42,8 +42,8 @@
install::
@echo
- @echo " Installation complete. To customize, copy /etc/xmp.conf to"
- @echo " \$$HOME/.xmp/xmp.conf and /etc/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
+ @echo " Installation complete. To customize, copy ${ETC_DIR}/xmp.conf to"
+ @echo " \$$HOME/.xmp/xmp.conf and ${ETC_DIR}/xmp-modules.conf to \$$HOME/.xmp/modules.conf"
@echo
@echo " Please report bugs to xmp-bugs@helllabs.org."
@echo

21
audio/xmp/files/patch-ad Normal file
View File

@ -0,0 +1,21 @@
--- Makefile.rules.in.orig Sun May 7 09:51:31 2000
+++ Makefile.rules.in Sat Aug 5 02:40:28 2000
@@ -7,14 +7,17 @@
exec_prefix= @prefix@
BIN_DIR = @bindir@
LIB_DIR = @libdir@
+ETC_DIR = @sysconfdir@
MAN_DIR = @mandir@/man1
CC = @CC@
-CFLAGS = -c @CFLAGS@ @DEFS@ @CINCS@
+CFLAGS = -c @CFLAGS@ @DEFS@ @CINCS@ -DETC_DIR=\"$(ETC_DIR)\"
LD = @CC@
LFLAGS = -o$@
RANLIB = @RANLIB@
INSTALL = @INSTALL@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_DATA = @INSTALL_DATA@
LIBS = @LIBS@ $(XLIBS)
SHELL = /bin/sh
PLATFORM= @PLATFORM@

13
audio/xmp/files/patch-ae Normal file
View File

@ -0,0 +1,13 @@
--- docs/Makefile.orig Thu Jan 20 06:49:20 2000
+++ docs/Makefile Sat Aug 5 02:44:20 2000
@@ -21,8 +21,8 @@
install:: docs
@echo Installing manpages in $(MAN_DIR)...
@[ -d $(MAN_DIR) ] || mkdir -p $(MAN_DIR)
- $(INSTALL) -m644 xmp.1 $(MAN_DIR)
+ $(INSTALL_DATA) xmp.1 $(MAN_DIR)
@if test "$(X_XMP)x" = xxmpx; then \
- $(INSTALL) -m644 $(X_XMP).1 $(MAN_DIR); \
+ $(INSTALL_DATA) $(X_XMP).1 $(MAN_DIR); \
fi

11
audio/xmp/files/patch-af Normal file
View File

@ -0,0 +1,11 @@
--- docs/xmp.1.orig Wed Mar 15 09:58:49 2000
+++ docs/xmp.1 Sat Aug 5 03:19:50 2000
@@ -225,7 +225,7 @@
Command line options \fB-M\fP and \fB-S\fP don\'t work correctly with xxmp\&.
.PP
.SH "FILES"
-\f(CW/etc/xmp\&.conf, /etc/xmp-modules\&.conf, $HOME/\&.xmp/xmp\&.conf,
+\f(CW%%PREFIX%%/etc/xmp\&.conf, %%PREFIX%%/etc/xmp-modules\&.conf, $HOME/\&.xmp/xmp\&.conf,
$HOME/\&.xmp/xmp-modules\&.conf\fP
.PP
.SH "AUTHOR"

11
audio/xmp/files/patch-ag Normal file
View File

@ -0,0 +1,11 @@
--- src/main/Makefile.orig Thu Jan 20 00:59:33 2000
+++ src/main/Makefile Sat Aug 5 02:43:15 2000
@@ -32,7 +32,7 @@
install:: $(BINS)
@echo Installing binaries in $(BIN_DIR)...
@[ -d $(BIN_DIR) ] || mkdir -p $(BIN_DIR)
- $(INSTALL) -s -m755 $(BINS) $(BIN_DIR)
+ $(INSTALL_PROGRAM) $(BINS) $(BIN_DIR)
$(OBJS): ../../Makefile.rules Makefile

15
audio/xmp/files/patch-ah Normal file
View File

@ -0,0 +1,15 @@
--- src/xmms/Makefile.orig Wed May 3 08:50:48 2000
+++ src/xmms/Makefile Sat Aug 5 02:45:42 2000
@@ -9,10 +9,10 @@
include ../../Makefile.rules
all: $(OBJS)
- gcc -shared -o libxmp.so $+ -L../../lib/ -lxmp
+ $(CC) -shared -o libxmp.so $+ -L../../lib/ -lxmp
install::
- $(INSTALL) -s -m755 libxmp.so `xmms-config --input-plugin-dir`
+ $(INSTALL_DATA) libxmp.so `xmms-config --input-plugin-dir`
$(OBJS): Makefile