* Take maintainership.

* Fix compilation with gcc 3.1; from Marc Espie <espie@openbsd.org>.
* Override variables with MAKE_ARGS instead of patching Makefile.
This commit is contained in:
Christian Weisgerber 2002-06-14 14:33:24 +00:00
parent 51d9e9ebf4
commit 9e93966b7c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61264
4 changed files with 19 additions and 12 deletions

View File

@ -1,4 +1,3 @@
# ex:ts=8
# New ports collection makefile for: bonk
# Date created: Jun 1, 2001
# Whom: ijliao
@ -11,6 +10,9 @@ PORTVERSION= 0.5
CATEGORIES= audio
MASTER_SITES= http://yoyo.cc.monash.edu.au/~pfh/bonk/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= naddy@FreeBSD.org
MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
PREFIX="${PREFIX}" INSTALL="${INSTALL_PROGRAM}"
.include <bsd.port.mk>

View File

@ -1,10 +0,0 @@
--- Makefile.orig Thu Jul 12 00:16:45 2001
+++ Makefile Thu Jul 12 00:17:05 2001
@@ -1,7 +1,4 @@
-PREFIX= /usr
-CXX= g++
-CXXFLAGS= -O3 -funroll-loops
INSTALL= install -c
# Uncomment this line for Linux and FreeBSD

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- bonk.cc.orig Fri Jun 14 16:18:52 2002
+++ bonk.cc Fri Jun 14 16:19:13 2002
@@ -38,6 +38,8 @@
#include <string>
#include <algorithm>
+using namespace std;
+
// Support from Linux and *BSD sound output
#if defined(__linux__)

View File

@ -1 +1,2 @@
@comment $FreeBSD$
bin/bonk