- Unbreak on 5.x
Approved by: adamw (mentor)
This commit is contained in:
parent
a2ca93df1c
commit
9e79d0a9c6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94444
@ -37,12 +37,6 @@ pre-everything::
|
||||
@${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500000
|
||||
BROKEN= "invalid C++"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKDIR} -type f -name Makefile | \
|
||||
${XARGS} -n 10 ${REINPLACE_CMD} -E -e \
|
||||
@ -65,4 +59,4 @@ post-patch:
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/L-Breeder ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
28
biology/L-Breeder/files/patch-Lsystem::Lstring.cpp
Normal file
28
biology/L-Breeder/files/patch-Lsystem::Lstring.cpp
Normal file
@ -0,0 +1,28 @@
|
||||
--- Lsystem/Lstring.cpp.orig Wed Aug 16 18:54:26 2000
|
||||
+++ Lsystem/Lstring.cpp Wed Nov 19 22:05:11 2003
|
||||
@@ -199,7 +199,7 @@
|
||||
|
||||
if (sscanf(the_text.c_str(),"%f",&temp)==1)
|
||||
return temp;
|
||||
- return sqrt(-1);
|
||||
+ return sqrtf(-1);
|
||||
|
||||
}
|
||||
|
||||
@@ -329,13 +329,13 @@
|
||||
float param;
|
||||
int conv,dummy;
|
||||
the_length=0;
|
||||
- if (the_pos==info_length()-1) return sqrt(-1);
|
||||
- if (bracketed_chars.find(the_text[the_pos])==string::npos) return sqrt(-1);
|
||||
+ if (the_pos==info_length()-1) return sqrt(-1.0);
|
||||
+ if (bracketed_chars.find(the_text[the_pos])==string::npos) return sqrt(-1.0);
|
||||
|
||||
conv=sscanf(&(the_text.data()[the_pos+1]),"(%f)%n",¶m,&the_length);
|
||||
if (conv==sscanf("","%n",&dummy)) {
|
||||
the_length=0;
|
||||
- return sqrt(-1);
|
||||
+ return sqrt(-1.0);
|
||||
} else {
|
||||
return param;
|
||||
};
|
25
biology/L-Breeder/files/patch-thinair::environ.h
Normal file
25
biology/L-Breeder/files/patch-thinair::environ.h
Normal file
@ -0,0 +1,25 @@
|
||||
--- thinair/environ.h.orig Wed Aug 16 17:08:27 2000
|
||||
+++ thinair/environ.h Wed Nov 19 21:54:56 2003
|
||||
@@ -35,17 +35,20 @@
|
||||
#include <minmax.h>
|
||||
#endif
|
||||
|
||||
- #if __GNUC__ >= 2 && __GNUC_MINOR__ >= 6 && defined( __cplusplus )
|
||||
+ #if ((__GNUC__ == 2 && __GNUC_MINOR__ >= 6) || __GNUC__ > 2) && defined( __cplusplus )
|
||||
#define _HAS_BOOL
|
||||
#define _STRING_CLASS
|
||||
- #if __GNUC__ >= 2 && __GNUC_MINOR__ < 7
|
||||
+ #define _ANSI_CPP_HEADERS
|
||||
+ #if __GNUC__ == 2 && __GNUC_MINOR__ < 7
|
||||
#define _STRING_HEADER <g++/String.h>
|
||||
#define _STRING String
|
||||
#else
|
||||
#define _STRING_HEADER <string>
|
||||
#define _STRING string
|
||||
#define _DIFFERING_RETURNS_ALLOWED
|
||||
+ #if __GNUC__ == 2
|
||||
#include <stl.h>
|
||||
+ #endif
|
||||
#endif
|
||||
#define _HAS_INT64
|
||||
|
Loading…
Reference in New Issue
Block a user