Update to 0.14.1

PR:		ports/82081
Submitted by:	ports fury
This commit is contained in:
Patrick Li 2005-06-10 08:11:44 +00:00
parent 757f03677d
commit 9e4ffc6932
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=137162
10 changed files with 130 additions and 286 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= screem
PORTVERSION= 0.12.1
PORTREVISION= 3
PORTVERSION= 0.14.1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -15,42 +14,24 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice GNOME/GTK-based HTML editor
LIB_DEPENDS+= neon.24:${PORTSDIR}/www/neon \
croco-${CROCO_VERSION}.3:${PORTSDIR}/textproc/libcroco \
dbus-1.1:${PORTSDIR}/devel/dbus
LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus \
croco-0.6.3:${PORTSDIR}/textproc/libcroco
USE_GMAKE= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= desktopfileutils gnomehack gnomeprefix gnometarget \
gtksourceview intlhack libgnomeprintui libgnomeui libgtkhtml
USE_XPM= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml \
gtksourceview intlhack desktopfileutils
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_OMF= yes
GCONF_SCHEMAS= screem.schemas
CROCO_VERSION= 0.6
.if !defined(WITHOUT_OPENSSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl
.endif
USE_PERL5= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --without-included-neon
post-patch:
@${REINPLACE_CMD} -e 's|\$${DATADIRNAME}/\$${PACKAGE}/pixmaps|\$${DATADIRNAME}/gnome/\$${PACKAGE}/pixmaps|g' \
${WRKSRC}/configure
post-configure:
@${REINPLACE_CMD} -e 's|\/\* #undef HAVE_LIMITS_H \*\/|#define HAVE_LIMITS_H 1|g' ${WRKSRC}/config.h
# HACK: This allows test builds into a temporary directory, but in the REAL world,
# gconf would have created this directory.
pre-install:
@${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults
@${REINPLACE_CMD} -e 's|$${DATADIRNAME}/$${PACKAGE}|$${DATADIRNAME}/gnome/$${PACKAGE}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\&\& make|\&\& $$(MAKE)|g' ${WRKSRC}/tests/Makefile.in
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (screem-0.12.1.tar.gz) = 4d1f50deee2888f0ac094cb3df61f1ad
SIZE (screem-0.12.1.tar.gz) = 4310597
MD5 (screem-0.14.1.tar.gz) = b23bf53698df79477f83f3d66b6eab0d
SIZE (screem-0.14.1.tar.gz) = 3947396

View File

@ -1,22 +0,0 @@
--- plugins/uploadWizard/Makefile.in.orig Tue Nov 23 17:42:18 2004
+++ plugins/uploadWizard/Makefile.in Tue Nov 23 17:44:26 2004
@@ -58,7 +58,7 @@
"$(DESTDIR)$(gladedir)"
plugins_execLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(plugins_exec_LTLIBRARIES)
-am__DEPENDENCIES_1 = $(neon_dir)/*.lo
+am__DEPENDENCIES_1 =
am__DEPENDENCIES_2 =
uploadWizard_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_2)
@@ -331,8 +331,8 @@
uploadWizard.h \
vfsdriver.c
-uploadWizard_la_LDFLAGS = -avoid-version -module $(NEON_CFLAGS)
-uploadWizard_la_LIBADD = $(NEONOBJS) $(NEON_LIBS)
+uploadWizard_la_LDFLAGS = -avoid-version -module
+uploadWizard_la_LIBADD =
config_h = $(top_builddir)/config.h
obj_ext = o
all: all-am

View File

@ -1,43 +0,0 @@
--- src/screem-application.c.orig Fri Apr 8 01:54:41 2005
+++ src/screem-application.c Fri Apr 8 02:15:23 2005
@@ -383,7 +383,7 @@ void screem_application_startup( ScreemA
if( conn ) {
dbus_connection_setup_with_g_main( conn, NULL );
- if( dbus_bus_service_exists( conn, "org.screem",
+ if( dbus_bus_name_has_owner( conn, "org.screem",
&error ) ) {
message = dbus_message_new_method_call(
"org.screem",
@@ -392,9 +392,10 @@ void screem_application_startup( ScreemA
"Open" );
if( start_files ) {
while( *start_files ) {
- dbus_message_append_iter_init( message,
+ dbus_message_iter_init_append( message,
&it );
- dbus_message_iter_append_string( &it,
+ dbus_message_iter_append_basic( &it,
+ DBUS_TYPE_STRING,
*start_files );
start_files ++;
}
@@ -407,7 +408,7 @@ void screem_application_startup( ScreemA
return;
} else {
- if( dbus_bus_acquire_service( conn, "org.screem",
+ if( dbus_bus_request_name( conn, "org.screem",
0, &error ) != -1 ) {
/* acquired, listen in for
* org.screem stuff */
@@ -1522,7 +1523,8 @@ static DBusHandlerResult screem_applicat
dbus_message_iter_init( message, &it );
add = ( ! priv->start_files );
- while( ( uri = dbus_message_iter_get_string( &it ) ) ) {
+ while( dbus_message_iter_get_arg_type( &it ) == DBUS_TYPE_STRING ) {
+ dbus_message_iter_get_basic( &it, &uri );
priv->start_files = g_slist_prepend( priv->start_files, uri );
if( ! dbus_message_iter_next( &it ) ) {
break;

View File

@ -1,10 +1,8 @@
bin/screem
lib/screem/plugins/colourWizard.so
lib/screem/plugins/cssWizard.so
lib/screem/plugins/css_wizard.so
lib/screem/plugins/entityWizard.so
lib/screem/plugins/formWizard.so
lib/screem/plugins/imageWizard.so
lib/screem/plugins/linkWizard.so
lib/screem/plugins/object_wizard.so
lib/screem/plugins/ssiWizard.so
@ -61,32 +59,19 @@ share/gnome/help/screem/C/figures/tree.png
share/gnome/help/screem/C/legal.xml
share/gnome/help/screem/C/screem.xml
share/gnome/mime-info/screem.keys
share/mime/application/vnd.wap.wmlc.xml
share/mime/application/vnd.wap.wmlscriptc.xml
share/mime/application/x-screem-tag-tree.xml
share/mime/application/x-screem.xml
share/mime/application/xhtml+xml.xml
share/mime/image/vnd.wap.wbmp.xml
share/mime/packages/screem.xml
share/mime/text/html.xml
share/mime/text/vnd.wap.wml.xml
share/mime/text/vnd.wap.wmlscript.xml
share/mime/text/x-component.xml
share/mime/text/x-javascript.xml
share/gnome/omf/screem/screem-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/screem/screem-C.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/screem.png
share/gnome/pixmaps/screem/splash/splash.png
share/gnome/pixmaps/screem.png
share/gnome/screem/dtd/HTMLlat1.ent
share/gnome/screem/dtd/HTMLspecial.ent
share/gnome/screem/dtd/HTMLsymbols.ent
share/gnome/screem/dtd/catalog
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Fframeset.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Floose.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Fstrict.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-frameset.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-strict.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-transitional.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Fframeset.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Floose.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Fstrict.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-frameset.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-strict.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-transitional.dtd
share/gnome/screem/dtd/screem-tagtree-config.dtd
share/gnome/screem/dtd/screem-tagtree.dtd
share/gnome/screem/dtd/xhtml-lat1.ent
@ -95,13 +80,14 @@ share/gnome/screem/dtd/xhtml-symbol.ent
share/gnome/screem/features.xml
share/gnome/screem/glade/css-wizard.glade
share/gnome/screem/glade/entityWizard.glade
share/gnome/screem/glade/imageWizard.glade
share/gnome/screem/glade/linkwizard.glade
share/gnome/screem/glade/object-wizard.glade
share/gnome/screem/glade/screem.glade
share/gnome/screem/glade/ssiwizard.glade
share/gnome/screem/glade/tablewizard.glade
share/gnome/screem/glade/uploadwizard.glade
share/gnome/screem/helpers/Tidy/TidyHTML.desktop
share/gnome/screem/helpers/Tidy/TidyXML.desktop
share/gnome/screem/hints/screem_hints.txt
share/gnome/screem/hints/screem_hints_fr.txt
share/gnome/screem/hints/screem_hints_pt_BR.txt
@ -164,7 +150,7 @@ share/gnome/screem/pixmaps/text.xpm
share/gnome/screem/pixmaps/th.xpm
share/gnome/screem/pixmaps/todo.png
share/gnome/screem/pixmaps/tr.xpm
share/gnome/screem/resources/Images/made.jpg
share/gnome/screem/resources/Images/made.png
share/gnome/screem/resources/Javascript/linktitle.js
share/gnome/screem/resources/Javascript/preload.js
share/gnome/screem/resources/Javascript/rollover.js
@ -197,35 +183,55 @@ share/locale/no/LC_MESSAGES/screem.mo
share/locale/pl/LC_MESSAGES/screem.mo
share/locale/pt_BR/LC_MESSAGES/screem.mo
share/locale/ru/LC_MESSAGES/screem.mo
share/locale/rw/LC_MESSAGES/screem.mo
share/locale/sk/LC_MESSAGES/screem.mo
share/locale/sv/LC_MESSAGES/screem.mo
share/locale/tr/LC_MESSAGES/screem.mo
share/locale/uk/LC_MESSAGES/screem.mo
share/locale/vi/LC_MESSAGES/screem.mo
share/locale/zh_CN/LC_MESSAGES/screem.mo
@dirrm lib/screem/plugins
@dirrm lib/screem
share/mime/application/vnd.wap.wmlc.xml
share/mime/application/vnd.wap.wmlscriptc.xml
share/mime/application/x-php-source.xml
share/mime/application/x-screem-tag-tree.xml
share/mime/application/x-screem.xml
share/mime/application/xhtml+xml.xml
share/mime/image/vnd.wap.wbmp.xml
share/mime/packages/screem.xml
share/mime/text/actionscript.xml
share/mime/text/html.xml
share/mime/text/javascript.xml
share/mime/text/vnd.wap.wml.xml
share/mime/text/vnd.wap.wmlscript.xml
share/mime/text/x-actionscript.xml
share/mime/text/x-component.xml
share/mime/text/x-javascript.xml
share/mime/text/x-php-source.xml
share/mime/text/x-php.xml
@dirrm share/gnome/screem/ui
@dirrm share/gnome/screem/tagtrees
@dirrm share/gnome/screem/resources/Templates
@dirrm share/gnome/screem/resources/PHP3
@dirrm share/gnome/screem/resources/Javascript
@dirrm share/gnome/screem/resources/Images
@dirrm share/gnome/screem/resources/HTML
@dirrm share/gnome/screem/resources/Applets
@dirrm share/gnome/screem/resources
@dirrm share/gnome/screem/pixmaps
@dirrm share/gnome/screem/hints
@dirrm share/gnome/screem/helpers/Tidy
@dirrm share/gnome/screem/helpers
@dirrm share/gnome/screem/glade
@dirrm share/gnome/screem/dtd
@dirrm share/gnome/screem
@dirrm share/gnome/pixmaps/screem/splash
@dirrm share/gnome/pixmaps/screem
@dirrm share/gnome/omf/screem
@dirrm share/gnome/help/screem/C/figures
@dirrm share/gnome/help/screem/C
@dirrm share/gnome/help/screem
@dirrm share/gnome/omf/screem
@dirrm share/gnome/pixmaps/screem/splash
@dirrm share/gnome/pixmaps/screem
@dirrm share/gnome/screem/dtd
@dirrm share/gnome/screem/glade
@dirrm share/gnome/screem/hints
@dirrm share/gnome/screem/pixmaps
@dirrm share/gnome/screem/resources/Applets
@dirrm share/gnome/screem/resources/HTML
@dirrm share/gnome/screem/resources/Images
@dirrm share/gnome/screem/resources/Javascript
@dirrm share/gnome/screem/resources/PHP3
@dirrm share/gnome/screem/resources/Templates
@dirrm share/gnome/screem/resources
@dirrm share/gnome/screem/tagtrees
@dirrm share/gnome/screem/ui
@dirrm share/gnome/screem
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/screem/screem-C.omf 2>/dev/null || /usr/bin/true
@dirrm lib/screem/plugins
@dirrm lib/screem
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true

View File

@ -6,8 +6,7 @@
#
PORTNAME= screem
PORTVERSION= 0.12.1
PORTREVISION= 3
PORTVERSION= 0.14.1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -15,42 +14,24 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice GNOME/GTK-based HTML editor
LIB_DEPENDS+= neon.24:${PORTSDIR}/www/neon \
croco-${CROCO_VERSION}.3:${PORTSDIR}/textproc/libcroco \
dbus-1.1:${PORTSDIR}/devel/dbus
LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus \
croco-0.6.3:${PORTSDIR}/textproc/libcroco
USE_GMAKE= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= desktopfileutils gnomehack gnomeprefix gnometarget \
gtksourceview intlhack libgnomeprintui libgnomeui libgtkhtml
USE_XPM= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml \
gtksourceview intlhack desktopfileutils
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_OMF= yes
GCONF_SCHEMAS= screem.schemas
CROCO_VERSION= 0.6
.if !defined(WITHOUT_OPENSSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl
.endif
USE_PERL5= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --without-included-neon
post-patch:
@${REINPLACE_CMD} -e 's|\$${DATADIRNAME}/\$${PACKAGE}/pixmaps|\$${DATADIRNAME}/gnome/\$${PACKAGE}/pixmaps|g' \
${WRKSRC}/configure
post-configure:
@${REINPLACE_CMD} -e 's|\/\* #undef HAVE_LIMITS_H \*\/|#define HAVE_LIMITS_H 1|g' ${WRKSRC}/config.h
# HACK: This allows test builds into a temporary directory, but in the REAL world,
# gconf would have created this directory.
pre-install:
@${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults
@${REINPLACE_CMD} -e 's|$${DATADIRNAME}/$${PACKAGE}|$${DATADIRNAME}/gnome/$${PACKAGE}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|\&\& make|\&\& $$(MAKE)|g' ${WRKSRC}/tests/Makefile.in
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (screem-0.12.1.tar.gz) = 4d1f50deee2888f0ac094cb3df61f1ad
SIZE (screem-0.12.1.tar.gz) = 4310597
MD5 (screem-0.14.1.tar.gz) = b23bf53698df79477f83f3d66b6eab0d
SIZE (screem-0.14.1.tar.gz) = 3947396

View File

@ -1,22 +0,0 @@
--- plugins/uploadWizard/Makefile.in.orig Tue Nov 23 17:42:18 2004
+++ plugins/uploadWizard/Makefile.in Tue Nov 23 17:44:26 2004
@@ -58,7 +58,7 @@
"$(DESTDIR)$(gladedir)"
plugins_execLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(plugins_exec_LTLIBRARIES)
-am__DEPENDENCIES_1 = $(neon_dir)/*.lo
+am__DEPENDENCIES_1 =
am__DEPENDENCIES_2 =
uploadWizard_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_2)
@@ -331,8 +331,8 @@
uploadWizard.h \
vfsdriver.c
-uploadWizard_la_LDFLAGS = -avoid-version -module $(NEON_CFLAGS)
-uploadWizard_la_LIBADD = $(NEONOBJS) $(NEON_LIBS)
+uploadWizard_la_LDFLAGS = -avoid-version -module
+uploadWizard_la_LIBADD =
config_h = $(top_builddir)/config.h
obj_ext = o
all: all-am

View File

@ -1,43 +0,0 @@
--- src/screem-application.c.orig Fri Apr 8 01:54:41 2005
+++ src/screem-application.c Fri Apr 8 02:15:23 2005
@@ -383,7 +383,7 @@ void screem_application_startup( ScreemA
if( conn ) {
dbus_connection_setup_with_g_main( conn, NULL );
- if( dbus_bus_service_exists( conn, "org.screem",
+ if( dbus_bus_name_has_owner( conn, "org.screem",
&error ) ) {
message = dbus_message_new_method_call(
"org.screem",
@@ -392,9 +392,10 @@ void screem_application_startup( ScreemA
"Open" );
if( start_files ) {
while( *start_files ) {
- dbus_message_append_iter_init( message,
+ dbus_message_iter_init_append( message,
&it );
- dbus_message_iter_append_string( &it,
+ dbus_message_iter_append_basic( &it,
+ DBUS_TYPE_STRING,
*start_files );
start_files ++;
}
@@ -407,7 +408,7 @@ void screem_application_startup( ScreemA
return;
} else {
- if( dbus_bus_acquire_service( conn, "org.screem",
+ if( dbus_bus_request_name( conn, "org.screem",
0, &error ) != -1 ) {
/* acquired, listen in for
* org.screem stuff */
@@ -1522,7 +1523,8 @@ static DBusHandlerResult screem_applicat
dbus_message_iter_init( message, &it );
add = ( ! priv->start_files );
- while( ( uri = dbus_message_iter_get_string( &it ) ) ) {
+ while( dbus_message_iter_get_arg_type( &it ) == DBUS_TYPE_STRING ) {
+ dbus_message_iter_get_basic( &it, &uri );
priv->start_files = g_slist_prepend( priv->start_files, uri );
if( ! dbus_message_iter_next( &it ) ) {
break;

View File

@ -1,10 +1,8 @@
bin/screem
lib/screem/plugins/colourWizard.so
lib/screem/plugins/cssWizard.so
lib/screem/plugins/css_wizard.so
lib/screem/plugins/entityWizard.so
lib/screem/plugins/formWizard.so
lib/screem/plugins/imageWizard.so
lib/screem/plugins/linkWizard.so
lib/screem/plugins/object_wizard.so
lib/screem/plugins/ssiWizard.so
@ -61,32 +59,19 @@ share/gnome/help/screem/C/figures/tree.png
share/gnome/help/screem/C/legal.xml
share/gnome/help/screem/C/screem.xml
share/gnome/mime-info/screem.keys
share/mime/application/vnd.wap.wmlc.xml
share/mime/application/vnd.wap.wmlscriptc.xml
share/mime/application/x-screem-tag-tree.xml
share/mime/application/x-screem.xml
share/mime/application/xhtml+xml.xml
share/mime/image/vnd.wap.wbmp.xml
share/mime/packages/screem.xml
share/mime/text/html.xml
share/mime/text/vnd.wap.wml.xml
share/mime/text/vnd.wap.wmlscript.xml
share/mime/text/x-component.xml
share/mime/text/x-javascript.xml
share/gnome/omf/screem/screem-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/screem/screem-C.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/screem.png
share/gnome/pixmaps/screem/splash/splash.png
share/gnome/pixmaps/screem.png
share/gnome/screem/dtd/HTMLlat1.ent
share/gnome/screem/dtd/HTMLspecial.ent
share/gnome/screem/dtd/HTMLsymbols.ent
share/gnome/screem/dtd/catalog
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Fframeset.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Floose.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Fstrict.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-frameset.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-strict.dtd
share/gnome/screem/dtd/http:%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-transitional.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Fframeset.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Floose.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fhtml4%2Fstrict.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-frameset.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-strict.dtd
share/gnome/screem/dtd/http%3A%2F%2Fwww.w3.org%2FTR%2Fxhtml1%2FDTD%2Fxhtml1-transitional.dtd
share/gnome/screem/dtd/screem-tagtree-config.dtd
share/gnome/screem/dtd/screem-tagtree.dtd
share/gnome/screem/dtd/xhtml-lat1.ent
@ -95,13 +80,14 @@ share/gnome/screem/dtd/xhtml-symbol.ent
share/gnome/screem/features.xml
share/gnome/screem/glade/css-wizard.glade
share/gnome/screem/glade/entityWizard.glade
share/gnome/screem/glade/imageWizard.glade
share/gnome/screem/glade/linkwizard.glade
share/gnome/screem/glade/object-wizard.glade
share/gnome/screem/glade/screem.glade
share/gnome/screem/glade/ssiwizard.glade
share/gnome/screem/glade/tablewizard.glade
share/gnome/screem/glade/uploadwizard.glade
share/gnome/screem/helpers/Tidy/TidyHTML.desktop
share/gnome/screem/helpers/Tidy/TidyXML.desktop
share/gnome/screem/hints/screem_hints.txt
share/gnome/screem/hints/screem_hints_fr.txt
share/gnome/screem/hints/screem_hints_pt_BR.txt
@ -164,7 +150,7 @@ share/gnome/screem/pixmaps/text.xpm
share/gnome/screem/pixmaps/th.xpm
share/gnome/screem/pixmaps/todo.png
share/gnome/screem/pixmaps/tr.xpm
share/gnome/screem/resources/Images/made.jpg
share/gnome/screem/resources/Images/made.png
share/gnome/screem/resources/Javascript/linktitle.js
share/gnome/screem/resources/Javascript/preload.js
share/gnome/screem/resources/Javascript/rollover.js
@ -197,35 +183,55 @@ share/locale/no/LC_MESSAGES/screem.mo
share/locale/pl/LC_MESSAGES/screem.mo
share/locale/pt_BR/LC_MESSAGES/screem.mo
share/locale/ru/LC_MESSAGES/screem.mo
share/locale/rw/LC_MESSAGES/screem.mo
share/locale/sk/LC_MESSAGES/screem.mo
share/locale/sv/LC_MESSAGES/screem.mo
share/locale/tr/LC_MESSAGES/screem.mo
share/locale/uk/LC_MESSAGES/screem.mo
share/locale/vi/LC_MESSAGES/screem.mo
share/locale/zh_CN/LC_MESSAGES/screem.mo
@dirrm lib/screem/plugins
@dirrm lib/screem
share/mime/application/vnd.wap.wmlc.xml
share/mime/application/vnd.wap.wmlscriptc.xml
share/mime/application/x-php-source.xml
share/mime/application/x-screem-tag-tree.xml
share/mime/application/x-screem.xml
share/mime/application/xhtml+xml.xml
share/mime/image/vnd.wap.wbmp.xml
share/mime/packages/screem.xml
share/mime/text/actionscript.xml
share/mime/text/html.xml
share/mime/text/javascript.xml
share/mime/text/vnd.wap.wml.xml
share/mime/text/vnd.wap.wmlscript.xml
share/mime/text/x-actionscript.xml
share/mime/text/x-component.xml
share/mime/text/x-javascript.xml
share/mime/text/x-php-source.xml
share/mime/text/x-php.xml
@dirrm share/gnome/screem/ui
@dirrm share/gnome/screem/tagtrees
@dirrm share/gnome/screem/resources/Templates
@dirrm share/gnome/screem/resources/PHP3
@dirrm share/gnome/screem/resources/Javascript
@dirrm share/gnome/screem/resources/Images
@dirrm share/gnome/screem/resources/HTML
@dirrm share/gnome/screem/resources/Applets
@dirrm share/gnome/screem/resources
@dirrm share/gnome/screem/pixmaps
@dirrm share/gnome/screem/hints
@dirrm share/gnome/screem/helpers/Tidy
@dirrm share/gnome/screem/helpers
@dirrm share/gnome/screem/glade
@dirrm share/gnome/screem/dtd
@dirrm share/gnome/screem
@dirrm share/gnome/pixmaps/screem/splash
@dirrm share/gnome/pixmaps/screem
@dirrm share/gnome/omf/screem
@dirrm share/gnome/help/screem/C/figures
@dirrm share/gnome/help/screem/C
@dirrm share/gnome/help/screem
@dirrm share/gnome/omf/screem
@dirrm share/gnome/pixmaps/screem/splash
@dirrm share/gnome/pixmaps/screem
@dirrm share/gnome/screem/dtd
@dirrm share/gnome/screem/glade
@dirrm share/gnome/screem/hints
@dirrm share/gnome/screem/pixmaps
@dirrm share/gnome/screem/resources/Applets
@dirrm share/gnome/screem/resources/HTML
@dirrm share/gnome/screem/resources/Images
@dirrm share/gnome/screem/resources/Javascript
@dirrm share/gnome/screem/resources/PHP3
@dirrm share/gnome/screem/resources/Templates
@dirrm share/gnome/screem/resources
@dirrm share/gnome/screem/tagtrees
@dirrm share/gnome/screem/ui
@dirrm share/gnome/screem
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/screem/screem-C.omf 2>/dev/null || /usr/bin/true
@dirrm lib/screem/plugins
@dirrm lib/screem
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true