Update to 4.6

The most important changes are described in the MIGRATING document:
- https://modules.readthedocs.io/en/v4.6.0/MIGRATING.html

Release notes:
- https://modules.readthedocs.io/en/v4.6.0/NEWS.html
- https://timeline.noticeable.io/cbzeG7wTvAIqj21zbUmx/posts/modules-4-6-0-released

PR:		249978
Submitted by:	Matthieu Volat <mazhe@alkumuna.eu>
This commit is contained in:
Mateusz Piotrowski 2020-10-02 19:18:40 +00:00
parent e3fdaa3a28
commit 9e034b4c83
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=551226
13 changed files with 130 additions and 414 deletions

View File

@ -5,6 +5,17 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20201002:
AFFECTS: users of sysutils/modules
AUTHOR: 0mp@FreeBSD.org
The upstream developers of the Modules port encourage users to consult
the MIGRATING document, which describes the major changes occurring between
versions of Modules. It provides an overview of the new features and changed
behaviors that will be encountered when upgrading:
https://modules.readthedocs.io/en/v4.6.0/MIGRATING.html
20200930:
AFFECTS: users of sysutils/syslog-ng32[789]
AUTHOR: cy@FreeBSD.org

View File

@ -2,29 +2,33 @@
# $FreeBSD$
PORTNAME= modules
PORTVERSION= 3.2.10
PORTREVISION= 1
PORTVERSION= 4.6.0
CATEGORIES= sysutils tcl
MASTER_SITES= SF/${PORTNAME}/Modules/${PORTNAME}-${PORTVERSION}
MASTER_SITES= https://github.com/cea-hpc/modules/releases/download/v${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Dynamic modification of a user environment
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING.GPLv2
USES= tcl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-x \
--with-version-path=${PREFIX}/Modules/versions \
--mandir=${MANPREFIX}/man \
--with-tcl-ver=${TCL_VER:S/.//} \
--with-tcl-inc=${TCL_INCLUDEDIR} \
--with-tcl-lib=${LOCALBASE}/lib \
--with-tclx-ver=${TCL_VER:S/.//}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR} \
bash:shells/bash
USES= gmake python:env shebangfix tar:bzip2 tcl
GNU_CONFIGURE= yes
GNU_CONFIGURE_PREFIX= ${PREFIX}/Modules
CONFIGURE_SHELL= ${LOCALBASE}/bin/bash
CONFIGURE_ARGS= --disable-compat-version \
--enable-versioning \
--with-python="${PYTHON_CMD}"
PLIST_SUB= MODULES_VERSION=${PORTVERSION}
post-extract:
${MV} ${WRKSRC}/doc/modulefile.4.in ${WRKSRC}/doc/modulefile.5.in
${MV} ${WRKSRC}/doc/build/modulefile.4 ${WRKSRC}/doc/build/modulefile.5
post-install:
@${STRIP_CMD} ${STAGEDIR}${GNU_CONFIGURE_PREFIX}/${PORTVERSION}/lib/libtclenvmodules.so
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (modules-3.2.10.tar.gz) = fb05c82a83477805a1d97737a9f0ca0db23f69b7bce504f1609ba99477b03955
SIZE (modules-3.2.10.tar.gz) = 419970
TIMESTAMP = 1601457747
SHA256 (modules-4.6.0.tar.bz2) = 616f994384adf4faf91df7d8b7ae2dab5bad20d642509c1a8e189e159968f911
SIZE (modules-4.6.0.tar.bz2) = 1589367

View File

@ -1,121 +0,0 @@
--- Makefile.in.orig 2012-12-19 17:02:26 UTC
+++ Makefile.in
@@ -74,7 +74,7 @@ CONFIG_CLEAN_FILES = modules.lsm .spec e
ext/common/.profile
CONFIG_CLEAN_VPATH_FILES =
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)" \
- "$(DESTDIR)$(man4dir)"
+ "$(DESTDIR)$(man5dir)"
PROGRAMS = $(bin_PROGRAMS)
am_modulecmd_OBJECTS = modulecmd-ModuleCmd_Avail.$(OBJEXT) \
modulecmd-ModuleCmd_Clear.$(OBJEXT) \
@@ -150,7 +150,7 @@ am__uninstall_files_from_dir = { \
$(am__cd) "$$dir" && rm -f $$files; }; \
}
man1dir = $(mandir)/man1
-man4dir = $(mandir)/man4
+man5dir = $(mandir)/man5
NROFF = nroff
MANS = $(man_MANS)
RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
@@ -320,7 +320,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
ACLOCAL_AMFLAGS = -I config
-man_MANS = doc/module.1 doc/modulefile.4
+man_MANS = doc/module.1 doc/modulefile.5
SUBDIRS = . init modulefiles @EXTDIR@ doc
DIST_SUBDIRS = . init modulefiles etc ext doc
SOURCES_H = modules_def.h getopt.h config.h
@@ -1087,10 +1087,10 @@ uninstall-man1:
} | sed -e 's,.*/,,;h;s,.*\.,,;s,^[^1][0-9a-z]*$$,1,;x' \
-e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,'`; \
dir='$(DESTDIR)$(man1dir)'; $(am__uninstall_files_from_dir)
-install-man4: $(man_MANS)
+install-man5: $(man_MANS)
@$(NORMAL_INSTALL)
- test -z "$(man4dir)" || $(MKDIR_P) "$(DESTDIR)$(man4dir)"
- @list=''; test -n "$(man4dir)" || exit 0; \
+ test -z "$(man5dir)" || $(MKDIR_P) "$(DESTDIR)$(man5dir)"
+ @list=''; test -n "$(man5dir)" || exit 0; \
{ for i in $$list; do echo "$$i"; done; \
l2='$(man_MANS)'; for i in $$l2; do echo "$$i"; done | \
sed -n '/\.4[a-z]*$$/p'; \
@@ -1103,26 +1103,26 @@ install-man4: $(man_MANS)
sed 'N;N;s,\n, ,g' | { \
list=; while read file base inst; do \
if test "$$base" = "$$inst"; then list="$$list $$file"; else \
- echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man4dir)/$$inst'"; \
- $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man4dir)/$$inst" || exit $$?; \
+ echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man5dir)/$$inst'"; \
+ $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man5dir)/$$inst" || exit $$?; \
fi; \
done; \
for i in $$list; do echo "$$i"; done | $(am__base_list) | \
while read files; do \
test -z "$$files" || { \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(man4dir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(man4dir)" || exit $$?; }; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(man5dir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(man5dir)" || exit $$?; }; \
done; }
-uninstall-man4:
+uninstall-man5:
@$(NORMAL_UNINSTALL)
- @list=''; test -n "$(man4dir)" || exit 0; \
+ @list=''; test -n "$(man5dir)" || exit 0; \
files=`{ for i in $$list; do echo "$$i"; done; \
l2='$(man_MANS)'; for i in $$l2; do echo "$$i"; done | \
sed -n '/\.4[a-z]*$$/p'; \
} | sed -e 's,.*/,,;h;s,.*\.,,;s,^[^4][0-9a-z]*$$,4,;x' \
-e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,'`; \
- dir='$(DESTDIR)$(man4dir)'; $(am__uninstall_files_from_dir)
+ dir='$(DESTDIR)$(man5dir)'; $(am__uninstall_files_from_dir)
# This directory's subdirectories are mostly independent; you can cd
# into them and run `make' without going through this Makefile.
@@ -1498,7 +1498,7 @@ check: check-recursive
all-am: Makefile $(PROGRAMS) $(MANS) config.h
installdirs: installdirs-recursive
installdirs-am:
- for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man4dir)"; do \
+ for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man5dir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-recursive
@@ -1570,7 +1570,7 @@ install-info: install-info-recursive
install-info-am:
-install-man: install-man1 install-man4
+install-man: install-man1 install-man5
install-pdf: install-pdf-recursive
@@ -1603,7 +1603,7 @@ ps-am:
uninstall-am: uninstall-binPROGRAMS uninstall-man
-uninstall-man: uninstall-man1 uninstall-man4
+uninstall-man: uninstall-man1 uninstall-man5
.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) all check-am \
ctags-recursive install-am install-strip tags-recursive
@@ -1619,14 +1619,14 @@ uninstall-man: uninstall-man1 uninstall-
info-am install install-am install-binPROGRAMS install-data \
install-data-am install-dvi install-dvi-am install-exec \
install-exec-am install-html install-html-am install-info \
- install-info-am install-man install-man1 install-man4 \
+ install-info-am install-man install-man1 install-man5 \
install-pdf install-pdf-am install-ps install-ps-am \
install-strip installcheck installcheck-am installdirs \
installdirs-am maintainer-clean maintainer-clean-generic \
mostlyclean mostlyclean-compile mostlyclean-generic pdf pdf-am \
ps ps-am tags tags-recursive uninstall uninstall-am \
uninstall-binPROGRAMS uninstall-man uninstall-man1 \
- uninstall-man4
+ uninstall-man5
test: check-local

View File

@ -1,21 +0,0 @@
--- cmdModule.c.orig 2016-08-09 09:37:36 UTC
+++ cmdModule.c
@@ -640,8 +640,16 @@ int Execute_TclFile( Tcl_Interp *interp
case TCL_OK: gotPartial = 0;
continue; /** while **/
- case TCL_ERROR: interp->errorLine = ((linenum-1)-gotPartial) +
- interp->errorLine;
+ case TCL_ERROR:
+#if (TCL_MAJOR_VERSION > 8) \
+ || (TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION >= 6)
+ Tcl_SetErrorLine(
+ interp,
+ ((linenum-1)-gotPartial) + Tcl_GetErrorLine(interp));
+#else
+ interp->errorLine =
+ ((linenum-1)-gotPartial) + interp->errorLine;
+#endif
/* FALLTHROUGH */
case TCL_LEVEL0_RETURN:

View File

@ -1,62 +0,0 @@
--- configure.orig 2012-12-19 17:02:25 UTC
+++ configure
@@ -1480,7 +1480,7 @@ Optional Packages:
specify a pattern for trace [[no]]
--with-tcl=<dir> directory containing tcl configuration
(tclConfig.sh) [[searches]]
- --with-tcl-ver=X.Y Tcl version to use [[search]]
+ --with-tcl-ver=XY Tcl version to use [[search]]
--with-tcl-lib=<dir> directory containing tcl libraries (libtclX.Y)
[[none]]
--with-tcl-inc=<dir> directory containing tcl include files
@@ -1518,7 +1518,7 @@ PREFIX/Modules/($MODULES_VERSION/ if mod
init/
man/
man1/
- man4/
+ man5/
modulefiles/
PREFIX/Modules/
modulefiles/
@@ -7099,9 +7099,9 @@ else
em_cv_tclver=${with_tclver}
fi #}}
- tclver=`echo $em_cv_tclver | sed -n -e '/[0-9]\.[0-9]/p'`
+ tclver=`echo $em_cv_tclver | sed -n -e '/[0-9][0-9]/p'`
if test x"$tclver" = x ; then #{
- as_fn_error $? "Must specify version (X.Y) if using this option" "$LINENO" 5
+ as_fn_error $? "Must specify version (XY) if using this option" "$LINENO" 5
fi #}
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${em_cv_tclver}" >&5
$as_echo "${em_cv_tclver}" >&6; }
@@ -7375,9 +7375,9 @@ else
em_cv_tclxver=${with_tclxver}
fi #}}
- tclxver=`echo $em_cv_tclxver | sed -n -e '/[0-9]\.[0-9]/p'`
+ tclxver=`echo $em_cv_tclxver | sed -n -e '/[0-9][0-9]/p'`
if test x"$tclxver" = x ; then #{
- as_fn_error $? "Must specify version (X.Y) if using this option" "$LINENO" 5
+ as_fn_error $? "Must specify version (XY) if using this option" "$LINENO" 5
fi #}
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using ${em_cv_tclxver}" >&5
$as_echo "using ${em_cv_tclxver}" >&6; }
@@ -7657,7 +7657,7 @@ else
EXTDIR="etc"
fi
-ac_config_files="$ac_config_files Makefile modules.lsm .spec doc/Makefile init/Makefile init/.modulespath doc/module.1 doc/modulefile.4 etc/Makefile etc/add.modules etc/mkroot etc/skel/.cshrc etc/skel/.login etc/skel/.kshenv etc/skel/.profile etc/global/csh.cshrc etc/global/csh.login etc/global/csh.modules etc/global/bashrc etc/global/profile etc/global/profile.modules ext/Makefile ext/add.ext ext/mkroot ext/common/.cshrc ext/common/.login ext/common/.kshenv ext/common/.profile modulefiles/Makefile modulefiles/modules modulefiles/module-git modulefiles/module-info modulefiles/null modulefiles/use.own modulefiles/dot modulefiles/version"
+ac_config_files="$ac_config_files Makefile modules.lsm .spec doc/Makefile init/Makefile init/.modulespath doc/module.1 doc/modulefile.5 etc/Makefile etc/add.modules etc/mkroot etc/skel/.cshrc etc/skel/.login etc/skel/.kshenv etc/skel/.profile etc/global/csh.cshrc etc/global/csh.login etc/global/csh.modules etc/global/bashrc etc/global/profile etc/global/profile.modules ext/Makefile ext/add.ext ext/mkroot ext/common/.cshrc ext/common/.login ext/common/.kshenv ext/common/.profile modulefiles/Makefile modulefiles/modules modulefiles/module-git modulefiles/module-info modulefiles/null modulefiles/use.own modulefiles/dot modulefiles/version"
ac_config_commands="$ac_config_commands default"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -8398,7 +8398,7 @@ do
"init/Makefile") CONFIG_FILES="$CONFIG_FILES init/Makefile" ;;
"init/.modulespath") CONFIG_FILES="$CONFIG_FILES init/.modulespath" ;;
"doc/module.1") CONFIG_FILES="$CONFIG_FILES doc/module.1" ;;
- "doc/modulefile.4") CONFIG_FILES="$CONFIG_FILES doc/modulefile.4" ;;
+ "doc/modulefile.5") CONFIG_FILES="$CONFIG_FILES doc/modulefile.5" ;;
"etc/Makefile") CONFIG_FILES="$CONFIG_FILES etc/Makefile" ;;
"etc/add.modules") CONFIG_FILES="$CONFIG_FILES etc/add.modules" ;;
"etc/mkroot") CONFIG_FILES="$CONFIG_FILES etc/mkroot" ;;

View File

@ -0,0 +1,66 @@
--- doc/Makefile.orig 2020-09-30 09:23:59 UTC
+++ doc/Makefile
@@ -22,9 +22,9 @@ ifeq ($(builddoc),n)
$(error No 'sphinx-build' command defined, cannot build documentation)
endif
-man: $(BUILD_DIR)/module.1 $(BUILD_DIR)/ml.1 $(BUILD_DIR)/modulefile.4
+man: $(BUILD_DIR)/module.1 $(BUILD_DIR)/ml.1 $(BUILD_DIR)/modulefile.5
ifeq ($(compatversion),y)
-man: $(COMPAT_MAN_DIR)/module.1 $(COMPAT_MAN_DIR)/modulefile.4
+man: $(COMPAT_MAN_DIR)/module.1 $(COMPAT_MAN_DIR)/modulefile.5
endif
txt: $(BUILD_DIR)/diff_v3_v4.txt $(BUILD_DIR)/MIGRATING.txt \
@@ -70,7 +70,7 @@ $(BUILD_DIR)/%.html: $(SOURCE_DIR)/%.rst $(SOURCE_DIR)
$(BUILD_DIR)/%.txt: $(SOURCE_DIR)/%.rst $(SOURCE_DIR)/version.py
$(SPHINXBUILD) $(SPHINXOPTS) -b text "$(SOURCE_DIR)" "$(BUILD_DIR)"
-$(BUILD_DIR)/%.4 $(BUILD_DIR)/%.1: $(SOURCE_DIR)/%.rst $(SOURCE_DIR)/version.py
+$(BUILD_DIR)/%.5 $(BUILD_DIR)/%.1: $(SOURCE_DIR)/%.rst $(SOURCE_DIR)/version.py
$(SPHINXBUILD) $(SPHINXOPTS) -t pathsubs -b man "$(SOURCE_DIR)" "$(BUILD_DIR)"
$(BUILD_DIR)/module.1.in: $(SOURCE_DIR)/module.rst $(SOURCE_DIR)/version.py
@@ -82,11 +82,11 @@ $(BUILD_DIR)/module.1: $(BUILD_DIR)/module.1.in
$(translate-in-script)
# compatibility version-related rules
-$(COMPAT_MAN_DIR)/module.1 $(COMPAT_MAN_DIR)/modulefile.4:
+$(COMPAT_MAN_DIR)/module.1 $(COMPAT_MAN_DIR)/modulefile.5:
$(MAKE) -C $(COMPAT_MAN_DIR) $(@F)
install: man txt
- mkdir -p $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man4
+ mkdir -p $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man5
ifeq ($(docinstall),y)
mkdir -p $(DESTDIR)$(docdir)
cp $(BUILD_DIR)/diff_v3_v4.txt $(DESTDIR)$(docdir)/
@@ -99,10 +99,10 @@ ifeq ($(docinstall),y)
endif
cp $(BUILD_DIR)/module.1 $(DESTDIR)$(mandir)/man1/
cp $(BUILD_DIR)/ml.1 $(DESTDIR)$(mandir)/man1/
- cp $(BUILD_DIR)/modulefile.4 $(DESTDIR)$(mandir)/man4/
+ cp $(BUILD_DIR)/modulefile.5 $(DESTDIR)$(mandir)/man5/
ifeq ($(compatversion),y)
cp $(COMPAT_MAN_DIR)/module.1 $(DESTDIR)$(mandir)/man1/module-compat.1
- cp $(COMPAT_MAN_DIR)/modulefile.4 $(DESTDIR)$(mandir)/man4/modulefile-compat.4
+ cp $(COMPAT_MAN_DIR)/modulefile.5 $(DESTDIR)$(mandir)/man5/modulefile-compat.5
endif
uninstall:
@@ -118,12 +118,12 @@ ifeq ($(docinstall),y)
endif
rm -f $(DESTDIR)$(mandir)/man1/module.1
rm -f $(DESTDIR)$(mandir)/man1/ml.1
- rm -f $(DESTDIR)$(mandir)/man4/modulefile.4
+ rm -f $(DESTDIR)$(mandir)/man5/modulefile.5
ifeq ($(compatversion),y)
rm -f $(DESTDIR)$(mandir)/man1/module-compat.1
- rm -f $(DESTDIR)$(mandir)/man4/modulefile-compat.4
+ rm -f $(DESTDIR)$(mandir)/man5/modulefile-compat.5
endif
- rmdir $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man4
+ rmdir $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man5
rmdir $(DESTDIR)$(mandir)
clean:

View File

@ -1,126 +0,0 @@
--- doc/Makefile.in.orig 2012-12-19 17:02:26 UTC
+++ doc/Makefile.in
@@ -33,7 +33,7 @@ PRE_UNINSTALL = :
POST_UNINSTALL = :
subdir = doc
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
- $(srcdir)/module.1.in $(srcdir)/modulefile.4.in
+ $(srcdir)/module.1.in $(srcdir)/modulefile.5.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/config/emtcl.m4 \
$(top_srcdir)/config/tcl.m4 $(top_srcdir)/acinclude.m4 \
@@ -42,7 +42,7 @@ am__configure_deps = $(am__aclocal_m4_de
$(ACLOCAL_M4)
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
-CONFIG_CLEAN_FILES = module.1 modulefile.4
+CONFIG_CLEAN_FILES = module.1 modulefile.5
CONFIG_CLEAN_VPATH_FILES =
SOURCES =
DIST_SOURCES =
@@ -74,10 +74,10 @@ am__uninstall_files_from_dir = { \
$(am__cd) "$$dir" && rm -f $$files; }; \
}
man1dir = $(mandir)/man1
-am__installdirs = "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man4dir)"
-man4dir = $(mandir)/man4
+am__installdirs = "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man5dir)"
+man5dir = $(mandir)/man5
NROFF = nroff
-MANS = $(man1_MANS) $(man4_MANS)
+MANS = $(man1_MANS) $(man5_MANS)
DEJATOOL = $(PACKAGE)
RUNTESTDEFAULTFLAGS = --tool $$tool --srcdir $$srcdir
EXPECT = expect
@@ -199,7 +199,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
man1_MANS = module.1
-man4_MANS = modulefile.4
+man5_MANS = modulefile.5
all: all-am
.SUFFIXES:
@@ -235,11 +235,11 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
$(am__aclocal_m4_deps):
module.1: $(top_builddir)/config.status $(srcdir)/module.1.in
cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@
-modulefile.4: $(top_builddir)/config.status $(srcdir)/modulefile.4.in
+modulefile.5: $(top_builddir)/config.status $(srcdir)/modulefile.5.in
cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@
install-man1: $(man1_MANS)
@$(NORMAL_INSTALL)
- test -z "$(man1dir)" || $(MKDIR_P) "$(DESTDIR)$(man1dir)"
+ test -z "$(DESTDIR)$(man1dir)" || $(MKDIR_P) "$(DESTDIR)$(man1dir)"
@list='$(man1_MANS)'; test -n "$(man1dir)" || exit 0; \
{ for i in $$list; do echo "$$i"; done; \
} | while read p; do \
@@ -269,32 +269,32 @@ uninstall-man1:
} | sed -e 's,.*/,,;h;s,.*\.,,;s,^[^1][0-9a-z]*$$,1,;x' \
-e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,'`; \
dir='$(DESTDIR)$(man1dir)'; $(am__uninstall_files_from_dir)
-install-man4: $(man4_MANS)
+install-man5: $(man5_MANS)
@$(NORMAL_INSTALL)
- test -z "$(man4dir)" || $(MKDIR_P) "$(DESTDIR)$(man4dir)"
- @list='$(man4_MANS)'; test -n "$(man4dir)" || exit 0; \
+ test -z "$(DESTDIR)$(man5dir)" || $(MKDIR_P) "$(DESTDIR)$(man5dir)"
+ @list='$(man5_MANS)'; test -n "$(man5dir)" || exit 0; \
{ for i in $$list; do echo "$$i"; done; \
} | while read p; do \
if test -f $$p; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; echo "$$p"; \
done | \
- sed -e 'n;s,.*/,,;p;h;s,.*\.,,;s,^[^4][0-9a-z]*$$,4,;x' \
+ sed -e 'n;s,.*/,,;p;h;s,.*\.,,;s,^[^5][0-9a-z]*$$,5,;x' \
-e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,' | \
sed 'N;N;s,\n, ,g' | { \
list=; while read file base inst; do \
if test "$$base" = "$$inst"; then list="$$list $$file"; else \
- echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man4dir)/$$inst'"; \
- $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man4dir)/$$inst" || exit $$?; \
+ echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man5dir)/$$inst'"; \
+ $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man5dir)/$$inst" || exit $$?; \
fi; \
done; \
for i in $$list; do echo "$$i"; done | $(am__base_list) | \
while read files; do \
test -z "$$files" || { \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(man4dir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(man4dir)" || exit $$?; }; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(man5dir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(man5dir)" || exit $$?; }; \
done; }
-uninstall-man4:
+uninstall-man5:
@$(NORMAL_UNINSTALL)
@list='$(man4_MANS)'; test -n "$(man4dir)" || exit 0; \
files=`{ for i in $$list; do echo "$$i"; done; \
@@ -395,7 +395,7 @@ check-am: all-am
check: check-am
all-am: Makefile $(MANS)
installdirs:
- for dir in "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man4dir)"; do \
+ for dir in "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man5dir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-am
@@ -464,7 +464,7 @@ install-info: install-info-am
install-info-am:
-install-man: install-man1 install-man4
+install-man: install-man1 install-man5
install-pdf: install-pdf-am
@@ -504,7 +504,7 @@ uninstall-man: uninstall-man1 uninstall-
install-data install-data-am install-dvi install-dvi-am \
install-exec install-exec-am install-html install-html-am \
install-info install-info-am install-man install-man1 \
- install-man4 install-pdf install-pdf-am install-ps \
+ install-man5 install-pdf install-pdf-am install-ps \
install-ps-am install-strip installcheck installcheck-am \
installdirs maintainer-clean maintainer-clean-generic \
mostlyclean mostlyclean-generic pdf pdf-am ps ps-am uninstall \

View File

@ -1,17 +0,0 @@
--- doc/module.1.in.orig 2012-11-08 22:45:02 UTC
+++ doc/module.1.in
@@ -120,7 +120,7 @@ command is defined with:
Upon invocation \fImodulecmd\fP sources rc files which contain global, user
and modulefile specific setups. These files are interpreted as modulefiles.
See
-.BR modulefile (4)
+.BR modulefile (5)
for detailed information.
.LP
Upon invocation of modulecmd module RC files are sourced in the following
@@ -498,4 +498,4 @@ If this defines a valid filename, it ser
.SH VERSION
@VERSION@
.SH SEE ALSO
-.BR modulefile (4)
+.BR modulefile (5)

View File

@ -1,20 +0,0 @@
--- doc/modulefile.5.in.orig 2012-12-06 22:51:08 UTC
+++ doc/modulefile.5.in
@@ -1,6 +1,6 @@
-.\" .TH MODULEFILE 4 "1 July 1994"
+.\" .TH MODULEFILE 5 "1 July 1994"
.\" minor editorial edits grenker 20090711
-.TH MODULEFILE 4 "July 2009" "Modules version @VERSION@" "Modules configuration"
+.TH MODULEFILE 5 "July 2009" "Modules version @VERSION@" "Modules configuration"
.nh
.SH NAME
modulefile \- files containing Tcl code for the Modules package
@@ -656,7 +656,7 @@ to your shell.
.RE
.RS
.I a syslog facility
-- directs logging to the syslog. See \fBsyslog.conf(4)\fP for detailed
+- directs logging to the syslog. See \fBsyslog.conf(5)\fP for detailed
description of the valid syslog facilities.
.RE
.RS

View File

@ -1,13 +0,0 @@
--- etc/Makefile.in.orig 2012-12-19 17:02:26 UTC
+++ etc/Makefile.in
@@ -403,8 +403,8 @@ install-data-local : $(EXTRA_scripts)
@list='$(EXTRA_scripts)'; for p in $$list; do \
if test -f $$p \
; then \
- echo " $(INSTALL_PROGRAM_ENV) $(INSTALL_PROGRAM) $$p $(DESTDIR)$(prefix)/bin/$$p"; \
- $(INSTALL_PROGRAM_ENV) $(INSTALL_PROGRAM) $$p $(DESTDIR)$(prefix)/bin/$$p; \
+ echo " $(INSTALL_PROGRAM_ENV) $(INSTALL_SCRIPT) $$p $(DESTDIR)$(prefix)/bin/$$p"; \
+ $(INSTALL_PROGRAM_ENV) $(INSTALL_SCRIPT) $$p $(DESTDIR)$(prefix)/bin/$$p; \
else :; fi; \
done

View File

@ -1,16 +0,0 @@
--- init/Makefile.in.orig 2012-12-19 17:02:26 UTC
+++ init/Makefile.in
@@ -437,9 +437,10 @@ uninstall-inits :
# We need to filter the *.in files to produce the init scripts
# since we don't know the value of '@prefix@' until Make time.
# (We can not rely on configure to give us correct values.)
-% : %.in $(top_builddir)/config.status
- sed -e "/@$(if $(subst 0,,$(WANTS_VERSIONING)),NOT,)VERSIONING\@/d; \
- s,@$(if $(subst 0,,$(WANTS_VERSIONING)),,NOT)VERSIONING\@,,g; \
+.SUFFIXES: .in .NULL
+.in: $(top_builddir)/config.status
+ sed -e "/@VERSIONING\@/d; \
+ s,@NOTVERSIONING\@,,g; \
s,@prefix\@,${prefix},g; \
s,@bindir\@,${exec_prefix}/bin,g; \
s,@VERSION\@,@VERSION@,g; \

View File

@ -1,24 +1,54 @@
man/man1/module.1.gz
man/man5/modulefile.5.gz
Modules/%%MODULES_VERSION%%/bin/add.modules
Modules/%%MODULES_VERSION%%/bin/createmodule.py
Modules/%%MODULES_VERSION%%/bin/envml
Modules/%%MODULES_VERSION%%/bin/mkroot
Modules/%%MODULES_VERSION%%/bin/modulecmd
Modules/%%MODULES_VERSION%%/init/.modulespath
Modules/%%MODULES_VERSION%%/etc/siteconfig.tcl
Modules/%%MODULES_VERSION%%/init/bash
Modules/%%MODULES_VERSION%%/init/bash_completion
Modules/%%MODULES_VERSION%%/init/cmake
Modules/%%MODULES_VERSION%%/init/csh
Modules/%%MODULES_VERSION%%/init/fish
Modules/%%MODULES_VERSION%%/init/fish_completion
Modules/%%MODULES_VERSION%%/init/ksh
Modules/%%MODULES_VERSION%%/init/ksh-functions/ml
Modules/%%MODULES_VERSION%%/init/ksh-functions/module
Modules/%%MODULES_VERSION%%/init/lisp
Modules/%%MODULES_VERSION%%/init/modulerc
Modules/%%MODULES_VERSION%%/init/perl.pm
Modules/%%MODULES_VERSION%%/init/profile.csh
Modules/%%MODULES_VERSION%%/init/profile.sh
Modules/%%MODULES_VERSION%%/init/python.py
Modules/%%MODULES_VERSION%%/init/r.R
Modules/%%MODULES_VERSION%%/init/ruby.rb
Modules/%%MODULES_VERSION%%/init/sh
Modules/%%MODULES_VERSION%%/init/tcl
Modules/%%MODULES_VERSION%%/init/tcsh
Modules/%%MODULES_VERSION%%/init/tcsh_completion
Modules/%%MODULES_VERSION%%/init/zsh
Modules/%%MODULES_VERSION%%/init/zsh-functions/_module
Modules/%%MODULES_VERSION%%/lib/libtclenvmodules.so
Modules/%%MODULES_VERSION%%/libexec/modulecmd.tcl
Modules/%%MODULES_VERSION%%/modulefiles/dot
Modules/%%MODULES_VERSION%%/modulefiles/module-git
Modules/%%MODULES_VERSION%%/modulefiles/module-info
Modules/%%MODULES_VERSION%%/modulefiles/modules
Modules/%%MODULES_VERSION%%/modulefiles/null
Modules/%%MODULES_VERSION%%/modulefiles/use.own
Modules/%%MODULES_VERSION%%/share/doc/CONTRIBUTING.txt
Modules/%%MODULES_VERSION%%/share/doc/COPYING.GPLv2
Modules/%%MODULES_VERSION%%/share/doc/ChangeLog
Modules/%%MODULES_VERSION%%/share/doc/INSTALL-win.txt
Modules/%%MODULES_VERSION%%/share/doc/INSTALL.txt
Modules/%%MODULES_VERSION%%/share/doc/MIGRATING.txt
Modules/%%MODULES_VERSION%%/share/doc/NEWS.txt
Modules/%%MODULES_VERSION%%/share/doc/README
Modules/%%MODULES_VERSION%%/share/doc/diff_v3_v4.txt
Modules/%%MODULES_VERSION%%/share/doc/example.txt
Modules/%%MODULES_VERSION%%/share/vim/vimfiles/ftdetect/modulefile.vim
Modules/%%MODULES_VERSION%%/share/vim/vimfiles/ftplugin/modulefile.vim
Modules/%%MODULES_VERSION%%/share/vim/vimfiles/syntax/modulefile.vim
Modules/versions/%%MODULES_VERSION%%
man/man1/ml.1.gz
man/man1/module.1.gz
man/man5/modulefile.5.gz