chinese/zh-librime: Update to 1.6.1
PR: 249512 Submitted by: Ka Ho Ng <khng300@gmail.com> Approved by: lichray@gmail.com (maintainer) Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D26515
This commit is contained in:
parent
f44a091f3d
commit
9df995e98b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=549619
@ -2,9 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= librime
|
||||
PORTVERSION= 1.2.9
|
||||
DISTVERSIONPREFIX= rime-
|
||||
PORTREVISION= 20
|
||||
PORTVERSION= 1.6.1
|
||||
CATEGORIES= chinese textproc
|
||||
|
||||
MAINTAINER= lichray@gmail.com
|
||||
@ -13,17 +11,20 @@ COMMENT= Rime Input Method Engine, the core library
|
||||
LICENSE= GPLv3
|
||||
|
||||
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
|
||||
libcapnp.so:devel/capnproto \
|
||||
libgflags.so:devel/gflags \
|
||||
libglog.so:devel/glog \
|
||||
libleveldb.so:databases/leveldb \
|
||||
libmarisa.so:devel/marisa-trie \
|
||||
libopencc.so:chinese/opencc \
|
||||
libyaml-cpp.so:devel/yaml-cpp
|
||||
libyaml-cpp.so:devel/yaml-cpp \
|
||||
|
||||
USES= cmake compiler:c++11-lib gettext pathfix perl5 pkgconfig xorg
|
||||
USES= cmake compiler:c++14-lang gettext pathfix perl5 pkgconfig xorg
|
||||
USE_PERL5= build patch
|
||||
|
||||
USE_CXXSTD= c++11
|
||||
CMAKE_OFF= BUILD_TEST
|
||||
|
||||
USE_CXXSTD= c++14
|
||||
USE_LDCONFIG= yes
|
||||
USE_XORG= xorgproto
|
||||
LDFLAGS+= -lintl
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1467479749
|
||||
SHA256 (rime-librime-rime-1.2.9_GH0.tar.gz) = d9f0e732b5bf0ee9d8872d00c79322eec7682139a898a65555f794795ac5f410
|
||||
SIZE (rime-librime-rime-1.2.9_GH0.tar.gz) = 5516609
|
||||
TIMESTAMP = 1600707948
|
||||
SHA256 (rime-librime-1.6.1_GH0.tar.gz) = 774ebd2ddb9c1301a8a981c65788e0fab71ef54505e04f39b3ce4dfdb8510302
|
||||
SIZE (rime-librime-1.6.1_GH0.tar.gz) = 2856751
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- CMakeLists.txt.orig 2014-12-21 11:46:44 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -123,7 +123,7 @@ if(NOT DEFINED BIN_INSTALL_DIR)
|
||||
set(BIN_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/bin)
|
||||
endif()
|
||||
|
||||
-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
+if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD|DragonFly")
|
||||
# uninstall target
|
||||
configure_file(
|
||||
"${CMAKE_CURRENT_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in"
|
||||
@@ -153,7 +153,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
file(GLOB supplement_schema ${PROJECT_SOURCE_DIR}/data/supplement/*.yaml)
|
||||
install(FILES ${supplement_schema} DESTINATION ${pkgdatadir})
|
||||
endif(BUILD_DATA)
|
||||
-endif(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
+endif(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD|DragonFly")
|
||||
|
||||
if(BUILD_SHARED_LIBS)
|
||||
add_definitions(-DRIME_BUILD_SHARED_LIBS)
|
@ -1,13 +0,0 @@
|
||||
https://github.com/rime/librime/issues/225
|
||||
|
||||
--- CMakeLists.txt.orig 2014-12-21 11:46:44 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -38,7 +38,7 @@ set(Boost_USE_MULTITHREADED ON)
|
||||
if(MSVC)
|
||||
set(Boost_USE_STATIC_RUNTIME ON)
|
||||
endif(MSVC)
|
||||
-find_package(Boost 1.46.0 REQUIRED COMPONENTS filesystem regex signals system)
|
||||
+find_package(Boost 1.46.0 REQUIRED COMPONENTS filesystem regex system)
|
||||
if(Boost_FOUND)
|
||||
include_directories(${Boost_INCLUDE_DIRS})
|
||||
link_directories(${Boost_LIBRARY_DIRS})
|
@ -1,6 +1,8 @@
|
||||
bin/rime_deployer
|
||||
bin/rime_dict_manager
|
||||
bin/rime_patch
|
||||
include/rime_api.h
|
||||
include/rime_levers_api.h
|
||||
lib/librime.so
|
||||
lib/librime.so.%%VER%%
|
||||
lib/librime.so.1
|
||||
|
Loading…
Reference in New Issue
Block a user