Update to 3.3.73
Add missing dependencies as reported by poudriere. Pet portlint.
This commit is contained in:
parent
a35001575e
commit
9de2d2b511
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=417670
@ -2,22 +2,28 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gtkwave
|
||||
PORTVERSION= 3.3.69
|
||||
PORTVERSION= 3.3.73
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= http://gtkwave.sourceforge.net/
|
||||
|
||||
MAINTAINER= zeising@FreeBSD.org
|
||||
COMMENT= Electronic Waveform Viewer
|
||||
|
||||
USES= desktop-file-utils gmake gperf pkgconfig shared-mime-info
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libfreetype.so:print/freetype2 \
|
||||
libfontconfig.so:x11-fonts/fontconfig
|
||||
|
||||
USES= desktop-file-utils gettext gmake gperf pkgconfig shared-mime-info
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-mime-update
|
||||
USE_GNOME= gtk20
|
||||
USE_GNOME= cairo gtk20
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
OPTIONS_DEFINE= TCL GCONF
|
||||
TCL_DESC= Enable support for TCL/TK
|
||||
TCL_USES= tk
|
||||
TCL_USES= tcl tk
|
||||
TCL_CONFIGURE_ON= --with-tcl=${TCL_LIBDIR} \
|
||||
--with-tk=${TK_LIBDIR}
|
||||
TCL_CONFIGURE_OFF= --disable-tcl
|
||||
@ -27,7 +33,6 @@ GCONF_USE= GNOME=gconf2
|
||||
|
||||
PORTDOCS= gtkwave.odt
|
||||
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for doc in ${PORTDOCS}
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (gtkwave-3.3.69.tar.gz) = d3f45beb0517b3dc63901bd35fb8ed4c1e489696936d806cca5ca8fc67d3f3a1
|
||||
SIZE (gtkwave-3.3.69.tar.gz) = 4097780
|
||||
TIMESTAMP = 1466954022
|
||||
SHA256 (gtkwave-3.3.73.tar.gz) = 57bc88efa248c9f76950a49e7ff6a3f4a2062cb512fe7eb2e86976eb7f2be86a
|
||||
SIZE (gtkwave-3.3.73.tar.gz) = 4122802
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.in.orig 2014-01-03 05:17:31.000000000 +0100
|
||||
+++ Makefile.in 2014-06-06 21:51:39.000000000 +0200
|
||||
@@ -310,7 +310,7 @@
|
||||
--- Makefile.in.orig 2014-01-03 04:17:31 UTC
|
||||
+++ Makefile.in
|
||||
@@ -310,7 +310,7 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig 2012-04-19 14:52:53.532889214 +0600
|
||||
+++ configure 2012-04-19 14:52:32.373895264 +0600
|
||||
@@ -9212,6 +9212,7 @@
|
||||
--- configure.orig 2016-05-11 18:22:21 UTC
|
||||
+++ configure
|
||||
@@ -10257,6 +10257,7 @@ OLD_LDFLAGS="${LDFLAGS}"
|
||||
TCLSPEC_LHS="${TCL_LIB_SPEC% *}"
|
||||
TKLSPEC_LHS="${TK_LIB_SPEC% *}"
|
||||
LDFLAGS="${LDFLAGS} ${TCLSPEC_LHS} ${TKLSPEC_LHS}"
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- doc/Makefile.in.orig 2013-05-13 14:24:11.641084031 +0200
|
||||
+++ doc/Makefile.in 2013-05-13 14:24:58.487075336 +0200
|
||||
@@ -32,7 +32,7 @@
|
||||
--- doc/Makefile.in.orig 2014-01-03 04:17:31 UTC
|
||||
+++ doc/Makefile.in
|
||||
@@ -32,7 +32,7 @@ am__make_dryrun = \
|
||||
esac; \
|
||||
test $$am__dry = yes; \
|
||||
}
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- examples/Makefile.in.orig 2014-01-03 05:17:31.000000000 +0100
|
||||
+++ examples/Makefile.in 2014-06-06 22:30:58.000000000 +0200
|
||||
@@ -32,7 +32,7 @@
|
||||
--- examples/Makefile.in.orig 2014-01-03 04:17:31 UTC
|
||||
+++ examples/Makefile.in
|
||||
@@ -32,7 +32,7 @@ am__make_dryrun = \
|
||||
esac; \
|
||||
test $$am__dry = yes; \
|
||||
}
|
||||
@ -9,7 +9,7 @@
|
||||
pkgincludedir = $(includedir)/@PACKAGE@
|
||||
pkglibdir = $(libdir)/@PACKAGE@
|
||||
pkglibexecdir = $(libexecdir)/@PACKAGE@
|
||||
@@ -258,7 +258,7 @@
|
||||
@@ -258,7 +258,7 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
dist_examples_DATA = des.gtkw des.tcl des.v des.fst transaction.fst transaction.gtkw transaction.c gtkwaverc
|
||||
|
@ -84,6 +84,7 @@ share/icons/gnome/48x48/mimetypes/gnome-mime-application-vnd.gtkwave-vzt.png
|
||||
share/icons/gtkwave_256x256x32.png
|
||||
share/icons/gtkwave_files_256x256x32.png
|
||||
share/icons/gtkwave_savefiles_256x256x32.png
|
||||
share/icons/hicolor/scalable/apps/gtkwave.svg
|
||||
%%EXAMPLESDIR%%/des.fst
|
||||
%%EXAMPLESDIR%%/des.gtkw
|
||||
%%EXAMPLESDIR%%/des.tcl
|
||||
|
Loading…
Reference in New Issue
Block a user