biology/trimadap: Trim adapter sequences from Illumina data
Reviewed by: mat Approved by: jrm Differential Revision: https://reviews.freebsd.org/D14935
This commit is contained in:
parent
d46cfd0917
commit
9db7a5f181
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=466367
@ -115,6 +115,7 @@
|
||||
SUBDIR += t_coffee
|
||||
SUBDIR += tinker
|
||||
SUBDIR += treepuzzle
|
||||
SUBDIR += trimadap
|
||||
SUBDIR += trimmomatic
|
||||
SUBDIR += ugene
|
||||
SUBDIR += vcftools
|
||||
|
23
biology/trimadap/Makefile
Normal file
23
biology/trimadap/Makefile
Normal file
@ -0,0 +1,23 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= trimadap
|
||||
DISTVERSION= 0.1-3
|
||||
DISTVERSIONSUFFIX= -gddfef21
|
||||
CATEGORIES= biology
|
||||
|
||||
MAINTAINER= jwb@FreeBSD.org
|
||||
COMMENT= Trim adapter sequences from Illumina data using heuristic rules
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= lh3
|
||||
|
||||
PLIST_FILES= bin/trimadap-mt
|
||||
|
||||
CFLAGS_i386= -msse2
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/trimadap-mt ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
3
biology/trimadap/distinfo
Normal file
3
biology/trimadap/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1522773176
|
||||
SHA256 (lh3-trimadap-0.1-3-gddfef21_GH0.tar.gz) = c2c42a3257d37b12be3523ed0d4415bddd401d72b99b05ba4ae33afaa3c3f373
|
||||
SIZE (lh3-trimadap-0.1-3-gddfef21_GH0.tar.gz) = 13138
|
20
biology/trimadap/files/patch-Makefile
Normal file
20
biology/trimadap/files/patch-Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
--- Makefile.orig 2017-02-11 22:31:35 UTC
|
||||
+++ Makefile
|
||||
@@ -1,10 +1,12 @@
|
||||
-CC=gcc
|
||||
-CFLAGS=-g -Wall -O2 -Wno-unused-function
|
||||
+CC ?= gcc
|
||||
+CFLAGS ?= -g -Wall -O2 -Wno-unused-function
|
||||
+LDFLAGS += -lz -lm
|
||||
|
||||
-all:trimadap-mt
|
||||
+all: trimadap-mt
|
||||
|
||||
trimadap-mt:trimadap-mt.c ksw.c kthread.c kseq.h ksw.h
|
||||
- $(CC) $(CFLAGS) -pthread ksw.c kthread.c trimadap-mt.c -o $@ -lz -lm
|
||||
+ $(CC) $(CFLAGS) -pthread ksw.c kthread.c trimadap-mt.c -o $@ $(LDFLAGS)
|
||||
|
||||
clean:
|
||||
- rm -fr gmon.out *.o ext/*.o a.out seqtk trimadap *~ *.a *.dSYM session* trimadap-mt
|
||||
+ rm -fr gmon.out *.o ext/*.o a.out seqtk trimadap *~ *.a \
|
||||
+ *.dSYM session* trimadap-mt
|
10
biology/trimadap/files/patch-kthread.c
Normal file
10
biology/trimadap/files/patch-kthread.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- kthread.c.orig 2017-02-11 22:31:35 UTC
|
||||
+++ kthread.c
|
||||
@@ -1,6 +1,7 @@
|
||||
#include <pthread.h>
|
||||
#include <stdlib.h>
|
||||
#include <limits.h>
|
||||
+#include <inttypes.h>
|
||||
|
||||
/************
|
||||
* kt_for() *
|
8
biology/trimadap/pkg-descr
Normal file
8
biology/trimadap/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
Trimadap is a small tool to trim adapter sequences from Illumina data. It
|
||||
performs SSE2-SW between each read and each adapter sequence and identifies
|
||||
adapter sequences with a few heuristic rules which can be found in the
|
||||
ta_trim1() function in trimadap-mt.c. The default adapters it uses are included
|
||||
in illumina.txt. These are typical Illumina adapters from paired-end
|
||||
sequencing.
|
||||
|
||||
WWW: https://github.com/lh3/trimadap
|
Loading…
Reference in New Issue
Block a user