add gaul 0.1846

Genetic Algorithm Utility Library
This commit is contained in:
Ying-Chieh Liao 2003-10-28 08:05:26 +00:00
parent 35583b1d7e
commit 9da5a12cc6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92418
6 changed files with 132 additions and 0 deletions

View File

@ -222,6 +222,7 @@
SUBDIR += g-wrap
SUBDIR += g2c
SUBDIR += gaa
SUBDIR += gaul
SUBDIR += gccxml
SUBDIR += gconf
SUBDIR += gconf2

28
devel/gaul/Makefile Normal file
View File

@ -0,0 +1,28 @@
# ex:ts=8
# Ports collection makefile for: gaul
# Date created: Oct 28, 2003
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= gaul
PORTVERSION= 0.1846
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-devel-${PORTVERSION}-0
MAINTAINER= ports@FreeBSD.org
COMMENT= Genetic Algorithm Utility Library
LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lcurses"
INSTALLS_SHLIB= yes
.include <bsd.port.mk>

1
devel/gaul/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (gaul-devel-0.1846-0.tar.gz) = 1cce2bf4546ee4739f85076ab26ca983

View File

@ -0,0 +1,15 @@
--- ltmain.sh.orig Tue Oct 28 15:49:19 2003
+++ ltmain.sh Tue Oct 28 15:49:30 2003
@@ -4286,10 +4286,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

9
devel/gaul/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
The Genetic Algorithm Utility Library (or, GAUL for short) is a flexible
programming library designed to aid in the development of applications that
use genetic, or evolutionary, algorithms. It provides data structures and
functions for handling and manipulation of the data required for a genetic
algorithm. Additional stochastic algorithms are provided for comparison to the
genetic algorithms. Much of the functionality is also available through a
simple S-Lang interface.
WWW: http://gaul.sourceforge.net/

78
devel/gaul/pkg-plist Normal file
View File

@ -0,0 +1,78 @@
bin/diagnostics
bin/fitting
bin/fitting_sd
bin/fitting_simplex
bin/goldberg1
bin/goldberg2
bin/mixed
bin/nnevolve
bin/onemax
bin/pingpong
bin/pingpong_sa
bin/pingpong_tabu
bin/pingpong_tabu2
bin/royalroad
bin/royalroad_bitstring
bin/royalroad_ss
bin/saveload
bin/struggle
bin/struggle2
bin/struggle3
bin/struggle4
bin/struggle5
bin/struggle5_forked
bin/struggle5_mp
bin/struggle_dc
bin/struggle_forked
bin/struggle_randomsearch
bin/struggle_ss
bin/struggle_systematicsearch
bin/test_ga
bin/test_sd
bin/test_simplex
bin/wildfire
bin/wildfire_forked
bin/wildfire_loadbalancing
include/gaul.h
include/gaul/avltree.h
include/gaul/compatibility.h
include/gaul/ga_bitstring.h
include/gaul/ga_chromo.h
include/gaul/ga_climbing.h
include/gaul/ga_core.h
include/gaul/ga_deterministiccrowding.h
include/gaul/ga_gradient.h
include/gaul/ga_intrinsics.h
include/gaul/ga_optim.h
include/gaul/ga_qsort.h
include/gaul/ga_randomsearch.h
include/gaul/ga_sa.h
include/gaul/ga_similarity.h
include/gaul/ga_simplex.h
include/gaul/ga_systematicsearch.h
include/gaul/ga_tabu.h
include/gaul/ga_utility.h
include/gaul/gaul_config.h
include/gaul/gaul_config_win.h
include/gaul/gaul_util.h
include/gaul/linkedlist.h
include/gaul/log_util.h
include/gaul/memory_chunks.h
include/gaul/memory_util.h
include/gaul/mpi_util.h
include/gaul/nn_util.h
include/gaul/random_util.h
include/gaul/str_match.h
include/gaul/str_util.h
include/gaul/table_util.h
include/gaul/timer_util.h
@dirrm include/gaul
lib/libgaul.a
lib/libgaul.so
lib/libgaul.so.0
lib/libgaul_util.a
lib/libgaul_util.so
lib/libgaul_util.so.0
lib/libnn_util.a
lib/libnn_util.so
lib/libnn_util.so.0