- Convert x11/libfm and x11/libfm-extra to Master-Slave Port
(same application, CATEGORIES, DISTFILES, install path) - Bump PORTREVISION - Move patches to Makefile PR: 200825 Submitted by: horia@racoviceanu.com (maintainer)
This commit is contained in:
parent
bfa3048623
commit
9d86ec5bc2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=393394
@ -1,29 +1,26 @@
|
||||
# Created by: Kris Moore <kmoore@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libfm-extra
|
||||
PORTVERSION= 1.2.3
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= SF/pcmanfm/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/LibFM/
|
||||
DISTNAME= libfm-${PORTVERSION}
|
||||
PORTNAME= libfm
|
||||
PORTREVISION= 1
|
||||
PKGNAMESUFFIX= -extra
|
||||
|
||||
MAINTAINER= horia@racoviceanu.com
|
||||
COMMENT= Core library of PCManFM file manager
|
||||
COMMENT= LibFM-Extra library
|
||||
|
||||
LICENSE= LGPL21
|
||||
|
||||
USES= gmake libtool pathfix pkgconfig tar:xz gettext-tools
|
||||
USE_GNOME= glib20 intltool intlhack
|
||||
MASTERDIR= ${.CURDIR}/../${PORTNAME}
|
||||
|
||||
DESCR= ${.CURDIR}/pkg-descr
|
||||
FILESDIR= ${.CURDIR}/files
|
||||
PATCHDIR= ${.CURDIR}/files
|
||||
PLIST= ${.CURDIR}/pkg-plist
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
WRKSRC= ${WRKDIR}/libfm-${PORTVERSION}
|
||||
EXTRA_ONLY= yes
|
||||
|
||||
EXTRA_PATCHES+= ${.CURDIR}/../libfm/files/patch-configure
|
||||
OPTIONS_EXCLUDE=DOCS NLS
|
||||
|
||||
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --with-extra-only \
|
||||
--disable-static \
|
||||
--disable-nls
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
@ -1,19 +0,0 @@
|
||||
--- src/Makefile.in.orig 2014-10-14 16:46:21 UTC
|
||||
+++ src/Makefile.in
|
||||
@@ -497,7 +497,7 @@ am__relativize = \
|
||||
reldir="$$dir2"
|
||||
|
||||
# we use common include directory for all headers
|
||||
-pkgincludedir = $(includedir)/@PACKAGE@-@FMLIBVER@
|
||||
+pkgincludedir = $(includedir)/@PACKAGE@
|
||||
ACLOCAL = @ACLOCAL@
|
||||
ACTIONS_SUBDIR = @ACTIONS_SUBDIR@
|
||||
ALL_LINGUAS = @ALL_LINGUAS@
|
||||
@@ -3079,7 +3079,6 @@ install-data-local:
|
||||
rm -rf "$(DESTDIR)$(includedir)/@PACKAGE@"; \
|
||||
fi
|
||||
test -z "$(includedir)" || $(MKDIR_P) "$(DESTDIR)$(includedir)"
|
||||
- @LN_S@ @PACKAGE@-@FMLIBVER@ "$(DESTDIR)$(includedir)/@PACKAGE@"
|
||||
|
||||
uninstall-local:
|
||||
@if test -L "$(DESTDIR)$(includedir)/@PACKAGE@"; then \
|
@ -1,3 +1,3 @@
|
||||
Library which provides the core functionality to PCManFM.
|
||||
libfm-extra library
|
||||
|
||||
WWW: http://wiki.lxde.org/en/Libfm
|
||||
|
@ -2,6 +2,6 @@ include/libfm/fm-extra.h
|
||||
include/libfm/fm-version.h
|
||||
include/libfm/fm-xml-file.h
|
||||
lib/libfm-extra.so
|
||||
lib/libfm-extra.so.4
|
||||
lib/libfm-extra.so.4.0.3
|
||||
lib/libfm-extra.so.%%ABI_VERSION%%
|
||||
lib/libfm-extra.so.%%ABI_VERSION%%.%%MICRO_VERSION%%
|
||||
libdata/pkgconfig/libfm-extra.pc
|
||||
|
Loading…
Reference in New Issue
Block a user