PR: 53741
Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com> Reviewed by: maintainer Upgrade devel/pcre to 4.3
This commit is contained in:
parent
f79c87235f
commit
9d7163560f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84550
@ -6,19 +6,16 @@
|
||||
#
|
||||
|
||||
PORTNAME= pcre
|
||||
PORTVERSION= 3.9
|
||||
PORTVERSION= 4.3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/programming/%SUBDIR%/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= dom@happygiraffe.net
|
||||
COMMENT= Perl Compatible Regular Expressions library
|
||||
|
||||
# Disabled until SourceForge put a proper copy of .tar.bz2 file on its mirrors
|
||||
# Currently, it is corrupted and does not match the one on the master site:
|
||||
# ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/
|
||||
#
|
||||
# USE_BZIP2= yes
|
||||
USE_BZIP2= yes
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
@ -27,6 +24,41 @@ CONFIGURE_ARGS+= --enable-utf8
|
||||
.endif
|
||||
|
||||
MAN1= pcregrep.1 pcretest.1
|
||||
MAN3= pcre.3 pcreposix.3
|
||||
MAN3= pcre.3 pcre_compile.3 pcre_config.3 \
|
||||
pcre_copy_named_substring.3 pcre_copy_substring.3 pcre_exec.3 \
|
||||
pcre_free_substring.3 pcre_free_substring_list.3 pcre_fullinfo.3 \
|
||||
pcre_get_named_substring.3 pcre_get_stringnumber.3 pcre_get_substring.3 \
|
||||
pcre_get_substring_list.3 pcre_info.3 pcre_maketables.3 \
|
||||
pcre_study.3 pcre_version.3 pcreapi.3 \
|
||||
pcrebuild.3 pcrecallout.3 pcrecompat.3 \
|
||||
pcrepattern.3 pcreperform.3 pcreposix.3 \
|
||||
pcresample.3
|
||||
|
||||
TXTDOC= Tech.Notes pcre.txt pcregrep.txt \
|
||||
pcretest.txt perltest.txt
|
||||
HTMLDOC= index pcre pcre_compile \
|
||||
pcre_config pcre_copy_named_substring pcre_copy_substring \
|
||||
pcre_exec pcre_free_substring pcre_free_substring_list \
|
||||
pcre_fullinfo pcre_get_named_substring pcre_get_stringnumber \
|
||||
pcre_get_substring pcre_get_substring_list pcre_info \
|
||||
pcre_maketables pcre_study pcre_version \
|
||||
pcreapi pcrebuild pcrecallout \
|
||||
pcrecompat pcregrep pcrepattern \
|
||||
pcreperform pcreposix pcresample \
|
||||
pcretest
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STRIP} ${PREFIX}/bin/pcregrep
|
||||
@${STRIP_CMD} ${STRIP} ${PREFIX}/bin/pcretest
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@for txt in ${TXTDOC}; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/$${txt} ${DOCSDIR}; \
|
||||
done
|
||||
@${MKDIR} ${DOCSDIR}/html
|
||||
@for html in ${HTMLDOC}; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/html/$${html}.html ${DOCSDIR}/html; \
|
||||
done
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (pcre-3.9.tar.gz) = 55d9f1ee68ff335850c0d07a2daf242a
|
||||
MD5 (pcre-4.3.tar.bz2) = 7bc7d5b590a41e6f9ede30f272002a02
|
||||
|
@ -1,28 +1,15 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh.orig Fri Aug 17 03:16:16 2001
|
||||
+++ ltmain.sh Fri Nov 16 17:54:42 2001
|
||||
@@ -2408,6 +2408,9 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test $build_libtool_need_lc = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
--- ltmain.sh.orig Thu May 22 15:25:54 2003
|
||||
+++ ltmain.sh Thu Jun 26 01:26:04 2003
|
||||
@@ -4286,12 +4286,6 @@
|
||||
IFS="$save_ifs"
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
- # Install the pseudo-library for information purposes.
|
||||
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
- instname="$dir/$name"i
|
||||
- $show "$install_prog $instname $destdir/$name"
|
||||
- $run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
-
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
||||
;;
|
||||
|
@ -9,3 +9,38 @@ lib/libpcre.so.0
|
||||
lib/libpcreposix.a
|
||||
lib/libpcreposix.so
|
||||
lib/libpcreposix.so.0
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Tech.Notes
|
||||
%%PORTDOCS%%%%DOCSDIR%%/pcre.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/pcregrep.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/pcretest.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/perltest.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_compile.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_config.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_copy_named_substring.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_copy_substring.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_exec.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_free_substring.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_free_substring_list.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_fullinfo.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_get_named_substring.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_get_stringnumber.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_get_substring.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_get_substring_list.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_info.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_maketables.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_study.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcre_version.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcreapi.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcrebuild.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcrecallout.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcrecompat.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcregrep.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcrepattern.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcreperform.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcreposix.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcresample.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/pcretest.html
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user