glide3 port. Most of the credit goes to Eric Anholt.

This makes a library good enough to be able to make the XFree86-4 port's
lib/modules/dri/tdfx_dri.so, which is enough to enable DRI on 3dfx cards.
This commit is contained in:
Nick Sayer 2001-04-01 03:38:41 +00:00
parent e72261faea
commit 9d49968574
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40683
13 changed files with 199 additions and 0 deletions

View File

@ -61,6 +61,7 @@
SUBDIR += gimp1
SUBDIR += giram
SUBDIR += gle
SUBDIR += glide3
SUBDIR += gliv
SUBDIR += gltk
SUBDIR += gnofract4d

44
graphics/glide3/Makefile Normal file
View File

@ -0,0 +1,44 @@
# New ports collection makefile for: Glide
# Date created: 31 Mar 2001
# Whom: Nick Sayer <nsayer@freebsd.org>
#
# $FreeBSD$
#
PORTNAME= Glide3-64Bit
PORTVERSION= 20010331
CATEGORIES= graphics
MASTER_SITES= http://www.teleport.com/~anholt/devel/dri/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= nsayer
DISTFILES= ${PORTNAME}-20010331.tgz \
${PORTNAME:S/G/g/}-2001-01-06.tar.gz
EXTRACT_ONLY= ${PORTNAME}-20010331.tgz
PATCH_SITES= http://www.teleport.com/~anholt/devel/dri/
PATCHFILES= ${PORTNAME:S/G/g/}-2001-01-06.diff
MAINTAINER= nsayer@FreeBSD.org
WRKSRC= ${WRKDIR}/Glide3
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_AUTOMAKE= yes
MAKEFILE= makefile.autoconf
USE_GMAKE= yes
.ifdef WITH_VOODOO3
CONFIGURE_ARGS+= --enable-fx-glide-hw=h3
.elifdef WITH_VOODOO2
CONFIGURE_ARGS+= --enable-fx-glide-hw=cvg
.endif
post-extract:
( cd ${WRKSRC}; ${TAR} xfpz \
${DISTDIR}/${PORTNAME:S/G/g/}-2001-01-06.tar.gz )
post-patch:
( cd ${WRKSRC} ; aclocal )
.include <bsd.port.mk>

3
graphics/glide3/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (Glide3-64Bit-20010331.tgz) = 19137a3d6ee854bcbcba1fc1bd9c0594
MD5 (glide3-64Bit-2001-01-06.tar.gz) = dd5ecfb28962b99948b6d323cdb37d7a
MD5 (glide3-64Bit-2001-01-06.diff) = 3b102d9d7c030fe7beeb5defa19b85a1

View File

@ -0,0 +1,30 @@
--- cvg/glide3/src/glidesys.h.orig Sat Mar 31 19:31:07 2001
+++ cvg/glide3/src/glidesys.h Sat Mar 31 19:24:43 2001
@@ -49,6 +49,7 @@
*
* 5 5/21/97 6:05a Peter
*/
+#include "config.h"
#ifndef __GLIDESYS_H__
#define __GLIDESYS_H__
--- h3/glide3/src/glidesys.h.orig Sat Mar 31 19:31:09 2001
+++ h3/glide3/src/glidesys.h Sat Mar 31 19:24:51 2001
@@ -56,6 +56,7 @@
*
* 5 5/21/97 6:05a Peter
*/
+#include "config.h"
#ifndef __GLIDESYS_H__
#define __GLIDESYS_H__
--- h5/glide3/src/glidesys.h.orig Sat Mar 31 19:31:11 2001
+++ h5/glide3/src/glidesys.h Sat Mar 31 19:24:58 2001
@@ -55,6 +55,7 @@
*
* 5 5/21/97 6:05a Peter
*/
+#include "config.h"
#ifndef __GLIDESYS_H__
#define __GLIDESYS_H__

View File

@ -0,0 +1 @@
3dfx 3d graphics library

View File

@ -0,0 +1,9 @@
This library is necessary in order to build XFree86's 3dfx DRI/DRM shim
(lib/modules/dri/tdfx_dri.so). It probably has other uses as well. :-)
The main distfile is unofficial. It was created by simply checking out
from CVS and tarring up the result on the date indicated in the filename.
This was done simply to make the port easier to deal with.
You will need to make sure to get the configure options right for the hardware
you will be using. This is left as an exercise to the reader. :-)

12
graphics/glide3/pkg-plist Normal file
View File

@ -0,0 +1,12 @@
lib/libglide3.so.13
lib/libglide3.so
lib/libglide3.a
include/glide3/3dfx.h
include/glide3/linutil.h
include/glide3/texus.h
include/glide3/sst1vid.h
include/glide3/g3ext.h
include/glide3/glide.h
include/glide3/glideutl.h
include/glide3/glidesys.h
@dirrm include/glide3

View File

@ -0,0 +1,44 @@
# New ports collection makefile for: Glide
# Date created: 31 Mar 2001
# Whom: Nick Sayer <nsayer@freebsd.org>
#
# $FreeBSD$
#
PORTNAME= Glide3-64Bit
PORTVERSION= 20010331
CATEGORIES= graphics
MASTER_SITES= http://www.teleport.com/~anholt/devel/dri/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= nsayer
DISTFILES= ${PORTNAME}-20010331.tgz \
${PORTNAME:S/G/g/}-2001-01-06.tar.gz
EXTRACT_ONLY= ${PORTNAME}-20010331.tgz
PATCH_SITES= http://www.teleport.com/~anholt/devel/dri/
PATCHFILES= ${PORTNAME:S/G/g/}-2001-01-06.diff
MAINTAINER= nsayer@FreeBSD.org
WRKSRC= ${WRKDIR}/Glide3
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_AUTOMAKE= yes
MAKEFILE= makefile.autoconf
USE_GMAKE= yes
.ifdef WITH_VOODOO3
CONFIGURE_ARGS+= --enable-fx-glide-hw=h3
.elifdef WITH_VOODOO2
CONFIGURE_ARGS+= --enable-fx-glide-hw=cvg
.endif
post-extract:
( cd ${WRKSRC}; ${TAR} xfpz \
${DISTDIR}/${PORTNAME:S/G/g/}-2001-01-06.tar.gz )
post-patch:
( cd ${WRKSRC} ; aclocal )
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (Glide3-64Bit-20010331.tgz) = 19137a3d6ee854bcbcba1fc1bd9c0594
MD5 (glide3-64Bit-2001-01-06.tar.gz) = dd5ecfb28962b99948b6d323cdb37d7a
MD5 (glide3-64Bit-2001-01-06.diff) = 3b102d9d7c030fe7beeb5defa19b85a1

View File

@ -0,0 +1,30 @@
--- cvg/glide3/src/glidesys.h.orig Sat Mar 31 19:31:07 2001
+++ cvg/glide3/src/glidesys.h Sat Mar 31 19:24:43 2001
@@ -49,6 +49,7 @@
*
* 5 5/21/97 6:05a Peter
*/
+#include "config.h"
#ifndef __GLIDESYS_H__
#define __GLIDESYS_H__
--- h3/glide3/src/glidesys.h.orig Sat Mar 31 19:31:09 2001
+++ h3/glide3/src/glidesys.h Sat Mar 31 19:24:51 2001
@@ -56,6 +56,7 @@
*
* 5 5/21/97 6:05a Peter
*/
+#include "config.h"
#ifndef __GLIDESYS_H__
#define __GLIDESYS_H__
--- h5/glide3/src/glidesys.h.orig Sat Mar 31 19:31:11 2001
+++ h5/glide3/src/glidesys.h Sat Mar 31 19:24:58 2001
@@ -55,6 +55,7 @@
*
* 5 5/21/97 6:05a Peter
*/
+#include "config.h"
#ifndef __GLIDESYS_H__
#define __GLIDESYS_H__

View File

@ -0,0 +1 @@
3dfx 3d graphics library

View File

@ -0,0 +1,9 @@
This library is necessary in order to build XFree86's 3dfx DRI/DRM shim
(lib/modules/dri/tdfx_dri.so). It probably has other uses as well. :-)
The main distfile is unofficial. It was created by simply checking out
from CVS and tarring up the result on the date indicated in the filename.
This was done simply to make the port easier to deal with.
You will need to make sure to get the configure options right for the hardware
you will be using. This is left as an exercise to the reader. :-)

View File

@ -0,0 +1,12 @@
lib/libglide3.so.13
lib/libglide3.so
lib/libglide3.a
include/glide3/3dfx.h
include/glide3/linutil.h
include/glide3/texus.h
include/glide3/sst1vid.h
include/glide3/g3ext.h
include/glide3/glide.h
include/glide3/glideutl.h
include/glide3/glidesys.h
@dirrm include/glide3