textproc/py-rst2html: Fix conflict with textproc/py-docutils

docutils 0.13.1 release included a new rst2html5 frontend, adding
rst2html5{.py} to LOCALBASE/bin. This conflicts with files already
packages with textproc/py-rst2html [1][2], resulting in a packging error.

Also affected (not currently packaged in FreeBSD Ports), is the
rst2html5-tools PyPI package [2].

Rename the conflicting script accordingly.

While I'm here:

- Fix *_DEPENDS versions to match upstream
- Remove unecessary limit to Python 2.x
- Enable concurrent installation

[1] https://bitbucket.org/andre_felipe_dias/rst2html5/issues/27/
[2] https://github.com/getnikola/nikola/issues/2657
[3] https://github.com/marianoguerra/rst2html5/issues/87

PR:		228414
Reported by:	roflik (via IRC)
Approved by:	koobs (python,  maintainer)
MFH:		2018Q2
This commit is contained in:
Kubilay Kocak 2018-05-22 05:15:28 +00:00
parent 68ec769804
commit 9d44f7f4d0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=470594
2 changed files with 26 additions and 5 deletions

View File

@ -11,13 +11,15 @@ MAINTAINER= python@FreeBSD.org
COMMENT= Produces HTML5 documents from reStructuredText sources
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.7:textproc/py-genshi@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pygments>=2.1:textproc/py-pygments@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}docutils>=0.12:textproc/py-docutils@${FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.7:textproc/py-genshi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pygments>=2.0.2:textproc/py-pygments@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}docutils>=0.12:textproc/py-docutils@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils concurrent autoplist
USES= python:2.7
USE_PYTHON= distutils autoplist
NO_ARCH= yes
.include <bsd.port.mk>

View File

@ -0,0 +1,19 @@
# Conflicts with docutils >-= 0.13.1
# 1d6174076454 doesn't actually resolve the (file) conflict
# https://bitbucket.org/andre_felipe_dias/rst2html5/issues/27/
# https://github.com/getnikola/nikola/issues/2657
# https://github.com/marianoguerra/rst2html5/issues/87
--- setup.py.orig 2018-05-22 02:47:00 UTC
+++ setup.py
@@ -51,8 +51,8 @@ setup(
include_package_data=True,
entry_points={
'console_scripts': [
- 'rst2html5 = rst2html5_:main',
- 'rst2html5.py = rst2html5_:main', # overrides docutils' rst2html5.py
+ 'rst2html5-rst2html5 = rst2html5_:main',
+ 'rst2html5-rst2html5.py = rst2html5_:main', # overrides docutils' rst2html5.py
],
},
)