Initial import of guiTAR version 0.1.4.
A gtk+/GNOME frontend to tar, gzip, bzip2, slp, rar, lha, arj, and zip. PR: 13136 Submitted by: Dominik Brettnacher <domi@saargate.de>
This commit is contained in:
parent
58f653e959
commit
9d286945bf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22801
35
sysutils/guitar/Makefile
Normal file
35
sysutils/guitar/Makefile
Normal file
@ -0,0 +1,35 @@
|
||||
# New ports collection makefile for: guiTAR
|
||||
# Version required: 0.1.4
|
||||
# Date created: Sat Aug 14 1999
|
||||
# Whom: domi@saargate.de
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= guiTAR-0.1.4
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://disq.bir.net.tr/guitar/ \
|
||||
http://artemis.efes.net/disq/guitar/
|
||||
|
||||
MAINTAINER= domi@saargate.de
|
||||
|
||||
LIB_DEPENDS= gtk12.3:${PORTSDIR}/x11-toolkits/gtk12
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
|
||||
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
|
||||
|
||||
.if defined(NO_GNOME)
|
||||
CONFIGURE_ARGS += --disable-gnome
|
||||
.else
|
||||
LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
@ ${INSTALL_PROGRAM} ${WRKSRC}/src/guitar ${PREFIX}/bin
|
||||
@ ${INSTALL_SCRIPT} ${SCRIPTDIR}/bsdtar2gnutar ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
sysutils/guitar/distinfo
Normal file
1
sysutils/guitar/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (guiTAR-0.1.4.tar.gz) = 386c1817faf3b9e7afbb8a6f285ba5f9
|
11
sysutils/guitar/files/patch-aa
Normal file
11
sysutils/guitar/files/patch-aa
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/programs.c.orig Sat Aug 14 11:32:24 1999
|
||||
+++ src/programs.c Sat Aug 14 11:38:08 1999
|
||||
@@ -1167,7 +1167,7 @@
|
||||
{
|
||||
f=fopen(tmp1,"w");
|
||||
fprintf(f,"#!/bin/sh\n");
|
||||
- fprintf(f,"%s tar vtf %s >%s 2>%s",pipe,fn,tmp2,tmp3);
|
||||
+ fprintf(f,"%s tar vtf %s |bsdtar2gnutar >%s 2>%s",pipe,fn,tmp2,tmp3);
|
||||
fclose(f);
|
||||
|
||||
chmod(tmp1,S_IRUSR | S_IWUSR | S_IXUSR);
|
1
sysutils/guitar/pkg-comment
Normal file
1
sysutils/guitar/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A gtk+/GNOME frontend to tar, gzip, bzip2, slp, rar, lha, arj and zip
|
15
sysutils/guitar/pkg-descr
Normal file
15
sysutils/guitar/pkg-descr
Normal file
@ -0,0 +1,15 @@
|
||||
guiTAR is a generic archive tool, written in GTK+/Gnome, supporting plain
|
||||
tarballs, tar.gz, tar.bz2, slp, zip, lzh, arj, and rar format.
|
||||
|
||||
Some features currently implemented:
|
||||
|
||||
Get a list of files inside an archive
|
||||
View one or more files inside an archive (at the same time)
|
||||
Create an archive
|
||||
Add a file into an archive
|
||||
Delete a file from an archive
|
||||
Extract one or more files inside an archive to a selected directory
|
||||
Multiple document interface
|
||||
|
||||
WWW: http://disq.bir.net.tr/guitar/
|
||||
Mirror: http://artemis.efes.net/disq/guitar/
|
2
sysutils/guitar/pkg-plist
Normal file
2
sysutils/guitar/pkg-plist
Normal file
@ -0,0 +1,2 @@
|
||||
bin/guitar
|
||||
bin/bsdtar2gnutar
|
44
sysutils/guitar/scripts/bsdtar2gnutar
Normal file
44
sysutils/guitar/scripts/bsdtar2gnutar
Normal file
@ -0,0 +1,44 @@
|
||||
#!/usr/bin/perl
|
||||
# converts output of BSD tar(1) into GNU tar compatible format
|
||||
# tries to support localization
|
||||
# bug reports are welcome!
|
||||
|
||||
# Version 0.01 26.07.1999 Dominik Brettnacher <domi@saargate.de>
|
||||
|
||||
# we need POSIX::strftime to find out the national abbreviations for
|
||||
# month names (used by BSD tar)
|
||||
use POSIX qw(strftime);
|
||||
for(0..11)
|
||||
{
|
||||
$Month{POSIX::strftime("%b", 0, 0, 0, 1, $_, 0)} = $_ + 1;
|
||||
}
|
||||
|
||||
while(<>)
|
||||
{
|
||||
m/^(.*) (.{6}) ([0-9 ]{2}:\d{2}) (\d{4}) (.*)/ || die "regular expression did not match, please report";
|
||||
|
||||
($day,$month) = month_or_mday_first($2);
|
||||
|
||||
printf("%s %i-%02i-%02i %s %s\n",$1,$4,$Month{$month},$day,$3,$5);
|
||||
}
|
||||
|
||||
# BSD tar uses a quite "different" way to output the date, roughly:
|
||||
# $date = strftime("%c", ...);
|
||||
# $date = substr($date,4,12) . " " . substr($date,20,4);
|
||||
# as it uses localization, we must try to find out whether mday is printed
|
||||
# before or after the month name itself. this seems to be a solution:
|
||||
sub month_or_mday_first
|
||||
{
|
||||
if($_[0] =~ m/([0-9 ]{2}) (.{3})/)
|
||||
{
|
||||
return ($1, $2);
|
||||
}
|
||||
elsif($_[0] =~ m/(.{3}) ([0-9 ]{2})/)
|
||||
{
|
||||
return ($2, $1);
|
||||
}
|
||||
else
|
||||
{
|
||||
die "invalid date format $_[0]";
|
||||
}
|
||||
}
|
Loading…
Reference in New Issue
Block a user