- Update to 5.2.0
PR: 214684 Submitted by: yuri@rawbw.com Approved by: maintainer
This commit is contained in:
parent
180d47bdfc
commit
9cf92e9e41
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=431074
@ -2,11 +2,10 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= paraview
|
||||
PORTVERSION= 4.3.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 5.2.0
|
||||
CATEGORIES= science graphics
|
||||
MASTER_SITES= http://www.paraview.org/files/v${VERMAJORMINOR}/
|
||||
DISTNAME= ParaView-v${PORTVERSION}-source
|
||||
DISTNAME= ParaView-v${PORTVERSION}
|
||||
|
||||
MAINTAINER= devel@stasyan.com
|
||||
COMMENT= Powerful scientific data visualization application
|
||||
@ -35,10 +34,10 @@ CONFLICTS_BUILD= protobuf*
|
||||
|
||||
USE_QT4= qmake_build moc_build rcc_build uic_build \
|
||||
linguisttools_build assistant_run qt3support \
|
||||
dbus designer gui help-tools network script \
|
||||
corelib dbus designer gui help-tools network script \
|
||||
sql svg xml webkit assistantclient clucene \
|
||||
xmlpatterns xmlpatterns-tool help
|
||||
USE_GL= yes
|
||||
USE_GL= gl
|
||||
USE_XORG= x11 xt xext ice xdmcp xau xcb xfixes xdamage xxf86vm xrender sm
|
||||
USE_LDCONFIG= yes
|
||||
USE_GSTREAMER= yes
|
||||
@ -63,7 +62,6 @@ MAKE_ENV= XDG_CONFIG_HOME=${WRKDIR}
|
||||
|
||||
SHEBANG_FILES= Catalyst/catalyze.py VTK/Examples/SearchScript.sh \
|
||||
VTK/Utilities/Maintenance/*.sh \
|
||||
Web/Applications/Parallel/server/launcher.sh \
|
||||
Plugins/SciberQuestToolKit/eigen-3.0.3/eigen-eigen-3.0.3/bench/basicbench.cxxlist \
|
||||
Plugins/SciberQuestToolKit/eigen-3.0.3/eigen-eigen-3.0.3/bench/*.sh \
|
||||
Plugins/SciberQuestToolKit/eigen-3.0.3/eigen-eigen-3.0.3/bench/bench_unrolling \
|
||||
@ -81,7 +79,6 @@ GL2PS_DESC= Install support conversion OpenGL to PostScript
|
||||
# VTKMPEG2 "Install patented MPEG2 encoder module" Off \
|
||||
|
||||
VERMAJORMINOR= ${PORTVERSION:R}
|
||||
WRKSRC= ${WRKDIR}/ParaView-v${PORTVERSION}-source
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (ParaView-v4.3.1-source.tar.gz) = d534c475fc052215ecadf4ad19d9c7996c634b5d965951292b966710509a2542
|
||||
SIZE (ParaView-v4.3.1-source.tar.gz) = 50842525
|
||||
TIMESTAMP = 1479453145
|
||||
SHA256 (ParaView-v5.2.0.tar.gz) = 894e42ef8475bb49e4e7e64f4ee2c37c714facd18bfbb1d6de7f69676b062c96
|
||||
SIZE (ParaView-v5.2.0.tar.gz) = 47087129
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- ParaViewCore/ClientServerCore/Default/vtkPVFileInformation.h.orig 2016-11-14 15:41:57 UTC
|
||||
+++ ParaViewCore/ClientServerCore/Default/vtkPVFileInformation.h
|
||||
@@ -30,6 +30,8 @@
|
||||
#include "vtkPVClientServerCoreDefaultModule.h" //needed for exports
|
||||
#include "vtkPVInformation.h"
|
||||
|
||||
+#include <time.h>
|
||||
+
|
||||
class vtkCollection;
|
||||
class vtkPVFileInformationSet;
|
||||
class vtkFileSequenceParser;
|
11
science/paraview/files/patch-Plugins_CDIReader_cdilib.c
Normal file
11
science/paraview/files/patch-Plugins_CDIReader_cdilib.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- Plugins/CDIReader/cdilib.c.orig 2016-11-19 09:40:46 UTC
|
||||
+++ Plugins/CDIReader/cdilib.c
|
||||
@@ -47,7 +47,7 @@
|
||||
#define _XOPEN_SOURCE 600
|
||||
#endif
|
||||
|
||||
-#if defined(__linux__) || defined(__APPLE__)
|
||||
+#if defined(__linux__) || defined(__FreeBSD__) || defined(__APPLE__)
|
||||
#include <unistd.h>
|
||||
#include <stdbool.h>
|
||||
#include <sys/types.h>
|
@ -1,11 +1,11 @@
|
||||
--- Plugins/PointSprite/CMakeLists.txt.orig 2009-07-28 21:17:26.000000000 +0700
|
||||
+++ Plugins/PointSprite/CMakeLists.txt 2010-04-19 16:41:17.000000000 +0700
|
||||
@@ -25,6 +25,8 @@
|
||||
--- Plugins/PointSprite/CMakeLists.txt.orig 2016-11-14 15:41:57 UTC
|
||||
+++ Plugins/PointSprite/CMakeLists.txt
|
||||
@@ -11,6 +11,8 @@ add_definitions(-D_SCL_SECURE_NO_DEPRECA
|
||||
#--------------------------------------------------
|
||||
# Find and Use ParaView
|
||||
#--------------------------------------------------
|
||||
+INCLUDE_DIRECTORIES(BEFORE ${QT_QTCORE_INCLUDE_DIR})
|
||||
+INCLUDE_DIRECTORIES(BEFORE ${QT_QTGUI_INCLUDE_DIR})
|
||||
IF (ParaView_SOURCE_DIR)
|
||||
INCLUDE_DIRECTORIES(
|
||||
${PARAVIEW_INCLUDE_DIRS}
|
||||
# we are building from within ParaView Source. The environment is already set.
|
||||
# Nothign more to do.
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Plugins/PointSprite/ParaViewPlugin/CMakeLists.txt.orig 2014-01-11 14:59:58.000000000 +0100
|
||||
+++ Plugins/PointSprite/ParaViewPlugin/CMakeLists.txt 2014-01-29 23:36:14.000000000 +0100
|
||||
@@ -6,6 +6,9 @@
|
||||
--- Plugins/PointSprite/ParaViewPlugin/CMakeLists.txt.orig 2016-11-14 15:41:57 UTC
|
||||
+++ Plugins/PointSprite/ParaViewPlugin/CMakeLists.txt
|
||||
@@ -6,6 +6,9 @@ include_directories(${VTK_INCLUDE_DIRS}
|
||||
${PointSpritePlugin_SOURCE_DIR}/Qvis
|
||||
${PointSpritePlugin_BINARY_DIR}/Qvis)
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- VTK/GUISupport/Qt/CMakeLists.txt.orig 2014-01-11 15:02:07.000000000 +0100
|
||||
+++ VTK/GUISupport/Qt/CMakeLists.txt 2014-01-29 23:50:07.000000000 +0100
|
||||
@@ -114,7 +114,10 @@
|
||||
set(QT_LIBRARIES ${Qt5Designer_LIBRARIES})
|
||||
--- VTK/GUISupport/Qt/CMakeLists.txt.orig 2016-11-14 15:41:57 UTC
|
||||
+++ VTK/GUISupport/Qt/CMakeLists.txt
|
||||
@@ -135,7 +135,10 @@ if(BUILD_SHARED_LIBS AND VTK_BUILD_QT_DE
|
||||
set(QT_LIBRARIES Qt5::${qt_component})
|
||||
else()
|
||||
add_definitions(-DQT_PLUGIN)
|
||||
- include_directories(${QT_QTDESIGNER_INCLUDE_DIR})
|
||||
|
@ -1,26 +0,0 @@
|
||||
--- VTK/Rendering/FreeType/vtkFreeTypeTools.cxx.orig 2014-01-11 15:02:09.000000000 +0100
|
||||
+++ VTK/Rendering/FreeType/vtkFreeTypeTools.cxx 2015-01-29 21:09:32.000000000 +0100
|
||||
@@ -1186,8 +1186,10 @@
|
||||
if (bitmap)
|
||||
{
|
||||
metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
|
||||
- metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
|
||||
- metaData.descent);
|
||||
+// metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
|
||||
+// metaData.descent);
|
||||
+ metaData.descent = std::min(-(static_cast<int>(bitmap->rows) - (bitmapGlyph->top - 1)),
|
||||
+ metaData.descent);
|
||||
}
|
||||
++heightString;
|
||||
}
|
||||
@@ -1951,8 +1953,8 @@
|
||||
if (bitmap)
|
||||
{
|
||||
bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
|
||||
- bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
|
||||
- bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
|
||||
+ bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + static_cast<int>(bitmap->width));
|
||||
+ bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - static_cast<int>(bitmap->rows));
|
||||
bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
|
||||
}
|
||||
else
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user