- Fix build on 6.3

- UNBREAK

Approved by:	portmgr (linimon)
This commit is contained in:
Pietro Cerutti 2008-09-11 08:09:49 +00:00
parent 5d6556dc39
commit 9c55c35b13
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=220332
2 changed files with 11 additions and 4 deletions

View File

@ -30,10 +30,6 @@ OPTIONS= LUA "Build with Lua scripting support" off
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
BROKEN= does not build
.endif
.if defined(WITH_LUA)
USE_LUA= 5.0+
.else

View File

@ -0,0 +1,11 @@
--- mrt/logger.cpp.orig 2008-09-11 09:12:44.000000000 +0200
+++ mrt/logger.cpp 2008-09-11 09:14:32.000000000 +0200
@@ -81,7 +81,7 @@
gettimeofday(&tv, NULL);
struct tm tm;
- localtime_r(&tv.tv_sec, &tm);
+ localtime_r((time_t *)&tv.tv_sec, &tm);
h = tm.tm_hour;
m = tm.tm_min;