Add p5-Audio-CD 0.04, a perl interface to libcdaudio.

PR:		22215
Submitted by:	Roman Shterenzon <roman@xpert.com>
This commit is contained in:
Will Andrews 2000-10-28 05:59:04 +00:00
parent a5f0c654a9
commit 9c52298bb9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34339
7 changed files with 63 additions and 0 deletions

View File

@ -100,6 +100,7 @@
SUBDIR += nspmod
SUBDIR += openal
SUBDIR += opennap
SUBDIR += p5-Audio-CD
SUBDIR += p5-MP3-ID3v1Tag
SUBDIR += p5-MP3-Info
SUBDIR += pimp3

View File

@ -0,0 +1,28 @@
# New ports collection makefile for: p5-Audio-CD
# Date created: 22 Oct 2000
# Whom: Roman Shterenzon <roman@xpert.com>
#
# $FreeBSD$
#
PORTNAME= Audio-CD
PORTVERSION= 0.04
CATEGORIES= audio perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Audio
PKGNAMEPREFIX= p5-
MAINTAINER= roman@xpert.com
LIB_DEPENDS= cdaudio.1:${PORTSDIR}/audio/libcdaudio
USE_PERL5= YES
MAN3= Audio::CD.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (Audio-CD-0.04.tar.gz) = 5b3051fd01a36c557a54e83ac0bde567

View File

@ -0,0 +1,12 @@
--- Makefile.PL.orig Wed May 17 08:12:52 2000
+++ Makefile.PL Sun Oct 22 17:41:36 2000
@@ -7,7 +7,8 @@
'macro' => {
CVSROOT => 'modperl.com:/local/cvs_repository',
},
- 'LIBS' => ["-lcdaudio"],
+ 'INC' => "-I$ENV{'PREFIX'}/include",
+ 'LIBS' => "-L$ENV{'PREFIX'}/lib -lcdaudio",
DEFINE => '-g',
OBJECT => 'cddb_lookup.o CD.o',
);

View File

@ -0,0 +1 @@
Perl interface to libcdaudio (cd + cddb)

View File

@ -0,0 +1,13 @@
Perl interface to libcdaudio (cd + cddb): http://cdcd.undergrid.net/
This module was created for adding CDDB support to <Xmms::shell> and
cd tray <eject>. I added methods for a good chunk of other
<libcdaudio> functions while I was at it, but the docs and glue is
not complete. I do not have interest in completing the interface and
docs, because xmms/Xmms::shell provides everything I need (at the
moment) for audio. If you have an interesting reason for needing the
missing pieces, I'll probably be interested in adding them.
WWW: http://www.perl.com/CPAN/authors/id/R/RC/RCAPUTO/
Roman Shterenzon <roman@xpert.com>

View File

@ -0,0 +1,7 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Audio/CD.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio/CD/CD.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio/CD/CD.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio/CD/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio/CD
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Audio 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Audio 2>/dev/null || true