Update to 1.10->1.11
Cleanup and make work for perl 5.00503 PR: 51688 Submitted by: maintainer Approved by: roberto (mentor)
This commit is contained in:
parent
44d66a7787
commit
9bfc6a9da3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82254
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= Text-Reform
|
||||
PORTVERSION= 1.10
|
||||
PORTVERSION= 1.11
|
||||
CATEGORIES= textproc perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= Text
|
||||
@ -18,6 +18,8 @@ COMMENT= Manual text wrapping and reformatting
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= Text::Reform.3
|
||||
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
|
||||
|
||||
pre-configure:
|
||||
@${FIND} ${WRKSRC} -name \*.orig -delete
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (Text-Reform-1.10.tar.gz) = 07608172aed9c4a5158a8184b8107029
|
||||
MD5 (Text-Reform-1.11.tar.gz) = 18646b9fee3d2ddecdacde1d9210d83d
|
||||
|
21
textproc/p5-Text-Reform/files/patch-lib::Text::Reform.pm
Normal file
21
textproc/p5-Text-Reform/files/patch-lib::Text::Reform.pm
Normal file
@ -0,0 +1,21 @@
|
||||
--- lib/Text/Reform.pm.orig Wed Apr 9 10:49:02 2003
|
||||
+++ lib/Text/Reform.pm Fri May 2 14:47:28 2003
|
||||
@@ -44,7 +43,7 @@
|
||||
}
|
||||
|
||||
sub carpfirst {
|
||||
- our %carped;
|
||||
+ my %carped;
|
||||
my ($msg) = @_;
|
||||
return if $carped{$msg}++;
|
||||
carp $msg;
|
||||
@@ -342,8 +341,7 @@
|
||||
|
||||
sub form
|
||||
{
|
||||
- our %carped;
|
||||
- local %carped;
|
||||
+ my %carped;
|
||||
my $config = {%std_config};
|
||||
my $startidx = 0;
|
||||
if (@_ && ref($_[0]) eq 'HASH') # RESETTING CONFIG
|
@ -1,3 +1,3 @@
|
||||
Manual text wrapping and reformatting
|
||||
|
||||
WWW: http://search.cpan.org/author/DCONWAY/Text-Reform/
|
||||
WWW: http://search.cpan.org/dist/Text-Reform/
|
||||
|
@ -1,8 +1,10 @@
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Reform/.packlist
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Text/demo_ws.pl
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Text/demo_table.pl
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Text/demo_filler.pl
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Text/demo_columns.pl
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Text/demo.pl
|
||||
lib/perl5/site_perl/%%PERL_VER%%/Text/Reform.pm
|
||||
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Reform
|
||||
%%SITE_PERL%%/Text/Reform.pm
|
||||
%%SITE_PERL%%/Text/demo.pl
|
||||
%%SITE_PERL%%/Text/demo_columns.pl
|
||||
%%SITE_PERL%%/Text/demo_filler.pl
|
||||
%%SITE_PERL%%/Text/demo_table.pl
|
||||
%%SITE_PERL%%/Text/demo_ws.pl
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Reform/.packlist
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Reform
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true
|
||||
|
Loading…
Reference in New Issue
Block a user