- Update to 18

PR:		ports/130047
Submitted by:	Pedro F. Giffuni <giffunip@tutopia.com>
Approved by:	maintainer timeout (2 months)
This commit is contained in:
Pav Lucistnik 2009-03-24 15:32:31 +00:00
parent 31771c66d0
commit 9bed3c1175
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=230864
9 changed files with 76 additions and 66 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= ngspice_rework
PORTVERSION= 17
PORTREVISION= 1
PORTVERSION= 18
CATEGORIES= cad
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ngspice
@ -16,12 +15,19 @@ DISTNAME= ng-spice-rework-${PORTVERSION}
MAINTAINER= amakawa@jp.FreeBSD.org
COMMENT= A circuit simulator derived from spice3f5
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:262
USE_GMAKE= yes
#XSPICE doesn't build
#CONFIGURE_ARGS+= --enable-xspice
.ifndef PACKAGE_BUILDING
CONFIGURE_ARGS+= --with-readline=yes
.else
CONFIGURE_ARGS+= --disable-debug
.endif
INFO= ngspice
MAN1= ngspice.1 ngnutmeg.1 ngsconvert.1
MAN1= ngspice.1 ngnutmeg.1 ngsconvert.1 ngmultidec.1
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (ng-spice-rework-17.tar.gz) = abe283dea98b913a2122f085076865b1
SHA256 (ng-spice-rework-17.tar.gz) = 58ec02a0ab48369724c9e98f9a6aa3e0f400ae7b361ba194f4bf06d1420f4496
SIZE (ng-spice-rework-17.tar.gz) = 5919637
MD5 (ng-spice-rework-18.tar.gz) = 3ab09b939939f7d0fb8cc9d8c77ead71
SHA256 (ng-spice-rework-18.tar.gz) = 1ae8ff5db42a0ca89803faed17fca75836f7c4f8dc026530efabc57eb4956954
SIZE (ng-spice-rework-18.tar.gz) = 7061554

View File

@ -1,11 +0,0 @@
--- configure.orig Tue Aug 30 16:58:35 2005
+++ configure Sat Dec 10 19:15:02 2005
@@ -3365,7 +3365,7 @@
if test "$enable_debug" = "no"; then
{ echo "$as_me:$LINENO: WARNING: Removing debugging option!" >&5
echo "$as_me: WARNING: Removing debugging option!" >&2;}
- CFLAGS=" "
+# CFLAGS=" "
fi
if test "x$GCC" = "xyes"; then

View File

@ -0,0 +1,23 @@
--- configure.in.orig 2008-12-29 19:13:00.000000000 -0500
+++ configure.in 2008-12-29 19:16:35.000000000 -0500
@@ -205,16 +205,16 @@
if test "$enable_debug" = "no"; then
if test "x$GCC" = "xyes"; then
AC_MSG_WARN(Removing debugging option!)
- CFLAGS="$ext_CFLAGS -O2 -Wall -s"
+ CFLAGS+="$ext_CFLAGS -O2 -Wall -s"
else
AC_MSG_WARN(Removing debugging option!)
- CFLAGS="$ext_CFLAGS -O2"
+ CFLAGS+="$ext_CFLAGS -O2"
fi
else
if test "x$GCC" = "xyes"; then
- CFLAGS="$ext_CFLAGS -g -O0 -Wall"
+ CFLAGS+="$ext_CFLAGS -g -O0 -Wall"
else
- CFLAGS="$ext_CFLAGS -g"
+ CFLAGS+="$ext_CFLAGS -g"
fi
fi

View File

@ -1,11 +1,11 @@
--- doc/Makefile.in.orig Sat Dec 10 18:03:00 2005
+++ doc/Makefile.in Sat Dec 10 18:05:11 2005
@@ -113,7 +113,7 @@
--- doc/Makefile.in.orig 2008-11-30 11:12:39.000000000 -0500
+++ doc/Makefile.in 2008-12-29 15:41:25.000000000 -0500
@@ -114,7 +114,7 @@
LN_S = @LN_S@
LTLIBOBJS = @LTLIBOBJS@
MAINT = @MAINT@
MAINTAINER_MODE_FALSE = @MAINTAINER_MODE_FALSE@
MAINTAINER_MODE_TRUE = @MAINTAINER_MODE_TRUE@
-MAKEINFO = @MAKEINFO@
+MAKEINFO = @MAKEINFO@ --no-split
NOTXGRAPH = @NOTXGRAPH@
NUMDEV = @NUMDEV@
NUMDEVDIR = @NUMDEVDIR@
MKDIR_P = @MKDIR_P@
NDEV_DIR = @NDEV_DIR@
NDEV_LIB = @NDEV_LIB@

View File

@ -1,40 +1,10 @@
--- src/frontend/resource.c.orig Thu Jun 30 23:38:21 2005
+++ src/frontend/resource.c Sat Dec 10 20:41:22 2005
@@ -424,6 +424,7 @@
--- src/frontend/resource.c.orig 2008-11-19 14:45:28.000000000 -0500
+++ src/frontend/resource.c 2008-12-29 15:44:52.000000000 -0500
@@ -605,6 +605,7 @@
fault(void)
{
signal(SIGSEGV, (SIGNAL_FUNCTION) fault); /* SysV style */
+ signal(SIGBUS, (SIGNAL_FUNCTION) fault); /* SysV style */
LONGJMP(env, 1);
signal(SIGSEGV, (SIGNAL_FUNCTION) fault); /* SysV style */
+ signal(SIGBUS, (SIGNAL_FUNCTION) fault); /* SysV style */
LONGJMP(env, 1);
}
@@ -436,7 +437,8 @@
char *low, *high, *at;
/* char *sbrk(int); */
long x;
- RETSIGTYPE (*orig_signal)( );
+ RETSIGTYPE (*orig_sigsegv)( );
+ RETSIGTYPE (*orig_sigbus)( );
if (getenv("SPICE_NO_DATASEG_CHECK"))
return 0;
@@ -444,7 +446,8 @@
low = 0;
high = (char *) ((unsigned long) sbrk(0) & ~((1 << LOG2_PAGESIZE) - 1));
- orig_signal = signal(SIGSEGV, (SIGNAL_FUNCTION) fault);
+ orig_sigsegv = signal(SIGSEGV, (SIGNAL_FUNCTION) fault);
+ orig_sigbus = signal(SIGBUS, (SIGNAL_FUNCTION) fault);
do {
@@ -472,7 +475,8 @@
} while (1);
- (void) signal(SIGSEGV, (SIGNAL_FUNCTION) orig_signal);
+ (void) signal(SIGSEGV, (SIGNAL_FUNCTION) orig_sigsegv);
+ (void) signal(SIGBUS, (SIGNAL_FUNCTION) orig_sigbus);
return (void *) high;
#endif

View File

@ -0,0 +1,14 @@
--- src/xspice/icm/Makefile.orig 2008-12-29 15:47:40.000000000 -0500
+++ src/xspice/icm/Makefile 2008-12-29 15:48:36.000000000 -0500
@@ -12,9 +12,9 @@
-include .deps/cm.P
-include .deps/dlmain.P
-UPMAKE = make -f $(TOPDIR)../Makefile TOPDIR=$(TOPDIR)../
+UPMAKE = gmake -f $(TOPDIR)../Makefile TOPDIR=$(TOPDIR)../
-MAKE = make -f $(TOPDIR)Makefile TOPDIR=$(TOPDIR)
+MAKE = gmake -f $(TOPDIR)Makefile TOPDIR=$(TOPDIR)
COMPILE = $(CC) $(INCLUDES) $(CFLAGS)

View File

@ -0,0 +1,11 @@
--- src/xspice/ipc/ipcstdio.c.orig Mon Nov 19 15:13:29 2007
+++ src/xspice/ipc/ipcstdio.c Mon Nov 19 15:18:42 2007
@@ -40,7 +40,7 @@
Ipc_Wait_t wait;
{
printf ("GET_LINE\n");
- gets (str);
+ fgets (str, sizeof str, stdin);
*len = strlen (str);
return IPC_STATUS_OK;
}

View File

@ -1,17 +1,14 @@
bin/makeidx
bin/nghelp
bin/ngmakeidx
bin/ngmultidec
bin/ngnutmeg
bin/ngproc2mod
bin/ngsconvert
bin/ngspice
lib/ng-spice-rework/libbsim4.a
share/ng-spice-rework/helpdir/ngspice.idx
share/ng-spice-rework/helpdir/ngspice.txt
share/ng-spice-rework/scripts/setplot
share/ng-spice-rework/scripts/spectrum
share/ng-spice-rework/scripts/spinit
@dirrm lib/ng-spice-rework
@dirrm share/ng-spice-rework/helpdir
@dirrm share/ng-spice-rework/scripts
@dirrm share/ng-spice-rework