upgrade to 1.7g0

PR:		46586
Submitted by:	Ports Fury
This commit is contained in:
Ying-Chieh Liao 2003-01-03 20:16:07 +00:00
parent dacd70f301
commit 9b9f2251a6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72461
7 changed files with 27 additions and 58 deletions

View File

@ -6,11 +6,11 @@
#
PORTNAME= bzflag
PORTVERSION= 1.7e.6
PORTVERSION= 1.7g.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bzflag
DISTNAME= ${PORTNAME}-${PORTVERSION:S/e./e/}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@ -36,9 +36,9 @@ post-build:
@(cd ${WRKSRC}/man && ${MAKE} targets)
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin/
@${INSTALL_MAN} ${WRKSRC}/man/*.6 ${PREFIX}/man/man6/
@${MKDIR} ${PREFIX}/share/bzflag/data
@${INSTALL_DATA} ${WRKSRC}/data/* ${PREFIX}/share/bzflag/data/
${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/man/*.6 ${MANPREFIX}/man/man6/
@${MKDIR} ${DATADIR}/data
${INSTALL_DATA} ${WRKSRC}/data/* ${DATADIR}/data/
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (bzflag-1.7e6.tgz) = 0afedee9279c305c0acda563287ad0f2
MD5 (bzflag-1.7g0.tgz) = 689009fa98416ac1abba4677870c7b9f

View File

@ -1,18 +1,11 @@
--- include/BzfString.h.orig Sat Nov 23 15:04:54 2002
+++ include/BzfString.h Sat Nov 23 15:05:16 2002
@@ -39,12 +39,14 @@
--- include/BzfString.h.orig Thu Oct 17 04:29:38 2002
+++ include/BzfString.h Mon Dec 9 22:08:01 2002
@@ -40,6 +40,8 @@
#include "common.h"
-#if defined(sun) || defined(__MWERKS__)
+#if 1
// solaris compiler doesn't like declaration of ostream
#include "bzfio.h"
#else
class ostream;
#endif
+
+using std::ostream;
+using std::ostream;
+
class BzfString {
public:
BzfString();

View File

@ -1,6 +1,6 @@
--- src/bzflag/bzflag.cxx.orig Sat Nov 23 15:16:44 2002
+++ src/bzflag/bzflag.cxx Sat Nov 23 15:17:53 2002
@@ -756,7 +756,7 @@
--- src/bzflag/bzflag.cxx.orig Fri Dec 6 02:22:44 2002
+++ src/bzflag/bzflag.cxx Mon Dec 9 22:09:36 2002
@@ -769,7 +769,7 @@
// read resources
{
@ -8,13 +8,4 @@
+ #if 1
ifstream resourceStream(getConfigFileName(), ios::in);
#else
ifstream resourceStream(getConfigFileName(), ios::in | ios::nocreate);
@@ -768,7 +768,7 @@
#if !defined(_WIN32) & !defined(macintosh)
else {
- ifstream resourceStream2(getConfigFileName2(), ios::in | ios::nocreate);
+ ifstream resourceStream2(getConfigFileName2(), ios::in);
if (resourceStream2) {
startupInfo.hasConfiguration = True;
resourceStream2 >> db;
ifstream resourceStream(getConfigFileName(), ios::in);

View File

@ -1,11 +0,0 @@
--- src/bzfs/bzfs.cxx.orig Sat Nov 23 15:03:31 2002
+++ src/bzfs/bzfs.cxx Sat Nov 23 15:03:45 2002
@@ -2805,7 +2805,7 @@
static WorldInfo *defineWorldFromFile(const char *filename)
{
// open file
- ifstream input(filename, ios::in | ios::nocreate);
+ ifstream input(filename, ios::in);
if (!input) {
cerr << "could not find bzflag world file : " << filename << endl;
return NULL;

View File

@ -1,18 +1,11 @@
--- src/bzflag/resources.h.orig Sat Nov 23 15:18:38 2002
+++ src/bzflag/resources.h Sat Nov 23 15:18:59 2002
@@ -20,12 +20,13 @@
#include "common.h"
--- src/bzflag/resources.h.orig Thu Oct 17 04:38:17 2002
+++ src/bzflag/resources.h Mon Dec 9 22:11:54 2002
@@ -21,6 +21,8 @@
#include "BzfString.h"
-#if defined(sun) || defined(macintosh)
-// solaris compiler doesn't like declaration of istream
+#if 1
#include "bzfio.h"
#else
class istream;
#endif
+
+using namespace std;
+using namespace std;
+
class ResourceDatabase {
public:
ResourceDatabase();

View File

@ -47,6 +47,7 @@ share/bzflag/data/ricochet.wav
share/bzflag/data/rlaser.rgb
share/bzflag/data/roof.rgb
share/bzflag/data/shock.wav
share/bzflag/data/teamgrab.wav
share/bzflag/data/teleport.wav
share/bzflag/data/timesbi.rgb
share/bzflag/data/timesbr.rgb
@ -54,3 +55,5 @@ share/bzflag/data/title.rgb
share/bzflag/data/wall.rgb
share/bzflag/data/ybolt.rgb
share/bzflag/data/ylaser.rgb
@dirrm share/bzflag/data
@dirrm share/bzflag