Don't compile haval.1996/haval.c separately, but as part of the top

haval.c (as in vendor's code). This works around weirdness in vendor's
endianness-determining pre-processor code and unbreaks sparc64. Much
rejoicing...
This commit is contained in:
Mikhail Teterin 2004-07-12 17:56:58 +00:00
parent 262fe773b3
commit 9b8ac30742
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113480
3 changed files with 2 additions and 26 deletions

View File

@ -82,10 +82,6 @@ post-install:
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
BROKEN= "Fails testsuite during build"
.endif
SHLIB_NAME= libTrf2.so.1
SHLIB_LINK= ${SHLIB_NAME:C/\.so\..*/.so/}

View File

@ -52,7 +52,7 @@
- *
* MDHaval_Update --
*
@@ -145,63 +116,2 @@
@@ -145,63 +116,3 @@
haval_hash ((CTX_TYPE*) context, &buf, 1);
}
-
@ -115,4 +115,4 @@
- * External code from here on.
- */
-
-#include "haval.1996/haval.c" /* THREADING: import of one constant var, read-only => safe */
#include "haval.1996/haval.c" /* THREADING: import of one constant var, read-only => safe */

View File

@ -13,12 +13,6 @@
- $(TRF_GENSRCDIR)/loadman.c \
$(TRF_GENSRCDIR)/init.c \
$(TRF_GENSRCDIR)/registry.c \
@@ -82,4 +81,5 @@
$(TRF_GENSRCDIR)/md5dig.c \
$(TRF_GENSRCDIR)/haval.c \
+ $(TRF_GENSRCDIR)/haval.1996/haval.c \
$(TRF_GENSRCDIR)/sha.c \
$(TRF_GENSRCDIR)/adler.c \
@@ -123,7 +123,5 @@
$(TRF_COMPRESS_OBJ)
@ -28,12 +22,6 @@
+TRF_BASE_OBJ = @DL_OBJS@ \
init.$(OBJEXT) \
registry.$(OBJEXT) \
@@ -157,4 +155,5 @@
md5dig.$(OBJEXT) \
haval.$(OBJEXT) \
+ haval-1996.$(OBJEXT) \
sha.$(OBJEXT) \
adler.$(OBJEXT) \
@@ -191,5 +190,5 @@
#========================================================================
@ -69,14 +57,6 @@
+test: $(Trf_LIB_FILE)
LD_LIBRARY_PATH="$(srcdir):../tea/:$(ZLIB_LIB_DIR):$(SSL_LIB_DIR)"; \
export LD_LIBRARY_PATH; \
@@ -612,4 +611,7 @@
$(COMPILE) -c `@CYGPATH@ $(TRF_GENSRCDIR)/haval.c` -o $@
+haval-1996.o: $(TRF_GENSRCDIR)/haval.1996/haval.c
+ $(COMPILE) -c `@CYGPATH@ $(TRF_GENSRCDIR)/haval.1996/haval.c` -o $@
+
sha.$(OBJEXT): $(TRF_GENSRCDIR)/sha.c
$(COMPILE) -c `@CYGPATH@ $(TRF_GENSRCDIR)/sha.c` -o $@
@@ -755,5 +757,5 @@
done
if test "x$(MAKE_LIB)" = "x$(MAKE_SHARED_LIB)"; then \