- Get rid FreeBSD 6.x support

This commit is contained in:
Martin Wilke 2011-11-07 03:25:29 +00:00
parent 2167bc17ca
commit 9b44799b8a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=285199
22 changed files with 12 additions and 137 deletions

View File

@ -37,9 +37,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/FastDB.htm ${DOCSDIR}
.endif
post-patch:
.if ${OSVERSION} < 601105
${REINPLACE_CMD} -e 's|^#define HAVE_GETHOSTBYNAME_R||' ${WRKSRC}/inc/config.h
.endif
.include <bsd.port.post.mk>

View File

@ -21,12 +21,4 @@ CPPFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
post-patch:
.if ${OSVERSION} < 601103
@${REINPLACE_CMD} -e \
'/GETHOSTBYNAME_R/s|^#define|// #define|g' ${WRKSRC}/config.h
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -45,12 +45,6 @@ INSTALLS_ICONS= yes
#OPTIONS= SELF_HOSTING "Host the database locally" on
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
BROKEN= does not configure on 6.x
.endif
#.if defined(WITH_SELF_HOSTING)
# Note: USE_PGSQL has already been set above.
BUILD_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
@ -66,4 +60,4 @@ post-patch:
post-install:
@-update-mime-database ${PREFIX}/share/mime
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -28,12 +28,6 @@ PLIST_FILES= %%JAVAJARDIR%%/jrrd.jar \
lib/libjrrd.la \
lib/libjrrd.so
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
BROKEN= does not configure on 6.X
.endif
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Installation settings:"
@ -41,4 +35,4 @@ pre-everything::
@${ECHO_MSG} " Location of Java port: ${JAVA_PORT}"
@${ECHO_MSG} ""
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -45,10 +45,6 @@ LUA_COMPS= lua
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
BROKEN= does not build on 6.x
.endif
.if ${PKGNAMESUFFIX} == 51
CONFLICTS= mysql-workbench-oss52*
.endif

View File

@ -33,13 +33,7 @@ CONFIGURE_ARGS= --with-rrd="${LOCALBASE}" --datadir="${PREFIX}/www" \
SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
BROKEN= does not configure on 6.X
.endif
post-install:
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -26,10 +26,4 @@ USE_PHP= yes
DEFAULT_PHP_VER=5
USE_PHPEXT= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
BROKEN= does not configure on 6.X
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -46,9 +46,6 @@ OPTIONS= DEJAVU "Use DejaVu fonts (requires X11)" off \
.include <bsd.port.options.mk>
.if ${OSVERSION} < 700000
BROKEN= does not configure
.endif
.if defined(WITH_PYTHON_MODULE)
USE_PYTHON= yes

View File

@ -69,10 +69,6 @@ PORTDOCS= *
MAN1= sqlite3.1
.endif
.if ${OSVERSION} < 700000
EXTRA_PATCHES+= ${FILESDIR}/pthread_equal_stub
.endif
# DEBUG "Enable debugging & verbose explain" off \
# This options used only for debug and is not required during normal work
# applications or its libraries.

View File

@ -1,11 +0,0 @@
--- src/mutex_unix.c.orig 2009-09-18 12:39:33.000000000 +0200
+++ src/mutex_unix.c 2009-09-18 12:39:04.000000000 +0200
@@ -326,4 +326,8 @@
return &sMutex;
}
+int pthread_equal() __attribute__ ((weak));
+
+#define pthread_equal(a,b) ((pthread_equal) ? pthread_equal(a,b) : 1)
+
#endif /* SQLITE_MUTEX_PTHREAD */

View File

@ -82,10 +82,6 @@ pre-everything::
CPPFLAGS+= -I${LOCALBASE}/include -Wno-deprecated-declarations
.if ${OSVERSION} < 700000
IGNORE= needs 7.X or higher
.endif
.if defined(WITH_DEBUGGING)
CONFIGURE_ARGS+= --enable-debug
.endif

View File

@ -32,12 +32,6 @@ PORTDOCS= AUTHORS COPYING ChangeLog ChangeLog-2008 ChangeLog-2009 INSTALL \
MAINTAINERS NEWS README TODO export-format-id io-provider-id \
objects-hierarchy.odg
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
.endif
post-patch:
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's| install-dist_pkgdocDATA||g' \
@ -47,4 +41,4 @@ post-patch:
${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,20 +0,0 @@
--- configure.orig 2009-10-19 21:06:41.000000000 +1000
+++ configure 2009-10-19 23:38:22.000000000 +1000
@@ -4718,7 +4718,7 @@
_ac_warning_def=error
- _ac_compliant_def="-ansi -Wno-overlength-strings -Wformat=2"
+ _ac_compliant_def="-ansi -Wformat=2"
# Check whether --enable-compile-warnings was given.
@@ -4808,7 +4808,7 @@
done
unset option
if test "$enable_compile_warnings" = "error" ; then
- warning_flags="$warning_flags -Werror"
+ warning_flags="$warning_flags"
fi
;;
*)

View File

@ -79,10 +79,6 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
.endif
.if ${OSVERSION} < 700000
BROKEN= does not compile
.endif
post-extract:
# remove pre-generated messages catalogs
${FIND} ${WRKSRC}/po -name "*.gmo" -delete

View File

@ -36,7 +36,7 @@ MAN1= ace-gperf.1
.include <bsd.port.pre.mk>
.if (${OSVERSION} >= 601103 && ${OSVERSION} < 700000) || ${OSVERSION} >= 700015
.if ${OSVERSION} >= 700015
EXTRA_PATCHES+= ${FILESDIR}/extra-ace-OS_NS_netdb.inl
.endif

View File

@ -75,12 +75,6 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
.if ${OSVERSION} < 700000
PLIST_SUB+= POST7="@comment " PRE7=""
.else
PLIST_SUB+= POST7="" PRE7="@comment "
.endif
.if ${ARCH} == "amd64"
ARCH= x86_64
.endif

View File

@ -21,8 +21,7 @@ include/dis-asm.h
include/symcat.h
lib/libbfd.a
lib/libbfd.la
%%PRE7%%lib/elf/libiberty.a
%%POST7%%lib/libiberty.a
lib/libiberty.a
lib/libopcodes.a
lib/libopcodes.la
%%NLS%%share/locale/da/LC_MESSAGES/bfd.mo

View File

@ -39,8 +39,6 @@ PLIST_SUB+= NLS=""
.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
.include <bsd.port.pre.mk>
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
@${REINPLACE_CMD} 's/MANS = yacc.1/MANS =/' ${WRKSRC}/doc/Makefile.in
@ -48,13 +46,6 @@ post-extract:
@${REINPLACE_CMD} 's/ install-exec-local//' ${WRKSRC}/lib/Makefile.in
.endif
#
# Requires texinfo 4.8 or above
#
.if ${OSVERSION} < 601000
@${REINPLACE_CMD} "/^@headitem/d" ${WRKSRC}/doc/bison.texinfo
.endif
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${EXAMPLESDIR}/calc++
@ -62,4 +53,4 @@ post-install:
${EXAMPLESDIR}/calc++
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -41,7 +41,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 700032 || (${OSVERSION} < 700000 && ${OSVERSION} > 602106)
.if ${OSVERSION} > 700032
CONFIGURE_ARGS+= --with-ncursesw --enable-widec
.else
CONFIGURE_ARGS+= --with-ncurses

View File

@ -24,12 +24,6 @@ USE_PERL5_RUN= yes
MAN1= cscout.1 cswc.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700000
LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
.endif
post-patch:
.if exists(/usr/include/g++/)
${REINPLACE_CMD} -i "" -e 's:g++-3:g++:g' \
@ -67,4 +61,4 @@ do-install:
.endfor
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -26,10 +26,6 @@ MAN1= dwarfdump.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
LIB_DEPENDS+= elf.0:${PORTSDIR}/devel/libelf
.endif
.if (${ARCH} == "amd64")
ARCH= x86_64
.endif

View File

@ -25,12 +25,6 @@ ALL_TARGET= dist
PLIST_FILES= ${JAVAJARDIR:C^${PREFIX}/^^}/${PORTNAME}.jar
PORTDOCS= "User Guide.pdf" api
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
BROKEN= does not install on 6.x
.endif
do-install:
${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
@ -42,4 +36,4 @@ post-install:
@${ECHO_MSG} " [ DONE ]"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>