Clean up historic entanglements with other ports:

* Merge Makefile and Makefile.inc.
* Add our own proper pkg-descr file.
* Remove support for building a BMP plugin.
This commit is contained in:
Christian Weisgerber 2015-04-11 19:31:22 +00:00
parent 5375f83a0a
commit 9b3c714d67
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=383825
4 changed files with 43 additions and 60 deletions

View File

@ -1,11 +1,39 @@
# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
PORTNAME= faad2
PORTVERSION= 2.7
PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= SF/faac/${PORTNAME}-src/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= xmms-
MAINTAINER= naddy@FreeBSD.org
COMMENT= XMMS plugin for faad
COMMENT= XMMS plugin for MP4/M4A/AAC files
MASTERDIR= ${.CURDIR}
LIB_DEPENDS= libxmms.so:${PORTSDIR}/multimedia/xmms \
libfaad.so:${PORTSDIR}/audio/faad
.include "${MASTERDIR}/Makefile.inc"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/plugins/xmms/src
USE_GNOME= gtk12
USES= pkgconfig tar:bzip2
WANT_GNOME= yes
EXTRA_CFLAGS= `xmms-config --cflags`
EXTRA_LDFLAGS= `xmms-config --libs`
PLUGINS_DIR= ${PREFIX}/lib/xmms/Input
PLIST_FILES= ${PLUGINS_DIR:S,^${PREFIX}/,,}/libmp4.so
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -fPIC -shared \
-I${LOCALBASE}/include -DHAVE_STDINT_H \
${EXTRA_CFLAGS} *.c -o libmp4.so \
-L${LOCALBASE}/lib -lfaad -lmp4ff \
${EXTRA_LDFLAGS}
do-install:
@${MKDIR} ${STAGEDIR}${PLUGINS_DIR}
cd ${WRKSRC}; ${INSTALL_LIB} libmp4.so ${STAGEDIR}${PLUGINS_DIR}
.include <bsd.port.mk>

View File

@ -1,39 +0,0 @@
# $FreeBSD$
PORTNAME= faad2
PORTVERSION= 2.7
PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= SF/faac/${PORTNAME}-src/${PORTNAME}-${PORTVERSION}
BUILD_DEPENDS= faad2>=2.7:${PORTSDIR}/audio/faad
RUN_DEPENDS= faad2>=2.7:${PORTSDIR}/audio/faad
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/plugins/xmms/src
USES+= pkgconfig tar:bzip2
WANT_GNOME= yes
DESCR= ${PORTSDIR}/audio/faad/pkg-descr
PLIST_FILES= ${PLUGINS_DIR:S,^${PREFIX}/,,}/libmp4.so
.if ${PKGNAMEPREFIX} == "xmms-"
LIB_DEPENDS+= libxmms.so:${PORTSDIR}/multimedia/xmms
USE_GNOME+= gtk12
PLUGINS_DIR= ${PREFIX}/lib/xmms/Input
EXTRA_CFLAGS= `xmms-config --cflags`
EXTRA_LDFLAGS+= `xmms-config --libs`
.endif
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -fPIC -shared \
-I${LOCALBASE}/include -DHAVE_STDINT_H \
${EXTRA_CFLAGS} *.c -o libmp4.so \
-L${LOCALBASE}/lib -lfaad -lmp4ff \
${EXTRA_LDFLAGS}
do-install:
@${MKDIR} ${STAGEDIR}${PLUGINS_DIR}
cd ${WRKSRC}; ${INSTALL_LIB} libmp4.so ${STAGEDIR}${PLUGINS_DIR}
.include <bsd.port.mk>

View File

@ -1,6 +1,6 @@
--- mp4_utils.c.orig 2004-10-18 05:44:51.000000000 +0900
+++ mp4_utils.c 2009-02-12 02:53:15.000000000 +0900
@@ -3,15 +3,22 @@
--- mp4_utils.c.orig 2004-10-17 20:44:51 UTC
+++ mp4_utils.c
@@ -3,7 +3,7 @@
*/
#include "mp4ff.h"
@ -9,18 +9,3 @@
#include <gtk/gtk.h>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
+
+#if defined(HAVE_BMP)
+#include <bmp/plugin.h>
+#include <bmp/titlestring.h>
+#include <bmp/util.h>
+#else
#include <xmms/plugin.h>
#include <xmms/titlestring.h>
#include <xmms/util.h>
+#endif /*HAVE_BMP*/
const char *mp4AudioNames[]=
{

View File

@ -0,0 +1,9 @@
FAAD2 (Freeware Advanced Audio Decoder) is an MPEG-2, MPEG-4 AAC decoder.
FAAD2 is the fastest ISO AAC audio decoder available and can be used with
DRM (Digital Radio Mondiale), and supports HE (High Efficiency), Main,
LC, LD, LTP, PS (Parametric Stereo) AAC files.
This is an XMMS plugin for playing MPEG-4 AAC files.
WWW: http://www.audiocoding.com/