sysutils/py-salt: Update to 3005.1

PR:		267845
Reported by:	i.dani at outlookdottcom
This commit is contained in:
Kirill Ponomarev 2022-11-18 15:22:35 +01:00
parent 56fc85f200
commit 9b3b2cf320
3 changed files with 52 additions and 4 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= salt
PORTVERSION= 3005
PORTVERSION= 3005.1
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -20,6 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}psutil>=0.3.0:sysutils/py-psutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=1.0.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jmespath>0:devel/py-jmespath@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyinotify>0:devel/py-pyinotify@${PY_FLAVOR}
USES= cpe python:3.6-3.9

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1661580885
SHA256 (salt-3005.tar.gz) = 1d200c45b88046178ea56fb5a75726dc620cc5e51411076a04df80ff52f79cd4
SIZE (salt-3005.tar.gz) = 17894520
TIMESTAMP = 1668768917
SHA256 (salt-3005.1.tar.gz) = fa14c5d873f863b50950121d7e23a2449502745490c7c48c0cf045406cfe57c1
SIZE (salt-3005.1.tar.gz) = 17914349

View File

@ -0,0 +1,47 @@
From 1b7fac1599a50c970fdef49abca7151cb11bdcd0 Mon Sep 17 00:00:00 2001
From: Pedro Algarvio <palgarvio@vmware.com>
Date: Tue, 11 Oct 2022 21:19:21 +0100
Subject: [PATCH] Disable the setuptools user warning "Setuptools is replacing
distutils."
Once we stop relying on distutils, this filter can be removed.
Signed-off-by: Pedro Algarvio <palgarvio@vmware.com>
---
salt/__init__.py | 8 ++++++++
setup.py | 2 ++
2 files changed, 10 insertions(+)
diff --git a/salt/__init__.py b/salt/__init__.py
index ebc54ac8443c..ec551abbc62a 100644
--- salt/__init__.py
+++ salt/__init__.py
@@ -69,6 +69,14 @@ def load_module(self, name):
append=True,
)
+# Filter the setuptools UserWarning until we stop relying on distutils
+warnings.filterwarnings(
+ "ignore",
+ message="Setuptools is replacing distutils.",
+ category=UserWarning,
+ module="_distutils_hack",
+)
+
def __define_global_system_encoding_variable__():
import sys
diff --git a/setup.py b/setup.py
index 0fac50ab4bc6..9d994ac8730c 100755
--- setup.py
+++ setup.py
@@ -4,6 +4,8 @@
"""
# pylint: disable=file-perms,resource-leakage
+import setuptools # isort:skip
+
import contextlib
import distutils.dist
import glob