Add papaya 0.90, graphical GTK mud client with plugin support.

PR:		32956
Submitted by:	Edwin Groothuis <edwin@mavetju.org>
This commit is contained in:
Pete Fritchman 2001-12-19 09:46:11 +00:00
parent d15cb1b623
commit 9b2f027b72
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51807
11 changed files with 219 additions and 0 deletions

View File

@ -326,6 +326,7 @@
SUBDIR += p5-XPC
SUBDIR += p5-perl-ldap
SUBDIR += pancho
SUBDIR += papaya
SUBDIR += passlogd
SUBDIR += pathchar
SUBDIR += pchar

40
net/papaya/Makefile Normal file
View File

@ -0,0 +1,40 @@
# New ports collection makefile for: papaya
# Date created: 23 August 2001
# Whom: Edwin Groothuis <edwin@mavetju.org>
#
# $FreeBSD$
#
PORTNAME= papaya
PORTVERSION= 0.90
CATEGORIES= net
MASTER_SITES= http://www.gtk-papaya.org/downloads/source/
DISTNAME= papaya-src-${PORTVERSION}
MAINTAINER= edwin@mavetju.org
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GTK= yes
WANT_GNOME= yes
.include <bsd.port.pre.mk>
.if !defined(HAVE_GNOME)
CONFIGURE_ARGS+= --disable-gnome
.endif
CONFIGURE_ENV+= GLIBCONFIG=${GLIB_CONFIG} GTKCONFIG=${GTK_CONFIG}
MAKE_ARGS+= PTHREAD_LIBS=${PTHREAD_LIBS} CXX="${CXX}"
post-patch:
@${PERL} -pi -e "s|/usr/local|${PREFIX}|" \
${WRKSRC}/src/install-system.sh
@${PERL} -pi -e "s|\@INSTALL\@|${INSTALL_PROGRAM}|g; \
s|\@INSTALL_DATA\@|${INSTALL_DATA}|g" \
${WRKSRC}/src/install-system.sh ${WRKSRC}/po/Makefile.in.in
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

1
net/papaya/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (papaya-src-0.90.tar.gz) = e0d61b27fba539b66a0fc87728410770

View File

@ -0,0 +1,25 @@
$FreeBSD$
--- Makefile.in.orig Mon Dec 17 22:13:42 2001
+++ Makefile.in Mon Dec 17 22:14:04 2001
@@ -6,17 +6,17 @@
all:
for subdir in $(SUBDIRS); do \
- make -C $$subdir; \
+ ${MAKE} -C $$subdir; \
done
clean:
for subdir in $(SUBDIRS); do \
- make -C $$subdir clean; \
+ ${MAKE} -C $$subdir clean; \
done
install:
for subdir in $(SUBDIRS); do \
- make -C $$subdir install; \
+ ${MAKE} -C $$subdir install; \
done
dist: Makefile

View File

@ -0,0 +1,61 @@
$FreeBSD$
--- configure.orig Mon Oct 15 21:41:00 2001
+++ configure Mon Dec 17 22:55:13 2001
@@ -2546,7 +2546,7 @@
CATOBJEXT=.cat
INSTOBJEXT=.cat
DATADIRNAME=lib
- INTLDEPS='$(top_builddir)/intl/libintl.a'
+ INTLDEPS='$(PREFIX)/lib/libintl.a'
INTLLIBS=$INTLDEPS
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
nls_cv_header_intl=intl/libintl.h
@@ -2675,7 +2675,7 @@
CATOBJEXT=.gmo
INSTOBJEXT=.mo
DATADIRNAME=share
- INTLDEPS='$(top_builddir)/intl/libintl.a'
+ INTLDEPS='$(PREFIX)/lib/libintl.a'
INTLLIBS=$INTLDEPS
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
nls_cv_header_intl=intl/libintl.h
@@ -3095,7 +3095,7 @@
# Extract the first word of "gtk-config", so it can be a program name with args.
-set dummy gtk-config; ac_word=$2
+set dummy ${GTK_CONFIG}; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
echo "configure:3101: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_GTKCONFIG'+set}'`\" = set"; then
@@ -3130,15 +3130,15 @@
fi
if test "x$GTKCONFIG" != "x"; then
- GTK_INC=`gtk-config --cflags`
- LIBGTK=`gtk-config --libs`
+ GTK_INC=`${GTK_CONFIG} --cflags`
+ LIBGTK=`${GTK_CONFIG} --libs`
LIBS="$LIBS $LIBGTK"
else
{ echo "configure: error: *** gtk is required ***" 1>&2; exit 1; }
fi
# Extract the first word of "glib-config", so it can be a program name with args.
-set dummy glib-config; ac_word=$2
+set dummy ${GLIB_CONFIG}; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
echo "configure:3144: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_GLIBCONFIG'+set}'`\" = set"; then
@@ -3173,8 +3173,8 @@
fi
if test "x$GLIBCONFIG" != "x"; then
- GLIB_INC=`glib-config --cflags`
- LIBGLIB=`glib-config --libs`
+ GLIB_INC=`${GLIB_CONFIG} --cflags`
+ LIBGLIB=`${GLIB_CONFIG} --libs`
LIBS="$LIBS $LIBGLIB"
else
{ echo "configure: error: *** glib is required ***" 1>&2; exit 1; }

View File

@ -0,0 +1,43 @@
--- /dev/null Fri Aug 24 22:05:18 2001
+++ mkinstalldirs Fri Aug 24 22:06:29 2001
@@ -0,0 +1,40 @@
+#! /bin/sh
+# mkinstalldirs --- make directory hierarchy
+# Author: Noah Friedman <friedman@prep.ai.mit.edu>
+# Created: 1993-05-16
+# Public domain
+
+# $Id: mkinstalldirs,v 1.1 1998/07/17 14:18:48 jbj Exp $
+
+errstatus=0
+
+for file
+do
+ set fnord `echo ":$file" | sed -ne 's/^:\//#/;s/^://;s/\// /g;s/^#/\//;p'`
+ shift
+
+ pathcomp=
+ for d
+ do
+ pathcomp="$pathcomp$d"
+ case "$pathcomp" in
+ -* ) pathcomp=./$pathcomp ;;
+ esac
+
+ if test ! -d "$pathcomp"; then
+ echo "mkdir $pathcomp" 1>&2
+
+ mkdir "$pathcomp" || lasterr=$?
+
+ if test ! -d "$pathcomp"; then
+ errstatus=$lasterr
+ fi
+ fi
+
+ pathcomp="$pathcomp/"
+ done
+done
+
+exit $errstatus
+
+# mkinstalldirs ends here

View File

@ -0,0 +1,26 @@
--- src/Makefile.in.orig Mon Oct 15 07:35:13 2001
+++ src/Makefile.in Wed Dec 19 04:02:47 2001
@@ -2,8 +2,8 @@
# Compilers. You shouldn't really need to change these.
##
-C++ = g++
-CC = gcc
+C++ = ${CXX}
+CC ?= gcc
##
# General configuration section.
@@ -21,10 +21,10 @@
SUBDIRS =
-C++FLAGS := -fno-rtti -fno-inline @DEBUG@ -DUNIX -Wall -Ih @DMALLOC@ @ZVT@ @ZLIB@ -DPREFIX=\"$(PREFIX)\" @IPV4@ @GTK@ @GTK_INC@ @GLIB_INC@ @GNOME_INC@
+C++FLAGS := -fno-rtti -fno-inline @DEBUG@ -DUNIX -Wall -Ih @DMALLOC@ @ZVT@ @ZLIB@ -DPREFIX=\"$(PREFIX)\" @IPV4@ @GTK@ @GTK_INC@ @GLIB_INC@ @GNOME_INC@ ${CXXFLAGS}
#C++FLAGS := -fno-rtti -fno-inline @DEBUG@ -DUNIX -Wall $(shell gtk-config --cflags) $(shell glib-config --cflags) $(shell gnome-config --cflags gnome) -Ih @DMALLOC@ @ZVT@ @ZLIB@ -DPREFIX=\"$(PREFIX)\" @IPV4@ @GTK@
-LFLAGS = @INTLLIBS@ @LIBS@ -lgthread
+LFLAGS = @INTLLIBS@ @LIBS@ ${PTHREAD_LIBS}
#CCMALLOC = @CCMALLOC@

1
net/papaya/pkg-comment Normal file
View File

@ -0,0 +1 @@
Graphical GTK mud client with plugin support

8
net/papaya/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
Papaya is a MUD client. A MUD client is a program like telnet, but
customised for playing MUDs with. Papaya has a number of features
designed to make playing MUDs more enjoyable. Papaya makes use of
Gnome to provide a graphical interface.
This port is for the executable (no plugins, see ports/net/papaya-plugins).
WWW: http://www.gtk-papaya.org/

4
net/papaya/pkg-message Normal file
View File

@ -0,0 +1,4 @@
--------------------------------------------------------------------
It is recommended you install the papaya-plugins package for added
functionality. It can be found in ports/net/papaya-plugins.
--------------------------------------------------------------------

9
net/papaya/pkg-plist Normal file
View File

@ -0,0 +1,9 @@
bin/papaya
share/locale/en/LC_MESSAGES/papaya.mo
share/locale/en_GB/LC_MESSAGES/papaya.mo
share/papaya/bitmaps/papaya.xpm
share/papaya/mcw.dat
share/papaya/mudlist.txt
share/papaya/papayarc
@dirrm share/papaya/bitmaps
@dirrm share/papaya