Initial import of Amphetamine - nice SDL-based run'n'shoot game.

This commit is contained in:
Maxim Sobolev 2000-06-05 12:00:18 +00:00
parent 0a409bd159
commit 9b1cacec8f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29219
7 changed files with 222 additions and 0 deletions

View File

@ -0,0 +1,30 @@
# New ports collection makefile for: amphetamine
# Date created: 6 March 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= amphetamine
PORTVERSION= 0.8.8
CATEGORIES= graphics
MASTER_SITES= http://www.dataway.ch/~lukasl/amph/files/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-data-${DATAVERSION}${EXTRACT_SUFX}
MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl \
Xpm.4:${PORTSDIR}/graphics/xpm
DATAVERSION= 0.8.6
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
post-install:
@(cd ${WRKDIR}/amph && ${TAR} -c -f - * ) \
| (cd ${PREFIX}/share/amph && ${TAR} --unlink -x -f -)
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (amphetamine-0.8.8.tar.bz2) = fa4bfc4ce6a7a8b23038d29f9fbfc640
MD5 (amphetamine-data-0.8.6.tar.bz2) = ed5f2a05b76918d3a624b38ba37dda0b

View File

@ -0,0 +1,84 @@
--- Makefile.orig Sun Feb 27 15:45:57 2000
+++ Makefile Mon Jun 5 14:43:04 2000
@@ -5,14 +5,14 @@
# User settings
#===============
-PREFIX := /usr/local
-INSTALL_DIR := ${PREFIX}/games/amph
+#PREFIX := /usr/local
+INSTALL_DIR := ${PREFIX}/share/amph
# Linux or SPARC
TARGET_ARCH := Linux
USE_LIB_XPM := TRUE
-SDL_HEADERS := `sdl-config --cflags`
+SDL_HEADERS := `${LOCALBASE}/bin/sdl-config --cflags`
# For framerate dislpay (doesn't work yet)
USE_LIB_SGE := FLASE
@@ -24,7 +24,7 @@
# Directories to search for header files
-SEARCHDIRS := -I${MYCODEDIR} ${SDL_HEADERS}
+SEARCHDIRS := -I${MYCODEDIR} ${SDL_HEADERS} -I ${X11BASE}/include
# makemake variables
@@ -35,12 +35,12 @@
# C
CC := gcc
-CFLAGS = ${DEPENDFLAGS}
+CFLAGS += ${DEPENDFLAGS}
# C++
CXX := g++
-CXXFLAGS = ${DEPENDFLAGS} -O9 -funroll-loops -fomit-frame-pointer -ffast-math -Wcast-align
+CXXFLAGS += ${DEPENDFLAGS} -O9 -funroll-loops -fomit-frame-pointer -ffast-math -Wcast-align
%.o : %.cpp
${CXX} ${CPPFLAGS} -c $< ${CXXFLAGS} -o $@
@@ -65,7 +65,7 @@
# linker
-LOADLIBES := -lm `sdl-config --libs`
+LOADLIBES := -lm `${LOCALBASE}/bin/sdl-config --libs`
ifeq ($(USE_LIB_XPM),TRUE)
LOADLIBES := $(LOADLIBES) -lXpm -lXt
@@ -75,7 +75,7 @@
LOADLIBES := $(LOADLIBES) -lSGE
endif
-LDFLAGS = -L/usr/lib -L/usr/local/lib -L/usr/X11R6/lib
+LDFLAGS = -L${X11BASE}/lib
.PHONY : default
default : amph
@@ -83,9 +83,9 @@
.PHONY : install
install: amph
@./mkinstalldirs ${INSTALL_DIR}
- @install -c ./amph ${INSTALL_DIR}
- @strip ${INSTALL_DIR}/amph
- @ln -s ${INSTALL_DIR}/amph ${PREFIX}/bin/amph
+ @${BSD_INSTALL_PROGRAM} ./amph ${PREFIX}/bin/amph
+#${INSTALL_DIR}
+# @ln -s ${INSTALL_DIR}/amph ${PREFIX}/bin/amph
# This is what makemake added
@@ -203,7 +203,7 @@
./src/Surface.o: ./src/AmpHead.hpp ./src/Clut.hpp ./src/ConstVal.hpp ./src/Graphfil.hpp ./src/Shape.hpp ./src/ShapeLd.hpp ./src/Surface.hpp ./src/System.hpp /usr/include/limits.h /usr/include/math.h /usr/include/stdio.h /usr/include/stdlib.h
-./src/System.o: ./src/AmpHead.hpp ./src/Graphfil.hpp ./src/System.hpp /usr/include/X11/xpm.h /usr/include/fcntl.h /usr/include/limits.h /usr/include/math.h /usr/include/stdio.h /usr/include/stdlib.h /usr/include/string.h /usr/include/sys/stat.h /usr/include/sys/time.h /usr/include/sys/types.h /usr/include/unistd.h
+./src/System.o: ./src/AmpHead.hpp ./src/Graphfil.hpp ./src/System.hpp ${X11BASE}/include/X11/xpm.h /usr/include/fcntl.h /usr/include/limits.h /usr/include/math.h /usr/include/stdio.h /usr/include/stdlib.h /usr/include/string.h /usr/include/sys/stat.h /usr/include/sys/time.h /usr/include/sys/types.h /usr/include/unistd.h
./src/Thing.o: ./src/AmpHead.hpp ./src/Appl.hpp ./src/Bullet.hpp ./src/ConstVal.hpp ./src/Element.hpp ./src/File.hpp ./src/Graphfil.hpp ./src/Level.hpp ./src/ObjInfo.hpp ./src/Object.hpp ./src/Pltform.hpp ./src/Shape.hpp ./src/ShapeLd.hpp ./src/Surface.hpp ./src/System.hpp ./src/Thing.hpp /usr/include/limits.h /usr/include/math.h /usr/include/stdio.h /usr/include/stdlib.h

View File

@ -0,0 +1,27 @@
--- src/Main.cpp.orig Mon Jun 5 14:34:38 2000
+++ src/Main.cpp Mon Jun 5 14:34:30 2000
@@ -1,3 +1,5 @@
+#include <floatingpoint.h>
+
#include "System.hpp"
#include "Appl.hpp"
#include "Clut.hpp"
@@ -74,7 +76,7 @@
my_argc = argc;
my_argv = argv;
if (checkCommandLine()) return 0;
-
+ fpsetmask(fpgetmask() & ~(FP_X_DZ|FP_X_INV));
gApplication = new CApplication();
gApplication->InitGraphics();
gApplication->LoadData();
@@ -82,6 +84,9 @@
gApplication->UnloadData();
gApplication->Quit();
delete gApplication;
+
+ fpresetsticky(FP_X_DZ|FP_X_INV);
+ fpsetmask(FP_X_DZ|FP_X_INV);
return 0;
}

View File

@ -0,0 +1 @@
Amphetamine is a 2D - Jump'n'run shooter

View File

@ -0,0 +1,15 @@
Amphetamine is a 2D - Jump'n'run shooter in the tradition of Super Mario Bros
and other classics. But it has unique features:
Highlights:
o Fast 256 colour graphics
o Never seen graphics (in this genre) such as coronas (remember Unreal),
dynamic coloured lightning, fogging, semitransparence and much more...
o Seven weapons (like the seven deadly sins): Fight with arrow and bow, a
scie, fire hands, etc. against monsters
o Raging fights against 11 bloodsucking monsters which themselves have several
killing powers.
WWW: http://n.ethz.ch/student/spjonas/
http://www.dataway.ch/~lukasl/amph/amph.html

View File

@ -0,0 +1,63 @@
bin/amph
share/amph/amph.conf
share/amph/amph.xpm
share/amph/data.d0
share/amph/data.d1
share/amph/data.d2
share/amph/data.d3
share/amph/data.d4
share/amph/data.g0
share/amph/data.g1
share/amph/data.g2
share/amph/data.g3
share/amph/data.g4
share/amph/data.p0
share/amph/data.p1
share/amph/sounds/aimedh.wav
share/amph/sounds/aimedl.wav
share/amph/sounds/bombh.wav
share/amph/sounds/bombl.wav
share/amph/sounds/borkh.wav
share/amph/sounds/borkl.wav
share/amph/sounds/bowh.wav
share/amph/sounds/bowl.wav
share/amph/sounds/dive.wav
share/amph/sounds/entrmenu.wav
share/amph/sounds/guidedh.wav
share/amph/sounds/guidedl.wav
share/amph/sounds/handsh.wav
share/amph/sounds/handsl.wav
share/amph/sounds/jump.wav
share/amph/sounds/lightoff.wav
share/amph/sounds/lighton.wav
share/amph/sounds/nazgulh.wav
share/amph/sounds/nazgull.wav
share/amph/sounds/openmenu.wav
share/amph/sounds/otygh.wav
share/amph/sounds/otygl.wav
share/amph/sounds/phiolh.wav
share/amph/sounds/phioll.wav
share/amph/sounds/pickup.wav
share/amph/sounds/platgo.wav
share/amph/sounds/platstop.wav
share/amph/sounds/scieh.wav
share/amph/sounds/sciel.wav
share/amph/sounds/selmenu.wav
share/amph/sounds/sorceryh.wav
share/amph/sounds/sorceryl.wav
share/amph/sounds/staffh.wav
share/amph/sounds/staffl.wav
share/amph/sounds/step.wav
share/amph/sounds/stonedam.wav
share/amph/sounds/swordh.wav
share/amph/sounds/swordl.wav
share/amph/sounds/test.wav
share/amph/sounds/trollh.wav
share/amph/sounds/trolll.wav
share/amph/sounds/warg1h.wav
share/amph/sounds/warg1l.wav
share/amph/sounds/warg2h.wav
share/amph/sounds/warg2l.wav
share/amph/user.conf
@dirrm share/amph/sounds
@dirrm share/amph