- Update to 1.0.2
- Correct LICENSE to be GPLv2+ - Fix LIB_DEPENDS
This commit is contained in:
parent
87dbbc3733
commit
9afcb5d264
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433450
@ -2,19 +2,19 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= irssi-otr
|
||||
PORTVERSION= 1.0.1
|
||||
PORTVERSION= 1.0.2
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= irc
|
||||
|
||||
MAINTAINER= ashish@FreeBSD.org
|
||||
COMMENT= Plugin for irssi for Off-the-Record (OTR) messaging
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/irssi/src/common.h:irc/irssi \
|
||||
${LOCALBASE}/bin/libgcrypt-config:security/libgcrypt
|
||||
LIB_DEPENDS= libotr.so.5:security/libotr \
|
||||
LIB_DEPENDS= libotr.so:security/libotr \
|
||||
libgcrypt.so:security/libgcrypt
|
||||
RUN_DEPENDS= irssi:irc/irssi
|
||||
|
||||
@ -31,4 +31,7 @@ INSTALL_TARGET= install-strip
|
||||
PLIST_FILES= lib/irssi/modules/libotr.so \
|
||||
share/irssi/help/otr
|
||||
|
||||
post-patch:
|
||||
${GREP} -Rl '$$(oldincludedir)' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} 's,$$(oldincludedir),${LOCALBASE}/include,g'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (cryptodotis-irssi-otr-v1.0.1_GH0.tar.gz) = 3b6baa39adab360cd4f6519b6d4a53db4eee7b070d6a9e716f1655245d3ca89d
|
||||
SIZE (cryptodotis-irssi-otr-v1.0.1_GH0.tar.gz) = 40334
|
||||
TIMESTAMP = 1486319780
|
||||
SHA256 (cryptodotis-irssi-otr-v1.0.2_GH0.tar.gz) = 4619208b9c9171aa97a41960b3e892390b6473e2988a056b9fe8e110daa1ae9c
|
||||
SIZE (cryptodotis-irssi-otr-v1.0.2_GH0.tar.gz) = 40947
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- help/Makefile.am.orig 2014-02-12 18:50:45.000000000 -0600
|
||||
+++ help/Makefile.am 2014-07-21 17:08:26.543319563 -0500
|
||||
@@ -1,6 +1,6 @@
|
||||
# The day Irssi will be able to check in $(prefix), this will change. Until
|
||||
# then, it's hardcoded.
|
||||
-helpdir = /usr/share/irssi/help
|
||||
+helpdir = /usr/local/share/irssi/help
|
||||
help_DATA = otr
|
||||
|
||||
EXTRA_DIST = otr
|
@ -1,10 +0,0 @@
|
||||
--- src/Makefile.am.orig 2014-02-12 18:50:45.000000000 -0600
|
||||
+++ src/Makefile.am 2014-07-21 16:43:34.653319339 -0500
|
||||
@@ -1,6 +1,6 @@
|
||||
AM_CFLAGS = $(LIBOTR_CFLAGS) $(LIBGCRYPT_CFLAGS) $(PACKAGE_FLAGS)
|
||||
|
||||
-IRSSI_DIST=/usr/include/irssi
|
||||
+IRSSI_DIST=/usr/local/include/irssi
|
||||
IRSSI_INCLUDE = -I$(IRSSI_DIST) \
|
||||
-I$(IRSSI_DIST)/src \
|
||||
-I$(IRSSI_DIST)/src/fe-common/core \
|
@ -1,6 +1,6 @@
|
||||
--- src/module.c 2014-02-12 18:50:45.000000000 -0600
|
||||
+++ src/module.c 2016-04-07 17:35:00.000000000 +0530
|
||||
@@ -32,6 +32,7 @@
|
||||
--- src/module.c.orig 2016-12-07 21:24:08 UTC
|
||||
+++ src/module.c
|
||||
@@ -33,6 +33,7 @@
|
||||
#include "otr.h"
|
||||
#include "otr-formats.h"
|
||||
#include "utils.h"
|
||||
@ -8,7 +8,7 @@
|
||||
|
||||
GCRY_THREAD_OPTION_PTHREAD_IMPL;
|
||||
|
||||
@@ -90,8 +91,13 @@ static void sig_server_sendmsg(SERVER_REC *server, const char *target,
|
||||
@@ -91,8 +92,13 @@ end:
|
||||
/*
|
||||
* Pipes all incoming private messages through OTR
|
||||
*/
|
||||
@ -23,7 +23,7 @@
|
||||
{
|
||||
int ret;
|
||||
char *new_msg = NULL;
|
||||
@@ -106,7 +112,11 @@ void sig_message_private(SERVER_REC *server, const char *msg,
|
||||
@@ -107,7 +113,11 @@ void sig_message_private(SERVER_REC *ser
|
||||
|
||||
if (!new_msg) {
|
||||
/* This message was not OTR */
|
||||
@ -36,18 +36,3 @@
|
||||
} else {
|
||||
/*
|
||||
* Check for /me IRC marker and if so, handle it so the user does not
|
||||
@@ -371,3 +371,13 @@ void otr_deinit(void)
|
||||
|
||||
theme_unregister();
|
||||
}
|
||||
+
|
||||
+#ifdef IRSSI_ABI_VERSION
|
||||
+/*
|
||||
+ * irssi abicheck()
|
||||
+ */
|
||||
+void otr_abicheck(int *version)
|
||||
+{
|
||||
+ *version = IRSSI_ABI_VERSION;
|
||||
+}
|
||||
+#endif
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/otr-ops.c 2014-02-12 18:50:45.000000000 -0600
|
||||
+++ src/otr-ops.c 2016-04-07 17:35:00.000000000 +0530
|
||||
--- src/otr-ops.c.orig 2016-12-07 21:24:08 UTC
|
||||
+++ src/otr-ops.c
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
#include "key.h"
|
||||
@ -8,7 +8,7 @@
|
||||
|
||||
static OtrlPolicy OTR_DEFAULT_POLICY =
|
||||
OTRL_POLICY_MANUAL | OTRL_POLICY_WHITESPACE_START_AKE;
|
||||
@@ -206,8 +207,13 @@ static void ops_handle_msg_event(void *opdata, OtrlMessageEvent msg_event,
|
||||
@@ -206,8 +207,13 @@ static void ops_handle_msg_event(void *o
|
||||
* submit a patch or email me a better way.
|
||||
*/
|
||||
signal_remove("message private", (SIGNAL_FUNC) sig_message_private);
|
||||
|
Loading…
Reference in New Issue
Block a user