devel/trompeloeil: New port: Header only C++14 mocking framework

This commit is contained in:
Yuri Victorovich 2022-12-02 07:44:59 -08:00
parent 408586d4b2
commit 9ac3a78345
6 changed files with 70 additions and 0 deletions

View File

@ -7392,6 +7392,7 @@
SUBDIR += treepy.el
SUBDIR += trellis
SUBDIR += trio
SUBDIR += trompeloeil
SUBDIR += truc
SUBDIR += tup
SUBDIR += ua_parser-core

View File

@ -0,0 +1,34 @@
PORTNAME= trompeloeil
DISTVERSIONPREFIX= v
DISTVERSION= 43
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
COMMENT= Header only C++14 mocking framework
WWW= https://github.com/rollbear/trompeloeil
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
TEST_DEPENDS= ${LOCALBASE}/include/catch2/catch.hpp:devel/catch \
criterion>0:devel/criterion
USES= cmake:testing # unclear how to run tests, see https://github.com/rollbear/trompeloeil/issues/287
USE_GITHUB= yes
GH_ACCOUNT= rollbear
NO_BUILD= yes
NO_ARCH= yes
OPTIONS_DEFINE= DOCS
PORTDOCS= *
post-install:
@cd ${STAGEDIR}${DOCSDIR} && \
${RM} LICENSE_1_0.txt && \
${MV} docs/* . && \
${RMDIR} docs
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1670024517
SHA256 (rollbear-trompeloeil-v43_GH0.tar.gz) = 86a0afa2e97347202a0a883ab43da78c1d4bfff0d6cb93205cfc433d0d9eb9eb
SIZE (rollbear-trompeloeil-v43_GH0.tar.gz) = 305074

View File

@ -0,0 +1,20 @@
--- CMakeLists.txt.orig 2022-10-26 09:57:07 UTC
+++ CMakeLists.txt
@@ -37,7 +37,7 @@ endif()
option(TROMPELOEIL_INSTALL_TARGETS "Sets whether trompeloeil should be installed" ${MASTER_PROJECT})
option(TROMPELOEIL_INSTALL_DOCS "Install documentation" ${TROMPELOEIL_INSTALL_TARGETS})
-if (MASTER_PROJECT AND CMAKE_BUILD_TYPE MATCHES Debug)
+if (BUILD_TESTING)
if (${CXX_STANDARD})
set(CMAKE_CXX_STANDARD ${CXX_STANDARD})
@@ -47,7 +47,7 @@ if (MASTER_PROJECT AND CMAKE_BUILD_TYPE MATCHES Debug)
set(CMAKE_CXX_STANDARD_REQUIRED YES)
set(CMAKE_CXX_EXTENSIONS OFF)
- set(CATCH_DIR ${CMAKE_CURRENT_BINARY_DIR}/catch)
+ set(CATCH_DIR ${CMAKE_INSTALL_PREFIX}/include/catch2)
if(NOT EXISTS ${CATCH_DIR}/catch.hpp)
if (NOT EXISTS ${CATCH_DIR})
make_directory(${CATCH_DIR})

View File

@ -0,0 +1 @@
trompeloeil is a thread-safe header-only mocking framework for C++11/14.

View File

@ -0,0 +1,11 @@
include/boost/trompeloeil.hpp
include/catch2/trompeloeil.hpp
include/criterion/trompeloeil.hpp
include/crpcut/trompeloeil.hpp
include/cxxtest/trompeloeil.hpp
include/doctest/trompeloeil.hpp
include/gtest/trompeloeil.hpp
include/trompeloeil.hpp
lib/cmake/trompeloeil/trompeloeil-config-version.cmake
lib/cmake/trompeloeil/trompeloeil-config.cmake
lib/cmake/trompeloeil/trompeloeil-targets.cmake