databases/sqlrelay: 0.58.1 -> 0.59
0.59 - updated docs, removed some Cygwin-specific info added support for login warnings made bind variable buffers dynamic on the client side added maxbindvars parameter on the server side binding a NULL to an integer works with db2 now moved getting started with DB docs into the cloud added a semaphore to ensure that the listener doesn't hand off the client to the connection until the connection is ready, elimiating a race condition on the handoff socket that could occur if the connection timed out waiting for the listener just after the listener had decided to use that connection oracle temp tables that need to be truncated at the end of the session are truncated with "truncate table xxx" now rather than "delete from xxx" oracle temp tables that need to be dropped at the end of the session are truncated first, rather than the connection re-logging in an ora-14452 error (basically indicating that a temp table can only be dropped after being truncated, or if the current session ends) does not automatically trigger a re-login any more updated cachemanager to use directory::read() directly instead of directory::getChildName(index) added cache and opencache commands to sqlrsh made cache ttl a 64-bit number added enabled="yes"/"no" parameter to logger modules updated odbc connection code to use new/delete and rudiments methods rather than malloc/free and native calls retired Ruby DBI driver fixed command line client crash when using -id "instance" with an instance that uses authtier="database" fixed bugs that could make reexecuted db2 selects fail and cause a database re-login loop tweaked spec file to remove empty directories on uninstall fixed typo that could sometimes cause a listener crash postgresql and mdbtools return error code of 1 rather than 0 for all errors now tweaked odbc driver to work with Oracle Heterogenous Agent (dblinks) fixed bugs related to autocommit with db's that support transaction blocks implemented the ODBC driver-manager dialog for windows updated windows installer to install ODBC registry settings ODBC driver copies references now fixed various bugs in sqlrconfigfile that caused sqlr-start with no -id to crash or behave strangely sometimes refactored build process to use nmake and be compatible with many different versions of MS Visual Studio updated the slow query logger to show the date/time that the query was executed consolidated c, c++ and server source/includes down a few levels implemented column-remapping for get db/table/column commands to enable different formats for mysql, odbc, etc. odbc connection correctly returns database/table lists now added support for maxselectlistsize/maxitembuffersize to MySQL connection updated mysql connection to fetch blob columns in chunks and not be bound by maxitembuffersize fixed a misspelling in sqlrelay.dtd swapped order of init directory detection, looking for /etc/init.d ahead of /etc/rc.d/init.d to resolve conflict with dkms on SuSE Enterprise C# api and tests compile and work under Mono on unix/linux now sqlr-start spawns a new window on Windows now added global temp table tracking for firebird added droptemptables parameter for firebird added globaltemptables parameter for oracle and firebird updated mysql connection to allow mysql_init to allocate a mysql struct on platforms that support mysql_init, rather than using a static struct fixed subtle noon/midnight-related bugs in date/time translation updated mysql connection to get affected rows when not using the statement api updated mysql connection not to use the statement API on windows, for now disabled mysql_change_user, for now fixed blob-input binds on firebird
This commit is contained in:
parent
63991c69ed
commit
9ab91a8f24
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=385725
@ -43,16 +43,16 @@ TOSTRIP= bin/sqlr-start \
|
||||
bin/sqlr-pwdenc \
|
||||
bin/sqlr-status \
|
||||
bin/sqlrsh \
|
||||
lib/libsqlrutil.so.1.0.0 \
|
||||
lib/libsqlrclient.so.1.0.0 \
|
||||
lib/libsqlrclientwrapper.so.1.0.0 \
|
||||
lib/libpqsqlrelay.so.1.0.0 \
|
||||
lib/libmysql3sqlrelay.so.1.0.0 \
|
||||
lib/libmysql40sqlrelay.so.1.0.0 \
|
||||
lib/libmysql41sqlrelay.so.1.0.0 \
|
||||
lib/libmysql50sqlrelay.so.1.0.0 \
|
||||
lib/libmysql51sqlrelay.so.1.0.0 \
|
||||
lib/libsqlrserver.so.1.0.0 \
|
||||
lib/libsqlrutil-0.59.so.1.0.0 \
|
||||
lib/libsqlrclient-0.59.so.1.0.0 \
|
||||
lib/libsqlrclientwrapper-0.59.so.1.0.0 \
|
||||
lib/libpqsqlrelay-0.59.so.1.0.0 \
|
||||
lib/libmysql3sqlrelay-0.59.so.1.0.0 \
|
||||
lib/libmysql40sqlrelay-0.59.so.1.0.0 \
|
||||
lib/libmysql41sqlrelay-0.59.so.1.0.0 \
|
||||
lib/libmysql50sqlrelay-0.59.so.1.0.0 \
|
||||
lib/libmysql51sqlrelay-0.59.so.1.0.0 \
|
||||
lib/libsqlrserver-0.59.so.1.0.0 \
|
||||
libexec/sqlrelay/sqlrauth_default.so \
|
||||
libexec/sqlrelay/sqlrauth_sqlrelay.so \
|
||||
libexec/sqlrelay/sqlrconnection_router.so \
|
||||
|
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
SQLRELAY_PORTNAME= sqlrelay
|
||||
SQLRELAY_PORTVERSION= 0.58.1
|
||||
SQLRELAY_PORTVERSION= 0.59
|
||||
|
||||
SQLRELAY_PORTDIR= ${PORTSDIR}/databases/${SQLRELAY_PORTNAME}
|
||||
SQLRELAY_WRKSRC_CMD= cd ${SQLRELAY_PORTDIR} && ${MAKE} -V WRKSRC
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (sqlrelay-0.58.1.tar.gz) = 03fd21bb3550fe368e5fe0a065b408e7f8060c569e91b966b8e7c092a376fc9e
|
||||
SIZE (sqlrelay-0.58.1.tar.gz) = 3724622
|
||||
SHA256 (sqlrelay-0.59.tar.gz) = f2e6433a153cd64684980246574654d49a1df8d4b5bcde75634e8fb19f405c02
|
||||
SIZE (sqlrelay-0.59.tar.gz) = 3224000
|
||||
|
@ -1,15 +1,19 @@
|
||||
--- Makefile.orig Thu Aug 5 18:46:10 2004
|
||||
+++ Makefile Mon Feb 14 10:26:16 2005
|
||||
@@ -26,9 +26,9 @@
|
||||
$(MAKE) -C init install
|
||||
$(MAKE) -C man install
|
||||
$(MAKE) -C doc install
|
||||
- $(MKINSTALLDIRS) $(libdir)/pkgconfig
|
||||
- $(INSTALL) -m 0644 sqlrelay-c.pc $(libdir)/pkgconfig/sqlrelay-c.pc
|
||||
- $(INSTALL) -m 0644 sqlrelay-c++.pc $(libdir)/pkgconfig/sqlrelay-c++.pc
|
||||
+ $(MKINSTALLDIRS) $(prefix)/libdata/pkgconfig
|
||||
+ $(INSTALL) -m 0644 sqlrelay-c.pc $(prefix)/libdata/pkgconfig/sqlrelay-c.pc
|
||||
+ $(INSTALL) -m 0644 sqlrelay-c++.pc $(prefix)/libdata/pkgconfig/sqlrelay-c++.pc
|
||||
--- Makefile.orig 2015-03-31 20:50:58 UTC
|
||||
+++ Makefile
|
||||
@@ -30,11 +30,11 @@ install-doc:
|
||||
cd doc $(AND) $(MAKE) install
|
||||
|
||||
uninstall:
|
||||
$(MAKE) -C src uninstall
|
||||
install-pkgconfig:
|
||||
- $(MKINSTALLDIRS) $(libdir)/pkgconfig
|
||||
- $(CP) sqlrelay-c.pc $(libdir)/pkgconfig/sqlrelay-c.pc
|
||||
- $(CHMOD) 0644 $(libdir)/pkgconfig/sqlrelay-c.pc
|
||||
- $(CP) sqlrelay-c++.pc $(libdir)/pkgconfig/sqlrelay-c++.pc
|
||||
- $(CHMOD) 0644 $(libdir)/pkgconfig/sqlrelay-c++.pc
|
||||
+ $(MKINSTALLDIRS) $(prefix)/libdata/pkgconfig
|
||||
+ $(CP) sqlrelay-c.pc $(prefix)/libdata/pkgconfig/sqlrelay-c.pc
|
||||
+ $(CHMOD) 0644 $(prefix)/libdata/pkgconfig/sqlrelay-c.pc
|
||||
+ $(CP) sqlrelay-c++.pc $(prefix)/libdata/pkgconfig/sqlrelay-c++.pc
|
||||
+ $(CHMOD) 0644 $(prefix)/libdata/pkgconfig/sqlrelay-c++.pc
|
||||
|
||||
uninstall: $(UNINSTALLSUBDIRS)
|
||||
$(RMTREE) $(libexecdir)
|
||||
|
@ -1,20 +1,20 @@
|
||||
--- config.mk.in.orig 2014-12-28 09:10:48.000000000 +0100
|
||||
+++ config.mk.in 2014-12-29 20:44:27.000000000 +0100
|
||||
@@ -9,7 +9,7 @@
|
||||
--- config.mk.in.orig 2015-05-07 19:42:23 UTC
|
||||
+++ config.mk.in
|
||||
@@ -8,7 +8,7 @@ prefix = @prefix@
|
||||
exec_prefix= @exec_prefix@
|
||||
includedir = @includedir@
|
||||
libdir = @libdir@
|
||||
-javadir = ${exec_prefix}/java
|
||||
+javadir = ${exec_prefix}/share/java/classes
|
||||
dotnetdir = $(libdir)
|
||||
libexecdir = @libexecdir@/sqlrelay
|
||||
bindir = @bindir@
|
||||
localstatedir = @localstatedir@
|
||||
@@ -33,7 +33,7 @@
|
||||
@@ -59,7 +59,7 @@ OBJ = lo
|
||||
TMPDIRCPPFLAG = -DTMP_DIR=\"$(tmpdir)\"
|
||||
DEBUGDIRCPPFLAG = -DDEBUG_DIR=\"$(debugdir)\"
|
||||
LOGDIRCPPFLAG = -DLOG_DIR=\"$(logdir)\"
|
||||
-CONFIGFILECPPFLAG = -DDEFAULT_CONFIG_FILE=\"$(sysconfdir)/sqlrelay.conf\" -DDEFAULT_CONFIG_DIR=\"$(sysconfdir)/sqlrelay.conf.d\"
|
||||
+CONFIGFILECPPFLAG = -DDEFAULT_CONFIG_FILE=\"$(sysconfdir)/sqlrelay/conf\" -DDEFAULT_CONFIG_DIR=\"$(sysconfdir)/sqlrelay\"
|
||||
+CONFIGFILECPPFLAG = -DDEFAULT_CONFIG_FILE=\"$(sysconfdir)/sqlrelay.conf\" -DDEFAULT_CONFIG_DIR=\"$(sysconfdir)/sqlrelay\"
|
||||
CACHEDIRCPPFLAG = -DCACHE_DIR=\"$(cachedir)\"
|
||||
|
||||
# link flags (-s, -static, -melf, -belf, etc.)
|
||||
|
||||
|
@ -1,18 +0,0 @@
|
||||
--- etc/Makefile.orig 2014-12-29 21:02:52.000000000 +0100
|
||||
+++ etc/Makefile 2014-12-29 21:03:40.000000000 +0100
|
||||
@@ -6,11 +6,10 @@
|
||||
|
||||
install:
|
||||
$(MKINSTALLDIRS) $(sysconfdir)
|
||||
- $(MKINSTALLDIRS) $(sysconfdir)/sqlrelay.conf.d
|
||||
- $(INSTALL) -m 644 sqlrelay.conf.example $(sysconfdir)
|
||||
- $(INSTALL) -m 644 sqlrelay.dtd $(sysconfdir)
|
||||
- $(INSTALL) -m 644 sqlrelay.xsd $(sysconfdir)
|
||||
- $(INSTALL) -m 644 sqlrelay.conf.example $(EXAMPLEDIR)/sqlrelay.conf
|
||||
+ $(MKINSTALLDIRS) $(sysconfdir)/sqlrelay
|
||||
+ $(INSTALL) -m 644 sqlrelay.conf.example $(sysconfdir)/sqlrelay/conf.sample
|
||||
+ $(INSTALL) -m 644 sqlrelay.dtd $(sysconfdir)/sqlrelay/
|
||||
+ $(INSTALL) -m 644 sqlrelay.xsd $(sysconfdir)/sqlrelay/
|
||||
|
||||
uninstall:
|
||||
$(RM) $(sysconfdir)/sqlrelay.conf.example
|
23
databases/sqlrelay/files/patch-etc_Makefile
Normal file
23
databases/sqlrelay/files/patch-etc_Makefile
Normal file
@ -0,0 +1,23 @@
|
||||
--- etc/Makefile.orig 2015-05-07 19:44:34 UTC
|
||||
+++ etc/Makefile
|
||||
@@ -4,13 +4,13 @@ include ../config.mk
|
||||
|
||||
install:
|
||||
$(MKINSTALLDIRS) $(sysconfdir)
|
||||
- $(MKINSTALLDIRS) $(sysconfdir)/sqlrelay.conf.d
|
||||
- $(CP) sqlrelay.conf.example $(sysconfdir)
|
||||
- $(CHMOD) 644 $(sysconfdir)/sqlrelay.conf.example
|
||||
- $(CP) sqlrelay.dtd $(sysconfdir)
|
||||
- $(CHMOD) 644 $(sysconfdir)/sqlrelay.dtd
|
||||
- $(CP) sqlrelay.xsd $(sysconfdir)
|
||||
- $(CHMOD) 644 $(sysconfdir)/sqlrelay.xsd
|
||||
+ $(MKINSTALLDIRS) $(sysconfdir)/sqlrelay
|
||||
+ $(CP) sqlrelay.conf.example $(sysconfdir)//sqlrelay/conf.sample
|
||||
+ $(CHMOD) 644 $(sysconfdir)/sqlrelay/conf.sample
|
||||
+ $(CP) sqlrelay.dtd $(sysconfdir)/sqlrelay/
|
||||
+ $(CHMOD) 644 $(sysconfdir)/sqlrelay/sqlrelay.dtd
|
||||
+ $(CP) sqlrelay.xsd $(sysconfdir)/sqlrelay/
|
||||
+ $(CHMOD) 644 $(sysconfdir)/sqlrelay/sqlrelay.xsd
|
||||
$(CP) sqlrelay.conf.example $(EXAMPLEDIR)/sqlrelay.conf
|
||||
$(CHMOD) 644 $(EXAMPLEDIR)/sqlrelay.conf
|
||||
|
@ -22,6 +22,7 @@ etc/sqlrelay/sqlrelay.xsd
|
||||
include/sqlrelay/private/bindvar.h
|
||||
include/sqlrelay/private/column.h
|
||||
include/sqlrelay/private/dll.h
|
||||
include/sqlrelay/private/listformat.h
|
||||
include/sqlrelay/private/row.h
|
||||
include/sqlrelay/private/sqlrclientwrapper.h
|
||||
include/sqlrelay/private/sqlrconnection.h
|
||||
@ -42,43 +43,43 @@ include/sqlrelay/sqlrclientwrapper.h
|
||||
include/sqlrelay/sqlrserver.h
|
||||
include/sqlrelay/sqlrutil.h
|
||||
lib/libmysql3sqlrelay.so
|
||||
lib/libmysql3sqlrelay.so.1
|
||||
lib/libmysql3sqlrelay.so.1.0.0
|
||||
lib/libmysql3sqlrelay-0.59.so.1
|
||||
lib/libmysql3sqlrelay-0.59.so.1.0.0
|
||||
lib/libmysql40sqlrelay.so
|
||||
lib/libmysql40sqlrelay.so.1
|
||||
lib/libmysql40sqlrelay.so.1.0.0
|
||||
lib/libmysql40sqlrelay-0.59.so.1
|
||||
lib/libmysql40sqlrelay-0.59.so.1.0.0
|
||||
lib/libmysql41sqlrelay.so
|
||||
lib/libmysql41sqlrelay.so.1
|
||||
lib/libmysql41sqlrelay.so.1.0.0
|
||||
lib/libmysql41sqlrelay-0.59.so.1
|
||||
lib/libmysql41sqlrelay-0.59.so.1.0.0
|
||||
lib/libmysql50sqlrelay.so
|
||||
lib/libmysql50sqlrelay.so.1
|
||||
lib/libmysql50sqlrelay.so.1.0.0
|
||||
lib/libmysql50sqlrelay-0.59.so.1
|
||||
lib/libmysql50sqlrelay-0.59.so.1.0.0
|
||||
lib/libmysql51sqlrelay.so
|
||||
lib/libmysql51sqlrelay.so.1
|
||||
lib/libmysql51sqlrelay.so.1.0.0
|
||||
lib/libmysql51sqlrelay-0.59.so.1
|
||||
lib/libmysql51sqlrelay-0.59.so.1.0.0
|
||||
lib/libpqsqlrelay.so
|
||||
lib/libpqsqlrelay.so.1
|
||||
lib/libpqsqlrelay.so.1.0.0
|
||||
lib/libpqsqlrelay-0.59.so.1
|
||||
lib/libpqsqlrelay-0.59.so.1.0.0
|
||||
lib/libsqlrclient.a
|
||||
lib/libsqlrclient.so
|
||||
lib/libsqlrclient.so.1
|
||||
lib/libsqlrclient.so.1.0.0
|
||||
lib/libsqlrclient-0.59.so.1
|
||||
lib/libsqlrclient-0.59.so.1.0.0
|
||||
lib/libsqlrclientwrapper.a
|
||||
lib/libsqlrclientwrapper.so
|
||||
lib/libsqlrclientwrapper.so.1
|
||||
lib/libsqlrclientwrapper.so.1.0.0
|
||||
lib/libsqlrclientwrapper-0.59.so.1
|
||||
lib/libsqlrclientwrapper-0.59.so.1.0.0
|
||||
%%ODBC%%lib/libsqlrodbc.a
|
||||
%%ODBC%%lib/libsqlrodbc.so
|
||||
%%ODBC%%lib/libsqlrodbc.so.1
|
||||
%%ODBC%%lib/libsqlrodbc.so.1.0.0
|
||||
%%ODBC%%lib/libsqlrodbc-0.59.so.1
|
||||
%%ODBC%%lib/libsqlrodbc-0.59.so.1.0.0
|
||||
lib/libsqlrserver.a
|
||||
lib/libsqlrserver.so
|
||||
lib/libsqlrserver.so.1
|
||||
lib/libsqlrserver.so.1.0.0
|
||||
lib/libsqlrserver-0.59.so.1
|
||||
lib/libsqlrserver-0.59.so.1.0.0
|
||||
lib/libsqlrutil.a
|
||||
lib/libsqlrutil.so
|
||||
lib/libsqlrutil.so.1
|
||||
lib/libsqlrutil.so.1.0.0
|
||||
lib/libsqlrutil-0.59.so.1
|
||||
lib/libsqlrutil-0.59.so.1.0.0
|
||||
libdata/pkgconfig/sqlrelay-c++.pc
|
||||
libdata/pkgconfig/sqlrelay-c.pc
|
||||
%%FIREBIRD%%libexec/sqlrelay/sqlrconnection_firebird.so
|
||||
@ -112,6 +113,7 @@ man/man8/sqlr-start.8.gz
|
||||
man/man8/sqlr-stop.8.gz
|
||||
share/examples/sample-mssqlserver-mysql-errors.map
|
||||
share/examples/sample-oracle-mysql-errors.map
|
||||
share/examples/sqlrelay.conf
|
||||
@dir %%ETCDIR%%
|
||||
@dir /var/sqlrelay/tmp/sockets
|
||||
@dir /var/sqlrelay/tmp/pids
|
||||
|
Loading…
Reference in New Issue
Block a user