Update and clean up the ioquake3 family of ports.

The following maintenance operations were performed:

- Recreate all patches with `make makepatch`
- Add LICENSE
- Update MAINTAINER to kami@freebsd.org
- games/ioquake3
  - Replace a lot of `.if ${PORT_OPTIONS:MFOO}` with `bsd.options.mk` fu
  - Add support for slaves using different SDL versions
- games/ioquake3-devel
  - Update to GIT revision 2808
  - Use SDL2
- games/iourbanterror
  - Change treatment of patches so `make makepatch` doesn't screw the patches in ${MASTERDIR}/files over
  - Update 4.2.018 to 4.2.023
- games/urbanterror-data
  - Update 4.2.018 to 4.2.023
  - Fix install without DOCS

Reviewed by:	cs
Approved by:	cs
Differential Revision:	https://reviews.freebsd.org/D5816
This commit is contained in:
Dominic Fandrey 2016-04-25 22:43:23 +00:00
parent 969dda2c45
commit 9ab41ffb0e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=414032
36 changed files with 282 additions and 303 deletions

View File

@ -4,9 +4,11 @@
PORTNAME= ioquake3-devel
PKGNAMESUFFIX= -server
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= Ioquake3 development snapshot dedicated server
LICENSE= GPLv2
MASTERDIR= ${.CURDIR}/../${PORTNAME}
IOQ3= SERVER GAMELIBS

View File

@ -3,30 +3,33 @@
PORTNAME?= ioquake3-devel
DISTVERSION?= GIT${GITREVISION}
PORTREVISION?= 2
PORTREVISION?= 0
MASTER_SITES?= ftp://deponie.yamagi.org/freebsd/distfiles/ioquake3/ \
http://deponie.yamagi.org/freebsd/distfiles/ioquake3/
EXTRACT_SUFX?= .tar.xz
MAINTAINER?= kamikaze@bsdforen.de
MAINTAINER?= kami@freebsd.org
COMMENT?= Development GIT snapshots of ioquake3
LICENSE?= GPLv2
MASTERDIR= ${.CURDIR}/../ioquake3
DESCR?= ${.CURDIR}/../${PORTNAME}/pkg-descr
DISTINFO_FILE?= ${.CURDIR}/../${PORTNAME}/distinfo
PATCHDIR?= ${.CURDIR}/../${PORTNAME}/files
PKGMESSAGE?= ${.CURDIR}/../${PORTNAME}/pkg-message
GITREVISION?= 2390
GITREVISION?= 2808
BINSUFFIX?= -devel
IOQ3?= CLIENT TOOLS DLRENDERER GAMELIBS OPUS OPENGL2
IOQ3ARCH?= ${ARCH:S/i386/x86/:S/amd64/x86_64/}
IOQ3SDL?= sdl2
Q3DOCS?= README.md \
id-readme.txt \
md4-readme.txt \
opengl2-readme.txt \
opengl2-readme.md \
voip-readme.txt
.include "${MASTERDIR}/Makefile"

View File

@ -1,2 +1,2 @@
SHA256 (ioquake3-devel-GIT2390.tar.xz) = 1ad3a8bfccaa54ed39221f86539676479187f5f832a4140cf5d7ee7be9a1b1be
SIZE (ioquake3-devel-GIT2390.tar.xz) = 4310568
SHA256 (ioquake3-devel-GIT2808.tar.xz) = a9fe73c4c29e218e64d782ce8b458a93e4860e81d4c1fc08e6556cd32dfabbb2
SIZE (ioquake3-devel-GIT2808.tar.xz) = 8166804

View File

@ -1,11 +0,0 @@
--- Makefile.orig 2015-10-25 13:13:52 UTC
+++ Makefile
@@ -1043,7 +1043,7 @@ ifeq ($(USE_VOIP),1)
CLIENT_CFLAGS += -DUSE_VOIP
SERVER_CFLAGS += -DUSE_VOIP
ifeq ($(USE_INTERNAL_SPEEX),1)
- CLIENT_CFLAGS += -DFLOATING_POINT -DUSE_ALLOCA -I$(SPEEXDIR)/include
+ CLIENT_CFLAGS := -I$(SPEEXDIR)/include -DFLOATING_POINT -DUSE_ALLOCA $(CLIENT_CFLAGS)
else
CLIENT_LIBS += -lspeex -lspeexdsp
endif

View File

@ -4,9 +4,11 @@
PORTNAME= ioquake3
PKGNAMESUFFIX= -server
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= Ioquake3 dedicated server
LICENSE= GPLv2
MASTERDIR= ${.CURDIR}/../${PORTNAME}
IOQ3= SERVER GAMELIBS

View File

@ -9,15 +9,19 @@ MASTER_SITES?= http://ioquake3.org/files/${DISTVERSION}/
# Using zip this way enables slaves to override it.
EXTRACT_SUFX?= .zip
MAINTAINER?= kamikaze@bsdforen.de
MAINTAINER?= kami@freebsd.org
COMMENT?= Cleaned-up and enhanced version of Quake 3
LICENSE?= GPLv2
LICENSE_FILE?= ${WRKSRC}/COPYING.txt
USES= pkgconfig gmake
# Port configuration flags:
# CLIENT SERVER TOOLS DLRENDERER GAMELIBS OPUS OPENGL2
IOQ3?= CLIENT TOOLS GAMELIBS
IOQ3ARCH?= ${ARCH}
IOQ3SDL?= sdl
.if ! ${IOQ3:MCLIENT} && ! ${IOQ3:MSERVER}
BROKEN= Slave ports must at least specify IOQ3=CLIENT or IOQ3=SERVER
@ -30,26 +34,14 @@ OPTIONS_DEFAULT= SERVER CURL OPENAL MUMBLE VORBIS
SERVER_DESC= Install dedicated server
MUMBLE_DESC= Enable Mumble support (no dependencies)
.endif
.if ${IOQ3:MTOOLS}
OPTIONS_DEFINE+= TOOLS
OPTIONS_DEFAULT+= TOOLS
IOQ3_OPTIONS= ${IOQ3:MTOOLS} ${IOQ3:MDLRENDERER} ${IOQ3:MGAMELIBS} \
${IOQ3:MOPUS}
OPTIONS_DEFINE+= ${IOQ3_OPTIONS} DOCS
OPTIONS_DEFAULT+= ${IOQ3_OPTIONS}
TOOLS_DESC= Enable modding tools
.endif
.if ${IOQ3:MDLRENDERER}
OPTIONS_DEFINE+= DLRENDERER
OPTIONS_DEFAULT+= DLRENDERER
DLRENDERER_DESC= Build dynamically loaded renderer
.endif
.if ${IOQ3:MGAMELIBS}
OPTIONS_DEFINE+= GAMELIBS
OPTIONS_DEFAULT+= GAMELIBS
GAMELIBS_DESC= Build game libraries
.endif
.if ${IOQ3:MOPUS}
OPTIONS_DEFINE+= OPUS
OPTIONS_DEFAULT+= OPUS
.endif
OPTIONS_DEFINE+=DOCS
MAKE_ARGS+= DEFAULT_BASEDIR="${Q3DIR}" \
DEFAULT_LIBDIR="${PREFIX}/${LIBDIR}" \
@ -91,33 +83,51 @@ Q3ENGINEVER?= ${DISTVERSION}
ONLY_FOR_ARCHS= amd64 i386
DEBUG_VARS= ALL_TARGET=debug
SERVER_RUN_DEPENDS= ${Q3SERVER}${BINSUFFIX}:games/${PORTNAME}-server
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_MAKE_ARGS= USE_CURL=1 USE_CURL_DLOPEN=0
CURL_MAKE_ARGS_OFF= USE_CURL=0
OPENAL_USES= openal:al
OPENAL_MAKE_ARGS= USE_OPENAL=1 USE_OPENAL_DLOPEN=0
OPENAL_MAKE_ARGS_OFF= USE_OPENAL=0
VORBIS_VARS= NEED_OGG=yes
VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
VORBIS_MAKE_ARGS= USE_CODEC_VORBIS=1
VORBIS_MAKE_ARGS_OFF= USE_CODEC_VORBIS=0
OPUS_VARS= NEED_OGG=yes
OPUS_LIB_DEPENDS= libopusfile.so:audio/opusfile \
libopus.so:audio/opus
OPUS_MAKE_ARGS= USE_CODEC_OPUS=1 USE_INTERNAL_OPUS=0
OPUS_MAKE_ARGS_OFF= USE_CODEC_OPUS=0
MUMBLE_MAKE_ARGS= USE_MUMBLE=1
MUMBLE_MAKE_ARGS_OFF= USE_MUMBLE=0
GAMELIBS_MAKE_ARGS= BUILD_GAME_SO=1
GAMELIBS_MAKE_ARGS_OFF= BUILD_GAME_SO=0
# Note that SMP is only supported on OS-X, hence the option has been removed.
SMP_VARS= Q3BIN+=${Q3CLIENT}-smp
SMP_MAKE_ARGS= BUILD_CLIENT_SMP=1
SMP_MAKE_ARGS_OFF= BUILD_CLIENT_SMP=0
DLRENDERER_MAKE_ARGS= USE_RENDERER_DLOPEN=1
DLRENDERER_MAKE_ARGS_OFF= USE_RENDERER_DLOPEN=0
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
ALL_TARGET= debug
.endif
.if ${PORT_OPTIONS:MSERVER}
RUN_DEPENDS+= ${Q3SERVER}${BINSUFFIX}:games/${PORTNAME}-server
.endif
.if !defined(DESKTOP_ENTRIES)
. if ${IOQ3:MCLIENT}
DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER}" "${COMMENT}" \
"${Q3ICON}" \
"${Q3CLIENT}${BINSUFFIX}" "Game;" false
"${Q3ICON}" "${Q3CLIENT}${BINSUFFIX}" "Game;" false
. endif
. if ${PORT_OPTIONS:MSMP}
DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER} SMP" "${COMMENT}" \
"${Q3ICON}" \
"${Q3CLIENT}-smp${BINSUFFIX}" "Game;" false
"${Q3ICON}" "${Q3CLIENT}-smp${BINSUFFIX}" "Game;" false
. endif
.endif
.if ${IOQ3:MCLIENT}
MAKE_ARGS+= BUILD_CLIENT=1
Q3BIN+= ${Q3CLIENT}
USE_SDL= sdl
USE_SDL= ${IOQ3SDL}
.else
MAKE_ARGS+= BUILD_CLIENT=0
.endif
@ -129,71 +139,11 @@ Q3BIN+= ${Q3SERVER}
MAKE_ARGS+= BUILD_SERVER=0
.endif
.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS+= libcurl.so:ftp/curl
MAKE_ARGS+= USE_CURL=1 USE_CURL_DLOPEN=0
.else
MAKE_ARGS+= USE_CURL=0
.endif
.if ${PORT_OPTIONS:MOPENAL}
USES+= openal:al
MAKE_ARGS+= USE_OPENAL=1 USE_OPENAL_DLOPEN=0
.else
MAKE_ARGS+= USE_OPENAL=0
.endif
.if ${PORT_OPTIONS:MVORBIS}
NEED_OGG= yes
LIB_DEPENDS+= libvorbis.so:audio/libvorbis
MAKE_ARGS+= USE_CODEC_VORBIS=1
.else
MAKE_ARGS+= USE_CODEC_VORBIS=0
.endif
.if ${PORT_OPTIONS:MOPUS}
NEED_OGG= yes
LIB_DEPENDS+= libopusfile.so:audio/opusfile \
libopus.so:audio/opus
MAKE_ARGS+= USE_CODEC_OPUS=1 USE_INTERNAL_OPUS=0
.else
MAKE_ARGS+= USE_CODEC_OPUS=0
.endif
.if defined(NEED_OGG)
LIB_DEPENDS+= libogg.so:audio/libogg
MAKE_ARGS+= USE_INTERNAL_OGG=0
.endif
.if ${PORT_OPTIONS:MMUMBLE}
MAKE_ARGS+= USE_MUMBLE=1
.else
MAKE_ARGS+= USE_MUMBLE=0
.endif
.if ${PORT_OPTIONS:MGAMELIBS}
MAKE_ARGS+= BUILD_GAME_SO=1
.else
MAKE_ARGS+= BUILD_GAME_SO=0
.endif
# Note that SMP is only supported on OS-X, hence the option has been removed.
.if ${PORT_OPTIONS:MSMP}
MAKE_ARGS+= BUILD_CLIENT_SMP=1
Q3BIN+= ${Q3CLIENT}-smp
.else
MAKE_ARGS+= BUILD_CLIENT_SMP=0
.endif
.if ${PORT_OPTIONS:MDLRENDERER}
MAKE_ARGS+= USE_RENDERER_DLOPEN=1
. if ${IOQ3:MOPENGL2}
Q3DOCS+= opengl2-readme.txt
. endif
.else
MAKE_ARGS+= USE_RENDERER_DLOPEN=0
.endif
# Generate a set of install instruction tuples: <cmd>;<src>;<dst>
.for bin in ${Q3BIN}
IOQ3_INST+= PROGRAM;${bin}.${IOQ3ARCH};bin/${bin}${BINSUFFIX}

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2009-04-22 22:54:48.000000000 +0400
+++ Makefile 2015-09-28 20:24:27.956819000 +0300
@@ -187,6 +187,8 @@
--- Makefile.orig 2009-04-22 18:54:48 UTC
+++ Makefile
@@ -187,6 +187,8 @@ ifeq ($(shell which pkg-config > /dev/nu
# FIXME: introduce CLIENT_CFLAGS
SDL_CFLAGS=$(shell pkg-config --cflags sdl|sed 's/-Dmain=SDL_main//')
SDL_LIBS=$(shell pkg-config --libs sdl)
@ -9,7 +9,7 @@
endif
# version info
@@ -521,44 +523,25 @@
@@ -521,44 +523,25 @@ else # ifeq mingw32
ifeq ($(PLATFORM),freebsd)
@ -72,7 +72,7 @@
SHLIBEXT=so
SHLIBCFLAGS=-fPIC
@@ -568,20 +551,52 @@
@@ -568,20 +551,52 @@ ifeq ($(PLATFORM),freebsd)
# don't need -ldl (FreeBSD)
LIBS=-lm
@ -131,7 +131,7 @@
else # ifeq freebsd
#############################################################################
@@ -831,7 +846,7 @@
@@ -831,7 +846,7 @@ endif
ifeq ($(USE_VOIP),1)
BASE_CFLAGS += -DUSE_VOIP
ifeq ($(USE_INTERNAL_SPEEX),1)
@ -140,7 +140,7 @@
else
CLIENT_LIBS += -lspeex
endif
@@ -1442,6 +1457,9 @@
@@ -1442,6 +1457,9 @@ ifeq ($(HAVE_VM_COMPILED),true)
ifeq ($(ARCH),x86_64)
Q3OBJ += $(B)/client/vm_x86_64.o $(B)/client/vm_x86_64_assembler.o
endif
@ -150,7 +150,7 @@
ifeq ($(ARCH),ppc)
Q3OBJ += $(B)/client/vm_powerpc.o $(B)/client/vm_powerpc_asm.o
endif
@@ -1591,6 +1609,9 @@
@@ -1591,6 +1609,9 @@ ifeq ($(HAVE_VM_COMPILED),true)
ifeq ($(ARCH),x86_64)
Q3DOBJ += $(B)/ded/vm_x86_64.o $(B)/ded/vm_x86_64_assembler.o
endif

View File

@ -1,6 +1,6 @@
--- README.orig 2009-04-08 05:36:16.000000000 +0200
+++ README 2011-10-27 13:13:59.000000000 +0200
@@ -79,6 +79,8 @@
--- README.orig 2009-04-08 03:36:16 UTC
+++ README
@@ -79,6 +79,8 @@ Makefile.local:
CFLAGS - use this for custom CFLAGS
V - set to show cc command line when building
DEFAULT_BASEDIR - extra path to search for baseq3 and such

View File

@ -1,6 +1,6 @@
--- code/client/snd_openal.c.orig 2009-12-26 18:10:44.000000000 +0100
+++ code/client/snd_openal.c 2009-12-26 18:11:00.000000000 +0100
@@ -1719,7 +1719,7 @@
--- code/client/snd_openal.c.orig 2009-03-15 12:39:53 UTC
+++ code/client/snd_openal.c
@@ -1719,7 +1719,7 @@ static cvar_t *s_alCapture;
#elif defined(MACOS_X)
#define ALDRIVER_DEFAULT "/System/Library/Frameworks/OpenAL.framework/OpenAL"
#else

View File

@ -1,6 +1,6 @@
--- code/qcommon/files.c.orig 2009-12-08 11:07:08.000000000 +0100
+++ code/qcommon/files.c 2009-12-08 11:08:41.000000000 +0100
@@ -241,6 +241,7 @@
--- code/qcommon/files.c.orig 2009-02-26 13:02:59 UTC
+++ code/qcommon/files.c
@@ -241,6 +241,7 @@ static cvar_t *fs_apppath;
#endif
static cvar_t *fs_basepath;
@ -8,7 +8,7 @@
static cvar_t *fs_basegame;
static cvar_t *fs_gamedirvar;
static searchpath_t *fs_searchpaths;
@@ -2761,6 +2762,7 @@
@@ -2761,6 +2762,7 @@ static void FS_Startup( const char *game
fs_debug = Cvar_Get( "fs_debug", "0", 0 );
fs_basepath = Cvar_Get ("fs_basepath", Sys_DefaultInstallPath(), CVAR_INIT );
fs_basegame = Cvar_Get ("fs_basegame", "", CVAR_INIT );

View File

@ -1,6 +1,6 @@
--- code/qcommon/q_platform.h.orig 2009-08-30 19:30:01.000000000 +0200
+++ code/qcommon/q_platform.h 2009-08-30 19:28:38.000000000 +0200
@@ -199,6 +199,8 @@
--- code/qcommon/q_platform.h.orig 2009-03-02 17:29:30 UTC
+++ code/qcommon/q_platform.h
@@ -199,6 +199,8 @@ Foundation, Inc., 51 Franklin St, Fifth
#ifdef __i386__
#define ARCH_STRING "i386"

View File

@ -1,6 +1,6 @@
--- code/qcommon/qcommon.h.orig 2009-12-08 11:09:48.000000000 +0100
+++ code/qcommon/qcommon.h 2009-12-08 11:10:43.000000000 +0100
@@ -1069,6 +1069,9 @@
--- code/qcommon/qcommon.h.orig 2009-01-17 23:09:58 UTC
+++ code/qcommon/qcommon.h
@@ -1069,6 +1069,9 @@ char *Sys_DefaultInstallPath(void);
char *Sys_DefaultAppPath(void);
#endif

View File

@ -1,6 +1,6 @@
--- code/qcommon/vm_interpreted.c 2009/11/01 19:58:07 1717
+++ code/qcommon/vm_interpreted.c 2010/01/16 10:55:51 1772
@@ -516,18 +516,20 @@
--- code/qcommon/vm_interpreted.c.orig 2008-08-23 22:45:30 UTC
+++ code/qcommon/vm_interpreted.c
@@ -526,18 +526,20 @@ nextInstruction2:
//VM_LogSyscalls( (int *)&image[ programStack + 4 ] );
{

View File

@ -1,6 +1,6 @@
--- code/qcommon/vm_x86.c.orig 2008-08-18 01:22:06.000000000 +0200
+++ code/qcommon/vm_x86.c 2013-11-14 11:44:27.000000000 +0100
@@ -36,7 +36,25 @@
--- code/qcommon/vm_x86.c.orig 2008-08-17 23:22:06 UTC
+++ code/qcommon/vm_x86.c
@@ -36,7 +36,25 @@ Foundation, Inc., 51 Franklin St, Fifth
/* need this on NX enabled systems (i386 with PAE kernel or
* noexec32=on x86_64) */
@ -27,7 +27,7 @@
#define VM_X86_MMAP
#endif
@@ -90,7 +108,11 @@
@@ -90,7 +108,11 @@ void AsmCall(void);
static void (*const asmCallPtr)(void) = AsmCall;

View File

@ -1,6 +1,6 @@
--- code/qcommon/vm_x86_64.c.orig 2009-08-30 20:50:41.000000000 +0200
+++ code/qcommon/vm_x86_64.c 2009-08-30 20:51:43.000000000 +0200
@@ -246,7 +246,7 @@
--- code/qcommon/vm_x86_64.c.orig 2008-08-06 16:09:29 UTC
+++ code/qcommon/vm_x86_64.c
@@ -246,7 +246,7 @@ void emit(const char* fmt, ...)
#else
#define JMPIARG \
emit("movq $%lu, %%rax", vm->codeBase+vm->instructionPointers[iarg]); \

View File

@ -1,6 +1,6 @@
--- code/sys/sys_main.c.orig 2009-03-02 23:26:36.000000000 +0100
+++ code/sys/sys_main.c 2009-12-08 11:31:12.000000000 +0100
@@ -49,6 +49,7 @@
--- code/sys/sys_main.c.orig 2009-03-02 22:26:36 UTC
+++ code/sys/sys_main.c
@@ -49,6 +49,7 @@ Foundation, Inc., 51 Franklin St, Fifth
static char binaryPath[ MAX_OSPATH ] = { 0 };
static char installPath[ MAX_OSPATH ] = { 0 };
@ -8,7 +8,7 @@
/*
=================
@@ -95,6 +96,30 @@
@@ -95,6 +96,30 @@ char *Sys_DefaultInstallPath(void)
/*
=================
@ -39,7 +39,7 @@
Sys_DefaultAppPath
=================
*/
@@ -384,6 +409,7 @@
@@ -384,6 +409,7 @@ Used to load a development dll instead o
#1 look down current path
#2 look in fs_homepath
#3 look in fs_basepath
@ -47,7 +47,7 @@
=================
*/
void *Sys_LoadDll( const char *name, char *fqpath ,
@@ -394,6 +420,7 @@
@@ -394,6 +420,7 @@ void *Sys_LoadDll( const char *name, cha
void (*dllEntry)( intptr_t (*syscallptr)(intptr_t, ...) );
char fname[MAX_OSPATH];
char *basepath;
@ -55,7 +55,7 @@
char *homepath;
char *pwdpath;
char *gamedir;
@@ -405,6 +432,7 @@
@@ -405,6 +432,7 @@ void *Sys_LoadDll( const char *name, cha
// TODO: use fs_searchpaths from files.c
pwdpath = Sys_Cwd();
basepath = Cvar_VariableString( "fs_basepath" );
@ -63,7 +63,7 @@
homepath = Cvar_VariableString( "fs_homepath" );
gamedir = Cvar_VariableString( "fs_game" );
@@ -413,6 +441,9 @@
@@ -413,6 +441,9 @@ void *Sys_LoadDll( const char *name, cha
if(!libHandle && homepath)
libHandle = Sys_TryLibraryLoad(homepath, gamedir, fname, fqpath);
@ -73,7 +73,7 @@
if(!libHandle && basepath)
libHandle = Sys_TryLibraryLoad(basepath, gamedir, fname, fqpath);
@@ -469,6 +500,10 @@
@@ -469,6 +500,10 @@ void Sys_ParseArgs( int argc, char **arg
# endif
#endif
@ -84,7 +84,7 @@
/*
=================
Sys_SigHandler
@@ -540,6 +575,7 @@
@@ -540,6 +575,7 @@ int main( int argc, char **argv )
Sys_ParseArgs( argc, argv );
Sys_SetBinaryPath( Sys_Dirname( argv[ 0 ] ) );
Sys_SetDefaultInstallPath( DEFAULT_BASEDIR );

View File

@ -1,6 +1,6 @@
--- code/sys/sys_unix.c.orig 2008-11-11 00:55:22.000000000 +0100
+++ code/sys/sys_unix.c 2011-10-27 13:11:15.000000000 +0200
@@ -53,7 +53,9 @@
--- code/sys/sys_unix.c.orig 2008-11-10 23:55:22 UTC
+++ code/sys/sys_unix.c
@@ -53,7 +53,9 @@ char *Sys_DefaultHomePath(void)
if( ( p = getenv( "HOME" ) ) != NULL )
{
Q_strncpyz( homePath, p, sizeof( homePath ) );

View File

@ -4,9 +4,11 @@
PORTNAME= iourbanterror
PKGNAMESUFFIX= -server
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= Urban Terror dedicated server
LICENSE= GPLv2
MASTERDIR= ${.CURDIR}/../${PORTNAME}
IOQ3= SERVER

View File

@ -8,19 +8,22 @@ PORTEPOCH= 1
CATEGORIES= games
DISTNAME= ioquake3-${DISTVERSION}
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= Quake 3 engine modified for Urban Terror (based on ioquake3)
RUN_DEPENDS= urbanterror-data>0:games/urbanterror-data
LICENSE?= GPLv2
MASTERDIR= ${.CURDIR}/../ioquake3
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
IOQ3?= CLIENT
# The docs belong to ioquake3
OPTIONS_EXCLUDE= DOCS
GAMEVERSION= 4.2.018
GAMEVERSION= 4.2.023
Q3ENGINEVER= ${DISTVERSION}+${GAMEVERSION}
Q3TOTALCONV= yes
Q3DIR= ${PREFIX}/share/quake3
@ -34,11 +37,12 @@ HOMEPATH= /.ioUrbanTerror
MAKE_ARGS+= BUILD_MISSIONPACK=0 \
BUILD_STANDALONE=1
post-patch:
pre-patch:
@(cd ${WRKSRC} && \
for pfile in ${.CURDIR}/../${PORTNAME}/files/patch-*; do \
for pfile in ${MASTERDIR}/files/patch-*; do \
${PATCH} < $${pfile}; \
done)
@${FIND} ${WRKSRC} -name \*.orig -delete
@${REINPLACE_CMD} \
-e 's/ioquake3/${Q3CLIENT}/g' \
-e 's/ioq3ded/${Q3SERVER}/g' \

View File

@ -1,6 +1,6 @@
--- code/qcommon/q_shared.h.orig 2014-03-23 17:10:02.000000000 +0100
+++ code/qcommon/q_shared.h 2014-03-23 17:12:24.000000000 +0100
@@ -27,11 +27,12 @@
--- code/qcommon/q_shared.h.orig 2008-11-03 17:03:54 UTC
+++ code/qcommon/q_shared.h
@@ -27,11 +27,12 @@ Foundation, Inc., 51 Franklin St, Fifth
// A user mod should never modify this file
#ifdef STANDALONE

View File

@ -0,0 +1,11 @@
--- code/qcommon/qcommon.h.orig 2016-03-31 19:41:05 UTC
+++ code/qcommon/qcommon.h
@@ -254,7 +254,7 @@ extern int demo_protocols[];
#endif
#endif
-#define PORT_MASTER 27950
+#define PORT_MASTER 27900
#define PORT_UPDATE 27951
#define PORT_SERVER 27960
#define NUM_SERVER_PORTS 4 // broadcast scan this many ports after

View File

@ -1,6 +1,6 @@
--- code/qcommon/vm_interpreted.c.orig 2014-03-23 17:14:22.000000000 +0100
+++ code/qcommon/vm_interpreted.c 2014-03-23 17:17:07.000000000 +0100
@@ -458,11 +458,11 @@
--- code/qcommon/vm_interpreted.c.orig 2016-03-31 19:41:05 UTC
+++ code/qcommon/vm_interpreted.c
@@ -458,11 +458,11 @@ nextInstruction2:
goto nextInstruction2;
case OP_STORE4:

View File

@ -1,6 +1,6 @@
--- code/qcommon/vm_x86.c.orig 2014-03-23 17:23:18.000000000 +0100
+++ code/qcommon/vm_x86.c 2014-03-23 17:24:58.000000000 +0100
@@ -512,7 +512,7 @@
--- code/qcommon/vm_x86.c.orig 2016-03-31 19:41:05 UTC
+++ code/qcommon/vm_x86.c
@@ -512,7 +512,7 @@ void VM_Compile( vm_t *vm, vmHeader_t *h
break;
}
if (code[pc+4] == OP_STORE4) {
@ -9,7 +9,7 @@
EmitString( "B8" ); // mov eax, 0x12345678
Emit4( Constant4() );
// if (!opt) {
@@ -527,7 +527,7 @@
@@ -527,7 +527,7 @@ void VM_Compile( vm_t *vm, vmHeader_t *h
break;
}
if (code[pc+4] == OP_STORE2) {

View File

@ -11,9 +11,11 @@ MASTER_SITES= SF/oarena:data \
DISTFILES= ${OA_DATA}:data
EXTRACT_ONLY=
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= OpenArena game data files
LICENSE= GPLv2
WRKSRC= ${WRKDIR}/baseoa
NO_BUILD= yes

View File

@ -8,9 +8,12 @@ CATEGORIES= games
MASTER_SITES= http://files.poulsander.com/~poul19/public_files/eliminationSource/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= OpenArena Mod: OpenArena Xpanded
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
PLIST_SUB+= DISTNAME="${DISTNAME}" \
PORTNAME="${PORTNAME}"

View File

@ -4,9 +4,11 @@
PORTNAME= openarena
PKGNAMESUFFIX= -server
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= OpenArena dedicated server
LICENSE= GPLv2
MASTERDIR= ${.CURDIR}/../${PORTNAME}
IOQ3= SERVER

View File

@ -7,13 +7,15 @@ PORTREVISION= 2
PORTEPOCH= 1
MASTER_SITES= SF/oarena/src \
http://files.poulsander.com/~poul19/public_files/oa/dev088/
DISTNAME= ${PORTNAME}-engine-source-0.8.8
DISTNAME= ${PORTNAME}-engine-source-${GAMEVERSION}
# Master port defines EXTRACT_SUFX unless already defined
EXTRACT_SUFX= .tar.bz2
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= Quake3 total conversion based on the ioquake3 engine
LICENSE?= GPLv2
RUN_DEPENDS= ${DATADIR}/${Q3BASE}/pak0.pk3:games/openarena-data
MASTERDIR= ${.CURDIR}/../ioquake3
@ -38,4 +40,7 @@ Q3DIR= ${DATADIR}
# No icon included with OpenArena
Q3ICON=
pre-patch:
@${FIND} ${WRKSRC} -name \*.orig -delete
.include "${MASTERDIR}/Makefile"

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2011-12-13 02:48:49.000000000 +0400
+++ Makefile 2015-09-30 17:16:31.951089000 +0300
@@ -205,6 +205,8 @@
--- Makefile.orig 2011-12-12 22:48:49 UTC
+++ Makefile
@@ -205,6 +205,8 @@ ifneq ($(BUILD_CLIENT),0)
OPENAL_LIBS=$(shell pkg-config --silence-errors --libs openal)
SDL_CFLAGS=$(shell pkg-config --silence-errors --cflags sdl|sed 's/-Dmain=SDL_main//')
SDL_LIBS=$(shell pkg-config --silence-errors --libs sdl)
@ -9,7 +9,7 @@
endif
# Use sdl-config if all else fails
ifeq ($(SDL_CFLAGS),)
@@ -570,9 +572,15 @@
@@ -570,9 +572,15 @@ else # ifeq mingw32
ifeq ($(PLATFORM),freebsd)
@ -25,7 +25,7 @@
-DUSE_ICON -DMAP_ANONYMOUS=MAP_ANON
CLIENT_CFLAGS = $(SDL_CFLAGS)
SERVER_CFLAGS =
@@ -595,27 +603,24 @@
@@ -595,27 +603,24 @@ ifeq ($(PLATFORM),freebsd)
# optional features/libraries
ifeq ($(USE_OPENAL),1)
@ -59,7 +59,7 @@
endif
# cross-compiling tweaks
@@ -897,7 +902,7 @@
@@ -897,7 +902,7 @@ ifeq ($(USE_VOIP),1)
CLIENT_CFLAGS += -DUSE_VOIP
SERVER_CFLAGS += -DUSE_VOIP
ifeq ($(USE_INTERNAL_SPEEX),1)

View File

@ -0,0 +1,30 @@
--- code/qcommon/files.c.orig 2011-12-24 12:29:32 UTC
+++ code/qcommon/files.c
@@ -250,6 +250,7 @@ static cvar_t *fs_apppath;
#endif
static cvar_t *fs_basepath;
+static cvar_t *fs_libpath;
static cvar_t *fs_basegame;
static cvar_t *fs_gamedirvar;
static searchpath_t *fs_searchpaths;
@@ -2859,6 +2860,7 @@ static void FS_Startup( const char *game
fs_debug = Cvar_Get( "fs_debug", "0", 0 );
fs_basepath = Cvar_Get ("fs_basepath", Sys_DefaultInstallPath(), CVAR_INIT );
fs_basegame = Cvar_Get ("fs_basegame", "", CVAR_INIT );
+ fs_libpath = Cvar_Get ("fs_libpath", Sys_DefaultLibPath(), CVAR_INIT );
homePath = Sys_DefaultHomePath();
if (!homePath || !homePath[0]) {
homePath = fs_basepath->string;
@@ -2878,6 +2880,11 @@ static void FS_Startup( const char *game
if (fs_apppath->string[0])
FS_AddGameDirectory(fs_apppath->string, gameName);
#endif
+
+ // Search default library location if given
+ if (fs_libpath->string[0]) {
+ FS_AddGameDirectory ( fs_libpath->string, gameName );
+ }
// NOTE: same filtering below for mods and basegame
if (fs_homepath->string[0] && Q_stricmp(fs_homepath->string,fs_basepath->string)) {

View File

@ -0,0 +1,12 @@
--- code/qcommon/qcommon.h.orig 2011-12-24 12:29:32 UTC
+++ code/qcommon/qcommon.h
@@ -1099,6 +1099,9 @@ char *Sys_DefaultInstallPath(void);
char *Sys_DefaultAppPath(void);
#endif
+void Sys_SetDefaultLibPath(const char *path);
+char *Sys_DefaultLibPath(void);
+
void Sys_SetDefaultHomePath(const char *path);
char *Sys_DefaultHomePath(void);
const char *Sys_TempPath(void);

View File

@ -1,9 +1,10 @@
--- code/qcommon/vm_x86.c.orig 2014-03-23 14:53:59.000000000 +0100
+++ code/qcommon/vm_x86.c 2014-03-23 14:55:33.000000000 +0100
@@ -91,7 +91,11 @@
--- code/qcommon/vm_x86.c.orig 2016-04-01 10:07:17 UTC
+++ code/qcommon/vm_x86.c
@@ -90,8 +90,11 @@ static int ftolPtr = (int)qftol0F7F;
void AsmCall(void);
static void (*const asmCallPtr)(void) = AsmCall;
-
+#ifdef __clang__
+ int callMask = 0;
+#else

View File

@ -0,0 +1,63 @@
--- code/sys/sys_main.c.orig 2011-12-24 12:29:37 UTC
+++ code/sys/sys_main.c
@@ -49,6 +49,7 @@ Foundation, Inc., 51 Franklin St, Fifth
static char binaryPath[ MAX_OSPATH ] = { 0 };
static char installPath[ MAX_OSPATH ] = { 0 };
+static char libPath[ MAX_OSPATH ] = { 0 };
/*
=================
@@ -95,6 +96,29 @@ char *Sys_DefaultInstallPath(void)
/*
=================
+Sys_SetDefaultLibPath
+=================
+*/
+void Sys_SetDefaultLibPath(const char *path)
+{
+ Q_strncpyz(libPath, path, sizeof(libPath));
+}
+
+/*
+=================
+Sys_DefaultLibPath
+=================
+*/
+char *Sys_DefaultLibPath(void)
+{
+ if (*libPath)
+ return libPath;
+ else
+ return Sys_Cwd();
+}
+
+/*
+=================
Sys_DefaultAppPath
=================
*/
@@ -490,6 +514,14 @@ void Sys_ParseArgs( int argc, char **arg
# endif
#endif
+#ifndef DEFAULT_LIBDIR
+# ifdef MACOS_X
+# define DEFAULT_LIBDIR Sys_StripAppBundle(Sys_BinaryPath())
+# else
+# define DEFAULT_LIBDIR Sys_BinaryPath()
+# endif
+#endif
+
/*
=================
Sys_SigHandler
@@ -564,6 +596,7 @@ int main( int argc, char **argv )
Sys_ParseArgs( argc, argv );
Sys_SetBinaryPath( Sys_Dirname( argv[ 0 ] ) );
Sys_SetDefaultInstallPath( DEFAULT_BASEDIR );
+ Sys_SetDefaultLibPath( DEFAULT_LIBDIR );
// Concatenate the command line for passing to Com_Init
for( i = 1; i < argc; i++ )

View File

@ -1,105 +0,0 @@
--- code/qcommon/files.c.orig 2011-12-24 13:29:32.000000000 +0100
+++ code/qcommon/files.c 2012-03-07 23:00:53.000000000 +0100
@@ -250,6 +250,7 @@
#endif
static cvar_t *fs_basepath;
+static cvar_t *fs_libpath;
static cvar_t *fs_basegame;
static cvar_t *fs_gamedirvar;
static searchpath_t *fs_searchpaths;
@@ -2859,6 +2860,7 @@
fs_debug = Cvar_Get( "fs_debug", "0", 0 );
fs_basepath = Cvar_Get ("fs_basepath", Sys_DefaultInstallPath(), CVAR_INIT );
fs_basegame = Cvar_Get ("fs_basegame", "", CVAR_INIT );
+ fs_libpath = Cvar_Get ("fs_libpath", Sys_DefaultLibPath(), CVAR_INIT );
homePath = Sys_DefaultHomePath();
if (!homePath || !homePath[0]) {
homePath = fs_basepath->string;
@@ -2878,6 +2880,11 @@
if (fs_apppath->string[0])
FS_AddGameDirectory(fs_apppath->string, gameName);
#endif
+
+ // Search default library location if given
+ if (fs_libpath->string[0]) {
+ FS_AddGameDirectory ( fs_libpath->string, gameName );
+ }
// NOTE: same filtering below for mods and basegame
if (fs_homepath->string[0] && Q_stricmp(fs_homepath->string,fs_basepath->string)) {
--- code/qcommon/qcommon.h.orig 2011-12-24 13:29:32.000000000 +0100
+++ code/qcommon/qcommon.h 2012-03-07 23:00:53.000000000 +0100
@@ -1099,6 +1099,9 @@
char *Sys_DefaultAppPath(void);
#endif
+void Sys_SetDefaultLibPath(const char *path);
+char *Sys_DefaultLibPath(void);
+
void Sys_SetDefaultHomePath(const char *path);
char *Sys_DefaultHomePath(void);
const char *Sys_TempPath(void);
--- code/sys/sys_main.c.orig 2011-12-24 13:29:37.000000000 +0100
+++ code/sys/sys_main.c 2012-03-07 23:00:53.000000000 +0100
@@ -49,6 +49,7 @@
static char binaryPath[ MAX_OSPATH ] = { 0 };
static char installPath[ MAX_OSPATH ] = { 0 };
+static char libPath[ MAX_OSPATH ] = { 0 };
/*
=================
@@ -95,6 +96,29 @@
/*
=================
+Sys_SetDefaultLibPath
+=================
+*/
+void Sys_SetDefaultLibPath(const char *path)
+{
+ Q_strncpyz(libPath, path, sizeof(libPath));
+}
+
+/*
+=================
+Sys_DefaultLibPath
+=================
+*/
+char *Sys_DefaultLibPath(void)
+{
+ if (*libPath)
+ return libPath;
+ else
+ return Sys_Cwd();
+}
+
+/*
+=================
Sys_DefaultAppPath
=================
*/
@@ -490,6 +514,14 @@
# endif
#endif
+#ifndef DEFAULT_LIBDIR
+# ifdef MACOS_X
+# define DEFAULT_LIBDIR Sys_StripAppBundle(Sys_BinaryPath())
+# else
+# define DEFAULT_LIBDIR Sys_BinaryPath()
+# endif
+#endif
+
/*
=================
Sys_SigHandler
@@ -564,6 +596,7 @@
Sys_ParseArgs( argc, argv );
Sys_SetBinaryPath( Sys_Dirname( argv[ 0 ] ) );
Sys_SetDefaultInstallPath( DEFAULT_BASEDIR );
+ Sys_SetDefaultLibPath( DEFAULT_LIBDIR );
// Concatenate the command line for passing to Com_Init
for( i = 1; i < argc; i++ )

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= data
PORTVERSION= 4.2.018
PORTVERSION= 4.2.023
CATEGORIES= games
MASTER_SITES= http://cdn.urbanterror.info/urt/42/zips/ \
http://www.f1m.fr/uploads/urt/ \
@ -12,7 +12,7 @@ DISTNAME= UrbanTerror${URT_VER}_full${URT_REV}
EXTRACT_SUFX= .zip
EXTRACT_ONLY=
MAINTAINER= kamikaze@bsdforen.de
MAINTAINER= kami@freebsd.org
COMMENT= Standalone realism based mod originally for Quake III Arena
NO_BUILD= yes
@ -27,6 +27,7 @@ URT_REV= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\2/}
PLIST_SUB+= VER=${URT_VER}
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
UTDOCS= readme${URT_VER}.txt \
How_To_Install.txt \
@ -41,11 +42,9 @@ do-install:
UrbanTerror${URT_VER}/q3ut4
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for utdoc in ${UTDOCS}
${MV} ${STAGEDIR}${DATADIR}/q3ut4/${utdoc} ${STAGEDIR}${DOCSDIR}
.endfor
${MV} ${UTDOCS:C!^!${STAGEDIR}${DATADIR}/q3ut4/!} ${STAGEDIR}${DOCSDIR}/
.else
${RM} ${STAGEDIR}${DATADIR}/q3ut4/readme${URT_VER}.txt
${RM} ${UTDOCS:C!^!${STAGEDIR}${DATADIR}/q3ut4/!}
.endif
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (UrbanTerror42_full018.zip) = 10710c5b762687a75a7abd3cc56de005ce12dcb7ac14c08f40bcb4e9d96f4e83
SIZE (UrbanTerror42_full018.zip) = 1702949967
SHA256 (UrbanTerror42_full023.zip) = e287e2a17432b81551f5c16e431d752484ce9be10508e756542f653757a29090
SIZE (UrbanTerror42_full023.zip) = 1924172827

View File

@ -1,6 +1,3 @@
%%PORTDOCS%%%%DOCSDIR%%/readme%%VER%%.txt
%%PORTDOCS%%%%DOCSDIR%%/How_To_Install.txt
%%PORTDOCS%%%%DOCSDIR%%/QIIIA_Game_Source_License.doc
%%DATADIR%%/q3ut4/autoexec_example.cfg
%%DATADIR%%/q3ut4/mapcycle_example.txt
%%DATADIR%%/q3ut4/server_example.cfg
@ -32,4 +29,11 @@
%%DATADIR%%/q3ut4/zUrT42_0024.pk3
%%DATADIR%%/q3ut4/zUrT42_0025.pk3
%%DATADIR%%/q3ut4/zUrT42_0026.pk3
%%DATADIR%%/q3ut4/zUrT42_0027.pk3
%%DATADIR%%/q3ut4/zUrT42_0028.pk3
%%DATADIR%%/q3ut4/zUrT42_0029.pk3
%%DATADIR%%/q3ut4/zUrT42_0030.pk3
%%DATADIR%%/q3ut4/zUrT42_qvm.pk3
%%DOCS%%%%DOCSDIR%%/How_To_Install.txt
%%DOCS%%%%DOCSDIR%%/QIIIA_Game_Source_License.doc
%%DOCS%%%%DOCSDIR%%/readme42.txt