- update to 1.5.4

This commit is contained in:
Dirk Meyer 2012-12-09 21:37:57 +00:00
parent 25495a995b
commit 9aa9018e40
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=308569
4 changed files with 33 additions and 40 deletions

View File

@ -1,8 +1,8 @@
# created by: Alan Eldridge <alane@geeksrus.net>
# Created by: Alan Eldridge <alane@geeksrus.net>
# $FreeBSD$
PORTNAME= cups
PORTVERSION= 1.5.2
PORTVERSION= 1.5.4
DISTVERSIONSUFFIX= -source
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
@ -54,17 +54,17 @@ CUPSSYSGRP= wheel
# UNIQUENAME must be set before bsd.port.pre.mk so OPTIONSFILE can be included
.if defined(CUPS_CLIENT)
PORTREVISION= 2
PORTREVISION= 0
LICENSE= LGPL21
CUPS_SUFFIX= -client
OPTIONS_DEFINE= GNUTLS
.elif defined(CUPS_IMAGE)
PORTREVISION= 1
PORTREVISION= 0
CUPS_SUFFIX= -image
LICENSE= LGPL21
OPTIONS_DEFINE= GNUTLS
.else
PORTREVISION= 2
PORTREVISION= 0
CUPS_SUFFIX= -base
CONFLICTS+= cupsddk-*
OPTIONS_DEFINE= GNUTLS LIBPAPER PHP PYTHON PAM LDAP DBUS LIBUSB XDG_OPEN GHOSTSCRIPT XPDF AVAHI MDNSRESPONDER
@ -88,10 +88,10 @@ USE_LDCONFIG= yes
PKGMESSAGE= ${NONEXISTENT}
DESCR= ${MASTERDIR}/pkg-descr.client
.elif defined(CUPS_IMAGE)
LIB_DEPENDS+= cups.2:${PORTSDIR}/${PKGCATEGORY}/cups-client \
jpeg.11:${PORTSDIR}/graphics/jpeg \
LIB_DEPENDS+= cups:${PORTSDIR}/${PKGCATEGORY}/cups-client \
jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
tiff:${PORTSDIR}/graphics/tiff
# force build if old cups is installed.
BUILD_DEPENDS+= cups-client${PKGNAMESUFFIX2}>=${PORTVERSION}:${PORTSDIR}/${PKGCATEGORY}/cups-client
COMMENT2= Library cupsimage
@ -102,8 +102,8 @@ USE_LDCONFIG= yes
PKGMESSAGE= ${NONEXISTENT}
DESCR= ${MASTERDIR}/pkg-descr.image
.else
LIB_DEPENDS+= cups.2:${PORTSDIR}/${PKGCATEGORY}/cups-client
LIB_DEPENDS+= cupsimage.2:${PORTSDIR}/${PKGCATEGORY}/cups-image
LIB_DEPENDS+= cups:${PORTSDIR}/${PKGCATEGORY}/cups-client
LIB_DEPENDS+= cupsimage:${PORTSDIR}/${PKGCATEGORY}/cups-image
# force build if old cups is installed.
BUILD_DEPENDS+= cups-client${PKGNAMESUFFIX2}>=${PORTVERSION}:${PORTSDIR}/${PKGCATEGORY}/cups-client
BUILD_DEPENDS+= cups-image${PKGNAMESUFFIX2}>=${PORTVERSION}:${PORTSDIR}/${PKGCATEGORY}/cups-image
@ -125,8 +125,8 @@ CONFIGURE_ARGS+= --with-printcap=${PREFIX}/etc/printcap
.if ${PORT_OPTIONS:MGNUTLS}
CONFIGURE_ARGS+= --disable-openssl --enable-gnutls
LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
USE_PKGCONFIG= yes
.else
CONFIGURE_ARGS+= --disable-gnutls --enable-openssl
@ -168,7 +168,7 @@ USE_PYTHON= yes
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MLIBPAPER}
CONFIGURE_ARGS+= --enable-libpaper
LIB_DEPENDS+= paper.2:${PORTSDIR}/print/libpaper
LIB_DEPENDS+= paper:${PORTSDIR}/print/libpaper
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MMDNSRESPONDER}
@ -205,7 +205,7 @@ CONFIGURE_ARGS+= --disable-ldap
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MDBUS}
LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
CONFIGURE_ARGS+= --enable-dbus
PLIST_SUB+= WITH_DBUS=""
.else

View File

@ -1,2 +1,2 @@
SHA256 (cups-1.5.2-source.tar.bz2) = b150aa108c631f4f07e92cb13c01263a67170e5ac8383c5548ef8f8473a187fb
SIZE (cups-1.5.2-source.tar.bz2) = 9595665
SHA256 (cups-1.5.4-source.tar.bz2) = 8023034e8b58eab1ad7279364e872270a77459f6fb59a84d03229cb1d2a6d0e5
SIZE (cups-1.5.4-source.tar.bz2) = 9583002

View File

@ -1,36 +1,28 @@
--- configure.orig 2011-07-25 22:19:20.000000000 +0200
+++ configure 2011-08-25 06:04:32.000000000 +0200
@@ -6259,6 +6259,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
+#include <sys/param.h>
#include <sys/ucred.h>
_ACEOF
rm -f conftest.$ac_objext
@@ -8689,7 +8690,7 @@
--- configure.orig 2012-07-27 22:57:23.000000000 +0200
+++ configure 2012-11-05 20:13:13.000000000 +0100
@@ -566,6 +566,7 @@
# Factoring default headers for most tests.
ac_includes_default="\
#include <stdio.h>
+#include <netinet/in.h>
#ifdef HAVE_SYS_TYPES_H
# include <sys/types.h>
#endif
@@ -5660,7 +5661,7 @@
CFLAGS="$CFLAGS `$PKGCONFIG --cflags dbus-1` -DDBUS_API_SUBJECT_TO_CHANGE"
CUPSDLIBS="$CUPSDLIBS `$PKGCONFIG --libs dbus-1`"
SERVERLIBS="$SERVERLIBS `$PKGCONFIG --libs dbus-1`"
DBUS_NOTIFIER="dbus"
- DBUS_NOTIFIERLIBS="`$PKGCONFIG --libs dbus-1`"
+ DBUS_NOTIFIERLIBS="`$PKGCONFIG --libs dbus-1` -pthread"
SAVELIBS="$LIBS"
LIBS="$LIBS $DBUS_NOTIFIERLIBS"
{ echo "$as_me:$LINENO: checking for dbus_message_iter_init_append" >&5
@@ -13524,6 +13525,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
+#include <netinet/in.h>
#include <resolv.h>
_ACEOF
rm -f conftest.$ac_objext
@@ -17447,7 +17449,7 @@
ac_fn_c_check_func "$LINENO" "dbus_message_iter_init_append" "ac_cv_func_dbus_message_iter_init_append"
@@ -8302,7 +8303,7 @@
if test x$ac_cv_header_pthread_h = xyes; then
- for flag in -lpthreads -lpthread -pthread; do
+ for flag in -pthread; do
{ echo "$as_me:$LINENO: checking for pthread_create using $flag" >&5
echo $ECHO_N "checking for pthread_create using $flag... $ECHO_C" >&6; }
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pthread_create using $flag" >&5
$as_echo_n "checking for pthread_create using $flag... " >&6; }
SAVELIBS="$LIBS"

View File

@ -1047,6 +1047,7 @@ sbin/reject
%%DATADIR%%/ipptool/onepage-letter.ps
%%DATADIR%%/ipptool/get-completed-jobs.test
%%DATADIR%%/ipptool/get-jobs.test
%%DATADIR%%/ipptool/get-printer-attributes.test
%%DATADIR%%/ipptool/ipp-1.1.test
%%DATADIR%%/ipptool/ipp-2.0.test
%%DATADIR%%/ipptool/ipp-2.1.test