p5-GD doesn't support gif generation, change to PNG method,

and change MAINTAINER's email,

use PERL_CONFIGURE instead "configure:".

PR:		ports/24657
Submitted by:	maintainer
This commit is contained in:
Vanilla I. Shu 2001-01-27 15:52:40 +00:00
parent cdb9101891
commit 9a9eb8a370
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37648
4 changed files with 51 additions and 7 deletions

View File

@ -5,24 +5,26 @@
# $FreeBSD$
#
PORTNAME= p5-GIFgraph
PORTNAME= GIFgraph
PORTVERSION= 1.10
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= GIFgraph
PKGNAMEPREFIX= p5-
DISTNAME= GIFgraph-${PORTVERSION}
MAINTAINER= laskavy@gambit.msk.su
MAINTAINER= ls@gambit.com.ru
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
USE_PERL5= YES
PERL_CONFIGURE= YES
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= GIFgraph.3 GIFgraph::colour.3
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
post-patch:
find ${WRKSRC} -name '*.orig' -delete
.include <bsd.port.mk>

View File

@ -0,0 +1,42 @@
--- GIFgraph./axestype.pm Wed Aug 26 03:37:14 1998
+++ GIFgraph/axestype.pm Tue Jan 23 19:21:04 2001
@@ -116,7 +116,7 @@
$self->draw_data($self->{graph}, $data);
$self->draw_legend($self->{graph});
- return $self->{graph}->gif
+ return $self->{graph}->png
}
sub set_x_label_font($) # (fontname)
--- GIFgraph./pie.pm Wed Aug 26 03:28:51 1998
+++ GIFgraph/pie.pm Tue Jan 23 19:23:09 2001
@@ -53,7 +53,7 @@
$self->draw_pie($self->{graph});
$self->draw_data($data, $self->{graph});
- return $self->{graph}->gif;
+ return $self->{graph}->png;
}
sub set_label_font($) # (fontname)
--- GIFgraph.pm. Wed Aug 26 03:28:48 1998
+++ GIFgraph.pm Tue Jan 23 19:31:49 2001
@@ -373,7 +373,7 @@
open(GIFLOGO, $self->{logo}) || return;
binmode(GIFLOGO) if ($GIFgraph::needs_binmode);
- unless ( $glogo = newFromGif GD::Image(\*GIFLOGO) )
+ unless ( $glogo = newFromPng GD::Image(\*GIFLOGO) )
{
warn "Problems reading $self->{logo}";
close(GIFLOGO);
@@ -465,7 +465,7 @@
{
my $s = shift;
- return $s->{graph}->gif;
+ return $s->{graph}->png;
}
} # End of package GIFgraph

View File

@ -1 +1 @@
A Perl package to generate GIF charts
A Perl package to generate PNG charts

View File

@ -1,2 +1,2 @@
This is GIFgraph, a package to generate GIF charts,
This is GIFgraph, a package to generate PNG charts,
using Lincoln Stein's GD.pm.