- Fix PLIST errors for config file

- Pet portlint while here

PR:		ports/172127
Approved by:	"Veniamin Gvozdikov" <g.veniamin@googlemail.com> (maintainer, via private email)
This commit is contained in:
Steve Wills 2012-09-28 13:41:47 +00:00
parent 24329c088e
commit 9a8d00c635
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=304995
3 changed files with 33 additions and 12 deletions

View File

@ -15,18 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= g.veniamin@googlemail.com
COMMENT= Agent for OCS Inventory server and FusionInventory for GLPI servers
OPTIONS= CUPS "Enable CUPS" OFF \
HTTP "Enable HTTP daemon mode" OFF \
ZLIB "Enable Zlib compression" ON \
SSL "Enable SSL" OFF \
DMIDECODE "Enable dmidecode hardware information" ON \
PCIUTILS "Enable pciutils hardware information" ON \
NMAP "Enable NMAP network inventory" OFF
LICENSE= GPLv2
USE_GMAKE= yes
BUILD_DEPENDS= p5-Text-Template>=0:${PORTSDIR}/textproc/p5-Text-Template \
p5-ExtUtils-MakeMaker>=6.59:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker \
p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
@ -36,7 +26,6 @@ BUILD_DEPENDS= p5-Text-Template>=0:${PORTSDIR}/textproc/p5-Text-Template \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-MockModule>=0:${PORTSDIR}/devel/p5-Test-MockModule \
p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
@ -44,9 +33,18 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-HTTP-Proxy>=0:${PORTSDIR}/www/p5-HTTP-Proxy \
p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
p5-IO-Capture>=0:${PORTSDIR}/devel/p5-IO-Capture \
p5-IO-Capture>=0:${PORTSDIR}/devel/p5-IO-Capture
OPTIONS= CUPS "Enable CUPS" OFF \
HTTP "Enable HTTP daemon mode" OFF \
ZLIB "Enable Zlib compression" ON \
SSL "Enable SSL" OFF \
DMIDECODE "Enable dmidecode hardware information" ON \
PCIUTILS "Enable pciutils hardware information" ON \
NMAP "Enable NMAP network inventory" OFF
PERL_CONFIGURE= yes
USE_GMAKE= yes
MAN1= fusioninventory-agent.1 \
fusioninventory-injector.1
@ -125,4 +123,9 @@ post-patch-script:
@${FIND} ${WRKSRC} -type f \( -name '*.orig' \) -delete
@${ECHO_MSG} " [ DONE ]"
post-install:
@if [ ! -f ${PREFIX}/etc/fusioninventory/agent.cfg ]; then \
${CP} -p ${PREFIX}/etc/fusioninventory/agent.cfg.sample ${PREFIX}/etc/fusioninventory/agent.cfg ; \
fi
.include <bsd.port.post.mk>

View File

@ -0,0 +1,15 @@
--- Makefile.PL.orig 2012-09-27 23:53:24.000000000 +0000
+++ Makefile.PL 2012-09-27 23:55:38.000000000 +0000
@@ -151,11 +151,7 @@
config_install :
install -d -m 755 $(DESTDIR)$(SYSCONFDIR)
- if [ -f $(DESTDIR)/$(SYSCONFDIR)/agent.cfg ]; then \
- install -m 644 etc/agent.cfg $(DESTDIR)$(SYSCONFDIR)/agent.cfg.new; \
- else \
- install -m 644 etc/agent.cfg $(DESTDIR)$(SYSCONFDIR)/agent.cfg; \
- fi
+ install -m 644 etc/agent.cfg $(DESTDIR)$(SYSCONFDIR)/agent.cfg.sample
data_install :
install -d -m 755 $(DESTDIR)$(DATADIR)

View File

@ -1,5 +1,8 @@
bin/fusioninventory-agent
bin/fusioninventory-injector
@unexec if cmp -s %D/etc/fusioninventory/agent.cfg.sample %D/etc/fusioninventory/agent.cfg; then rm -f %D/etc/fusioninventory/agent.cfg; fi
etc/fusioninventory/agent.cfg.sample
@exec if [ ! -f %D/etc/fusioninventory/agent.cfg ] ; then cp -p %D/etc/fusioninventory/agent.cfg.sample %D/etc/fusioninventory/agent.cfg; fi
share/fusioninventory/lib/FusionInventory/Agent.pm
share/fusioninventory/lib/FusionInventory/Agent/Config.pm
share/fusioninventory/lib/FusionInventory/Agent/HTTP/Client.pm