- Update to 6.3.9

PR:		ports/129755
Submitted by:	Matthias Andree <matthias.andree@gmx.de>
Approved by:	maintainer timeout (barner; 20 days)
This commit is contained in:
Pav Lucistnik 2009-01-08 12:12:44 +00:00
parent 515cca9f16
commit 9a45bddce5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=225443
7 changed files with 33 additions and 94 deletions

View File

@ -10,8 +10,7 @@
# want fetchmailconf to work, define WITH_X11
PORTNAME= fetchmail
PORTVERSION= 6.3.8
PORTREVISION= 7
PORTVERSION= 6.3.9
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
${MASTER_SITE_SUNSITE:S/$/:sunsite/}\
@ -35,7 +34,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
--with-hesiod=no --enable-fallback=no
--with-hesiod=no --enable-fallback=no PYTHON=:
# bsd.openssl.mk will add the LDFLAGS to CONFIGURE_ENV:
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \

View File

@ -1,3 +1,3 @@
MD5 (fetchmail-6.3.8.tar.bz2) = 66b97500b0a1e3c0916b3b5314f597f5
SHA256 (fetchmail-6.3.8.tar.bz2) = 5612f9af367f641e0efd084f44fcf1889669e711dbd8c60f6b7953e494d1b09b
SIZE (fetchmail-6.3.8.tar.bz2) = 1323515
MD5 (fetchmail-6.3.9.tar.bz2) = 72c20ad2b9629f1a109668b05a84d823
SHA256 (fetchmail-6.3.9.tar.bz2) = 3dfd3b04aa552331f91f96bdf5f5afe489c31a600ae7973f5814bde5555813dc
SIZE (fetchmail-6.3.9.tar.bz2) = 1538134

View File

@ -1,11 +0,0 @@
--- sink.c (revision 5118)
+++ sink.c (revision 5119)
@@ -262,7 +262,7 @@
const char *md1 = "MAILER-DAEMON", *md2 = "MAILER-DAEMON@";
/* don't bounce in reply to undeliverable bounces */
- if (!msg->return_path[0] ||
+ if (!msg || !msg->return_path[0] ||
strcmp(msg->return_path, "<>") == 0 ||
strcasecmp(msg->return_path, md1) == 0 ||
strncasecmp(msg->return_path, md2, strlen(md2)) == 0)

View File

@ -1,52 +0,0 @@
--- report.c.orig 2008-07-01 18:15:58.000000000 +0200
+++ report.c 2008-07-01 18:18:53.000000000 +0200
@@ -238,11 +238,17 @@
rep_ensuresize();
#if defined(VA_START)
- VA_START (args, message);
for ( ; ; )
{
+ /*
+ * args has to be initialized before every call of vsnprintf(),
+ * because vsnprintf() invokes va_arg macro and thus args is
+ * undefined after the call.
+ */
+ VA_START(args, message);
n = vsnprintf (partial_message + partial_message_size_used, partial_message_size - partial_message_size_used,
message, args);
+ va_end (args);
if (n >= 0
&& (unsigned)n < partial_message_size - partial_message_size_used)
@@ -254,7 +260,6 @@
partial_message_size += 2048;
partial_message = REALLOC (partial_message, partial_message_size);
}
- va_end (args);
#else
for ( ; ; )
{
@@ -304,12 +309,13 @@
rep_ensuresize();
#if defined(VA_START)
- VA_START (args, message);
for ( ; ; )
{
+ VA_START(args, message);
n = vsnprintf (partial_message + partial_message_size_used,
partial_message_size - partial_message_size_used,
message, args);
+ va_end(args);
/* old glibc versions return -1 for truncation */
if (n >= 0
@@ -322,7 +328,6 @@
partial_message_size += 2048;
partial_message = REALLOC (partial_message, partial_message_size);
}
- va_end (args);
#else
for ( ; ; )
{

View File

@ -9,28 +9,3 @@
INSTALL_HEADER = $(INSTALL_DATA)
transform = $(program_transform_name)
NORMAL_INSTALL = :
@@ -864,24 +864,6 @@
rm -f y.tab.c
uninstall-info-am:
install-pythonPYTHON: $(python_PYTHON)
- @$(NORMAL_INSTALL)
- test -z "$(pythondir)" || $(mkdir_p) "$(DESTDIR)$(pythondir)"
- @list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
- if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
- if test -f $$b$$p; then \
- f=$(am__strip_dir) \
- dlist="$$dlist $$f"; \
- echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
- $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
- else :; fi; \
- done; \
- if test -n "$$dlist"; then \
- if test -z "$(DESTDIR)"; then \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
- else \
- PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pythondir)" $$dlist; \
- fi; \
- else :; fi
uninstall-pythonPYTHON:
@$(NORMAL_UNINSTALL)

View File

@ -0,0 +1,18 @@
Index: driver.c
===================================================================
--- driver.c (Revision 5254)
+++ driver.c (Revision 5255)
@@ -1435,9 +1435,11 @@
/* end-of-mailbox processing before we repoll or switch to another one */
if (ctl->server.base_protocol->end_mailbox_poll)
{
- err = (ctl->server.base_protocol->end_mailbox_poll)(mailserver_socket, ctl);
- if (err)
+ tmperr = (ctl->server.base_protocol->end_mailbox_poll)(mailserver_socket, ctl);
+ if (tmperr) {
+ err = tmperr;
goto cleanUp;
+ }
}
/* Return now if we have reached the fetchlimit */
if (maxfetch && maxfetch <= fetches)

View File

@ -16,15 +16,25 @@ libexec/fetchmailconf.py
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%NLS%%share/locale/ca/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/cs/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/da/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/de/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/el/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/es/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/fi/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/fr/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/gl/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/id/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/ja/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/nl/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/pl/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/ru/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/sk/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/sq/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/tr/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/vi/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/fetchmail.mo
@unexec if cmp -s %D/etc/fetchmailrc.sample %D/etc/fetchmailrc; then rm -f %D/etc/fetchmailrc; fi
etc/fetchmailrc.sample
@exec if [ ! -f %D/etc/fetchmailrc ] ; then cp -p %D/%F %B/fetchmailrc; fi