Update www/cutelyst and related ports to latest upstream release

Release notes are at
	https://dantti.wordpress.com/2021/01/19/cutelyst-2-14-2-and-asql-0-27-released/
There were patches from FreeBSD upstreamed, and some tidying-up,
and there's a bunch of patches and benchmark improvements.
This commit is contained in:
Adriaan de Groot 2021-01-21 22:43:51 +00:00
parent 9f918ff4e4
commit 9a1a824fae
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=562253
6 changed files with 10 additions and 46 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= asql
DISTVERSIONPREFIX= v
DISTVERSION= 0.26.0
DISTVERSION= 0.27.0
CATEGORIES= databases
PKGNAMEPREFIX= cutelyst-

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1609503064
SHA256 (cutelyst-asql-v0.26.0_GH0.tar.gz) = ca30ace4f62e37f6644f7a56883f137d5e1341226cad347a675205e33857ce6b
SIZE (cutelyst-asql-v0.26.0_GH0.tar.gz) = 33150
TIMESTAMP = 1611268564
SHA256 (cutelyst-asql-v0.27.0_GH0.tar.gz) = 5d54dbdc0f97f2e63ade95bb3794bb8f5b7238cf7a248236b756c3146707260a
SIZE (cutelyst-asql-v0.27.0_GH0.tar.gz) = 33303

View File

@ -2,7 +2,7 @@
PORTNAME= cutelyst
DISTVERSIONPREFIX= v
DISTVERSION= 2.14.0
DISTVERSION= 2.14.2
CATEGORIES= www
MAINTAINER= adridg@FreeBSD.org

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1609503082
SHA256 (cutelyst-cutelyst-v2.14.0_GH0.tar.gz) = 73115acaa1df8574bed4333b3ee142b09f1a7abe1272c19379392c1735e85bea
SIZE (cutelyst-cutelyst-v2.14.0_GH0.tar.gz) = 489834
TIMESTAMP = 1611268580
SHA256 (cutelyst-cutelyst-v2.14.2_GH0.tar.gz) = 5ff193f6bded151e6f5f9525bb93b8d4b4eac925ca83c557fd8471dd0ceca95a
SIZE (cutelyst-cutelyst-v2.14.2_GH0.tar.gz) = 490467

View File

@ -1,38 +0,0 @@
FreeBSD isn't Linux, in spite of being a non-Apple UNIX.
There's unreached code in the patch showing how we *could*
do it if (when) libepoll-shim supports the whole API needed.
--- CMakeLists.txt.orig 2019-02-15 20:30:30 UTC
+++ CMakeLists.txt
@@ -166,7 +166,30 @@ if(UNIX AND NOT (APPLE OR HAIKU))
endif()
if (LINUX)
- add_subdirectory(EventLoopEPoll)
+ if(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+ # FreeBSD isn't Linux, but it gets claimed as Linux, above.
+ #
+ # Try to find the EPOLL implementation from libepoll-shim; while
+ # epoll.h is found, and timerfd.h is found, the implementation
+ # in timerfd is insufficient (missing timerfd_gettime), and besides
+ # that there is also no eventfd.h.
+ #
+ # So, do the work of finding EPOLL, but don't use that subdirectory.
+ # Also, decide that we're not Linux after all.
+ find_file(EPOLL_H sys/epoll.h
+ HINTS libepoll-shim /usr/local/include/libepoll-shim
+ )
+ if (EPOLL_H)
+ get_filename_component(EPOLL_SYS_DIR ${EPOLL_H} DIRECTORY)
+ get_filename_component(EPOLL_DIR ${EPOLL_SYS_DIR} DIRECTORY)
+ include_directories(${EPOLL_DIR})
+ # add_subdirectory(EventLoopEPoll)
+ endif()
+ set(LINUX FALSE)
+ else()
+ # Real Linux
+ add_subdirectory(EventLoopEPoll)
+ endif()
endif()
add_subdirectory(wsgi)

View File

@ -1,6 +1,7 @@
bin/cutelyst-wsgi2
bin/cutelyst2
include/cutelyst2-qt5/Cutelyst/Action
include/cutelyst2-qt5/Cutelyst/ActionChain
include/cutelyst2-qt5/Cutelyst/Application
include/cutelyst2-qt5/Cutelyst/Component
include/cutelyst2-qt5/Cutelyst/Context
@ -94,6 +95,7 @@ include/cutelyst2-qt5/Cutelyst/Upload
include/cutelyst2-qt5/Cutelyst/View
include/cutelyst2-qt5/Cutelyst/WSGI/wsgi.h
include/cutelyst2-qt5/Cutelyst/action.h
include/cutelyst2-qt5/Cutelyst/actionchain.h
include/cutelyst2-qt5/Cutelyst/application.h
include/cutelyst2-qt5/Cutelyst/async.h
include/cutelyst2-qt5/Cutelyst/component.h