Update to 0.9.1.
Prompted by: many Submitted by: Anders Nordby <anders@fix.no>
This commit is contained in:
parent
041b23f64a
commit
99f7fd175a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53899
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= py-MySQLdb
|
||||
PORTVERSION= 0.9.0
|
||||
PORTVERSION= 0.9.1
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= mysql-python
|
||||
|
@ -1 +1 @@
|
||||
MD5 (MySQL-python-0.9.0.tar.gz) = bd56fa81769739d6710e320b3765675b
|
||||
MD5 (MySQL-python-0.9.1.tar.gz) = 802e271d46e3d845045ce0378f82fd85
|
||||
|
@ -1,17 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- _mysql.c 2002/01/09 13:02:08 1.1
|
||||
+++ _mysql.c 2002/01/09 13:06:07
|
||||
@@ -781,7 +781,11 @@
|
||||
goto error;
|
||||
}
|
||||
if (!row) {
|
||||
+#if PY_VERSION_HEX < 0x02020000
|
||||
if (_PyTuple_Resize(r, i, 0) == -1) goto error;
|
||||
+#else
|
||||
+ if (_PyTuple_Resize(r, i) == -1) goto error;
|
||||
+#endif
|
||||
break;
|
||||
}
|
||||
v = convert_row(self, row);
|
@ -1,13 +1,15 @@
|
||||
--- setup.py.orig Tue Oct 31 21:28:16 2000
|
||||
+++ setup.py Wed Nov 1 13:51:41 2000
|
||||
@@ -32,8 +32,8 @@
|
||||
--- setup.py.orig Wed Oct 17 05:17:30 2001
|
||||
+++ setup.py Tue Jan 22 00:33:59 2002
|
||||
@@ -24,9 +24,9 @@
|
||||
libraries = [mysqlclient, "z"]
|
||||
runtime_library_dirs = []
|
||||
extra_objects = [r'c:\mysql\lib\opt\mysqlclient.lib']
|
||||
elif os.name == "posix": # most Linux/UNIX platforms
|
||||
- include_dirs = ['/usr/include/mysql']
|
||||
- library_dirs = ['/usr/lib/mysql']
|
||||
extra_objects = []
|
||||
-elif sys.platform in ("freebsd4", "openbsd2"):
|
||||
- include_dirs = ['/usr/local/include/mysql']
|
||||
- library_dirs = ['/usr/local/lib/mysql']
|
||||
+elif sys.platform[:7] in ("freebsd", "openbsd"):
|
||||
+ include_dirs = ['%%LOCALBASE%%/include/mysql']
|
||||
+ library_dirs = ['%%LOCALBASE%%/lib/mysql']
|
||||
# MySQL-3.23 seems to need libz
|
||||
libraries = [mysqlclient, "z"]
|
||||
# On some platorms, this can be used to find the shared libraries
|
||||
runtime_library_dirs = []
|
||||
extra_objects = []
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= py-MySQLdb
|
||||
PORTVERSION= 0.9.0
|
||||
PORTVERSION= 0.9.1
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= mysql-python
|
||||
|
@ -1 +1 @@
|
||||
MD5 (MySQL-python-0.9.0.tar.gz) = bd56fa81769739d6710e320b3765675b
|
||||
MD5 (MySQL-python-0.9.1.tar.gz) = 802e271d46e3d845045ce0378f82fd85
|
||||
|
@ -1,17 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- _mysql.c 2002/01/09 13:02:08 1.1
|
||||
+++ _mysql.c 2002/01/09 13:06:07
|
||||
@@ -781,7 +781,11 @@
|
||||
goto error;
|
||||
}
|
||||
if (!row) {
|
||||
+#if PY_VERSION_HEX < 0x02020000
|
||||
if (_PyTuple_Resize(r, i, 0) == -1) goto error;
|
||||
+#else
|
||||
+ if (_PyTuple_Resize(r, i) == -1) goto error;
|
||||
+#endif
|
||||
break;
|
||||
}
|
||||
v = convert_row(self, row);
|
@ -1,13 +1,15 @@
|
||||
--- setup.py.orig Tue Oct 31 21:28:16 2000
|
||||
+++ setup.py Wed Nov 1 13:51:41 2000
|
||||
@@ -32,8 +32,8 @@
|
||||
--- setup.py.orig Wed Oct 17 05:17:30 2001
|
||||
+++ setup.py Tue Jan 22 00:33:59 2002
|
||||
@@ -24,9 +24,9 @@
|
||||
libraries = [mysqlclient, "z"]
|
||||
runtime_library_dirs = []
|
||||
extra_objects = [r'c:\mysql\lib\opt\mysqlclient.lib']
|
||||
elif os.name == "posix": # most Linux/UNIX platforms
|
||||
- include_dirs = ['/usr/include/mysql']
|
||||
- library_dirs = ['/usr/lib/mysql']
|
||||
extra_objects = []
|
||||
-elif sys.platform in ("freebsd4", "openbsd2"):
|
||||
- include_dirs = ['/usr/local/include/mysql']
|
||||
- library_dirs = ['/usr/local/lib/mysql']
|
||||
+elif sys.platform[:7] in ("freebsd", "openbsd"):
|
||||
+ include_dirs = ['%%LOCALBASE%%/include/mysql']
|
||||
+ library_dirs = ['%%LOCALBASE%%/lib/mysql']
|
||||
# MySQL-3.23 seems to need libz
|
||||
libraries = [mysqlclient, "z"]
|
||||
# On some platorms, this can be used to find the shared libraries
|
||||
runtime_library_dirs = []
|
||||
extra_objects = []
|
||||
|
Loading…
Reference in New Issue
Block a user