Update to 0.1.5.
This commit is contained in:
parent
630d04fd83
commit
99e5e3b172
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108629
@ -6,8 +6,7 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= libXt
|
PORTNAME= libXt
|
||||||
PORTVERSION= 0.1.4
|
PORTVERSION= 0.1.5
|
||||||
PORTREVISION= 5
|
|
||||||
CATEGORIES= x11-toolkits
|
CATEGORIES= x11-toolkits
|
||||||
MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
|
MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
|
||||||
|
|
||||||
@ -16,8 +15,7 @@ COMMENT= X Toolkit library
|
|||||||
|
|
||||||
LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11 \
|
LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11 \
|
||||||
${X11BASE}/libdata/pkgconfig/sm.pc:${PORTSDIR}/x11/libSM
|
${X11BASE}/libdata/pkgconfig/sm.pc:${PORTSDIR}/x11/libSM
|
||||||
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
|
BUILD_DEPENDS= ${LIB_PC_DEPENDS}
|
||||||
${LIB_PC_DEPENDS}
|
|
||||||
RUN_DEPENDS= ${LIB_PC_DEPENDS}
|
RUN_DEPENDS= ${LIB_PC_DEPENDS}
|
||||||
|
|
||||||
CONFLICTS= XFree86-libraries-*
|
CONFLICTS= XFree86-libraries-*
|
||||||
@ -33,7 +31,4 @@ CFLAGS+= -DMALLOC_0_RETURNS_NULL
|
|||||||
INSTALLS_SHLIB= yes
|
INSTALLS_SHLIB= yes
|
||||||
USE_GNOME= gnomehack pkgconfig
|
USE_GNOME= gnomehack pkgconfig
|
||||||
|
|
||||||
post-extract:
|
|
||||||
@${MV} ${WRKSRC}/ObjectP.h ${WRKSRC}/include/X11
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
MD5 (libXt-0.1.4.tar.bz2) = 32b6528c9deb058d1a9ed17ffa848df8
|
MD5 (libXt-0.1.5.tar.bz2) = 8ff20498eeedebe2fb72f93c2d7beab1
|
||||||
SIZE (libXt-0.1.4.tar.bz2) = 407934
|
SIZE (libXt-0.1.5.tar.bz2) = 415938
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
--- Makefile.in.orig Wed Mar 31 01:57:05 2004
|
|
||||||
+++ Makefile.in Wed Mar 31 02:07:39 2004
|
|
||||||
@@ -163,12 +163,12 @@
|
|
||||||
|
|
||||||
SUBDIRS = include util
|
|
||||||
|
|
||||||
-AM_CFLAGS = $(RENDER_CFLAGS) $(X_CFLAGS) -I$(top_srcdir)/include/X11
|
|
||||||
+AM_CFLAGS = $(RENDER_CFLAGS) $(X_CFLAGS) $(SM_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/include/X11
|
|
||||||
|
|
||||||
lib_LTLIBRARIES = libXt.la
|
|
||||||
|
|
||||||
-BUILT_SOURCES = StringDefs.c StringDefs.h Shell.h
|
|
||||||
-CLEANFILES = StringDefs.c StringDefs.h Shell.h
|
|
||||||
+BUILT_SOURCES = StringDefs.c include/X11/StringDefs.h include/X11/Shell.h
|
|
||||||
+CLEANFILES=StringDefs.c StringDefs.h Shell.h include/X11/StringDefs.h include/X11/Shell.h
|
|
||||||
|
|
||||||
nodist_libXt_la_SOURCES = StringDefs.c
|
|
||||||
|
|
||||||
@@ -210,7 +210,6 @@
|
|
||||||
Manage.c \
|
|
||||||
NextEvent.c \
|
|
||||||
Object.c \
|
|
||||||
- ObjectP.h \
|
|
||||||
PassivGraI.h \
|
|
||||||
PassivGrab.c \
|
|
||||||
Pointer.c \
|
|
||||||
@@ -899,6 +898,7 @@
|
|
||||||
$(top_builddir)/util/makestrs $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
|
|
||||||
install -d include/X11/
|
|
||||||
install -m644 $(top_builddir)/StringDefs.h include/X11/
|
|
||||||
+ install -m644 $(top_builddir)/Shell.h include/X11/
|
|
||||||
|
|
||||||
$(top_builddir)/util/makestrs$(EXEEXT): force
|
|
||||||
cd util; $(MAKE)
|
|
@ -1,23 +0,0 @@
|
|||||||
--- include/Makefile.in.orig Wed Mar 31 01:57:05 2004
|
|
||||||
+++ include/Makefile.in Wed Mar 31 02:09:56 2004
|
|
||||||
@@ -148,6 +148,7 @@
|
|
||||||
X11/Intrinsic.h \
|
|
||||||
X11/IntrinsicP.h \
|
|
||||||
X11/Object.h \
|
|
||||||
+ X11/ObjectP.h \
|
|
||||||
X11/RectObj.h \
|
|
||||||
X11/RectObjP.h \
|
|
||||||
X11/ShellP.h \
|
|
||||||
@@ -155,9 +156,10 @@
|
|
||||||
X11/VendorP.h
|
|
||||||
|
|
||||||
nodist_xtinclude_HEADERS = \
|
|
||||||
- X11/StringDefs.h
|
|
||||||
+ X11/StringDefs.h \
|
|
||||||
+ X11/Shell.h
|
|
||||||
|
|
||||||
-DISTCLEANFILES = X11/StringDefs.h
|
|
||||||
+DISTCLEANFILES = X11/StringDefs.h X11/Shell.h
|
|
||||||
subdir = include
|
|
||||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
||||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
Loading…
Reference in New Issue
Block a user