SALOME is a free software that provides a generic platform for Pre

and Post-Processing for numerical simulation.
+Supports interoperability between CAD modeling and
 computation software (CAD-CAE link)
+Makes easier the integration of new components on heterogeneous systems
 for numerical computation
+Sets the priority to multi-physics coupling between computation software
+Provides a generic user interface, user-friendly and efficient,
 which helps to reduce the costs and  delays of carrying out the studies
+Reduces training time to the specific time for learning the software solution
 which has been based on this platform
+All functionalities are accessible through the programmatic
 integrated Python console

This package contains Job manager module.

WWW: http://www.salome-platform.org
- Stas Timokhin
devel@stasyan.com

PR:		ports/152396
Submitted by:	Stas Timokhin <devel at stasyan.com>
This commit is contained in:
Thierry Thomas 2011-01-04 21:15:54 +00:00
parent d6df47c2d9
commit 998f56359b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=267392
5 changed files with 78 additions and 0 deletions

View File

@ -76,6 +76,7 @@
SUBDIR += salome
SUBDIR += salome-geom
SUBDIR += salome-gui
SUBDIR += salome-jobmanager
SUBDIR += salome-kernel
SUBDIR += salome-light
SUBDIR += salome-med

View File

@ -0,0 +1,15 @@
# New ports collection makefile for: cad/salome-jobmanager
# Date created: 10 Nov 2010
# Whom: Stas Timokhin <devel@stasyan.com>
#
# $FreeBSD$
CATEGORIES= cad science
MASTERDIR= ${.CURDIR}/../salome
PORTNAME= salome
PKGNAMESUFFIX= -jobmanager
SAL_MODULE_UPPER= JOBMANAGER
.include "${MASTERDIR}/Makefile"

View File

@ -0,0 +1,11 @@
--- configure.ac.orig 2010-11-10 13:50:32.000000000 +0600
+++ configure.ac 2010-11-10 13:50:39.000000000 +0600
@@ -39,7 +39,7 @@
# argument. Exemple:
# $ filename="../KERNEL_SRC/configure
# $ absfilename=`absolute_path $filename`
-function absolute_path {
+absolute_path () {
filename=$1
here=`pwd`
apath=`dirname $filename`

View File

@ -0,0 +1,19 @@
SALOME is a free software that provides a generic platform for Pre
and Post-Processing for numerical simulation.
+Supports interoperability between CAD modeling and
computation software (CAD-CAE link)
+Makes easier the integration of new components on heterogeneous systems
for numerical computation
+Sets the priority to multi-physics coupling between computation software
+Provides a generic user interface, user-friendly and efficient,
which helps to reduce the costs and delays of carrying out the studies
+Reduces training time to the specific time for learning the software solution
which has been based on this platform
+All functionalities are accessible through the programmatic
integrated Python console
This package contains Job manager module.
WWW: http://www.salome-platform.org
- Stas Timokhin
devel@stasyan.com

View File

@ -0,0 +1,32 @@
bin/jobmanager_gui
bin/start_jobmanager.sh
include/salome/BL_Exception.hxx
include/salome/BL_SalomeGui.hxx
include/salome/BL_Traces.hxx
lib/salome/libBL_Bases.a
lib/salome/libBL_Bases.la
lib/salome/libBL_Bases.so
lib/salome/libBL_Bases.so.0
lib/salome/libBL_Engine.a
lib/salome/libBL_Engine.la
lib/salome/libBL_Engine.so
lib/salome/libBL_Engine.so.0
lib/salome/libBL_GenericGui.a
lib/salome/libBL_GenericGui.la
lib/salome/libBL_GenericGui.so
lib/salome/libBL_GenericGui.so.0
lib/salome/libBL_Wrappers_Qt.a
lib/salome/libBL_Wrappers_Qt.la
lib/salome/libBL_Wrappers_Qt.so
lib/salome/libBL_Wrappers_Qt.so.0
lib/salome/libBL_Wrappers_SALOME.a
lib/salome/libBL_Wrappers_SALOME.la
lib/salome/libBL_Wrappers_SALOME.so
lib/salome/libBL_Wrappers_SALOME.so.0
lib/salome/libJOBMANAGER.a
lib/salome/libJOBMANAGER.la
lib/salome/libJOBMANAGER.so
lib/salome/libJOBMANAGER.so.0
%%DATADIR%%/resources/jobmanager/SalomeApp.xml
%%DATADIR%%/resources/jobmanager/jobmanager.png
@dirrm %%DATADIR%%/resources/jobmanager