- Respect CFLAGS

- Fix build with gcc41
- Mark broken on RELENG_5

PR:		ports/111492
Submitted by:	trasz
Approved by:	miwi (mentor)
This commit is contained in:
Edward Tomasz Napierala 2007-04-21 14:31:57 +00:00
parent fb646d0403
commit 9963592a98
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=190545
6 changed files with 65 additions and 3 deletions

View File

@ -21,8 +21,9 @@ LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
jack.0:${PORTSDIR}/audio/jack
USE_QT_VER= 3
MAKE_ENV= QTDIR="${QT_PREFIX}"
MAKE_ENV+= QTDIR="${QT_PREFIX}"
USE_SCONS= yes
SCONS_ENV+= CXX="${CXX}"
.include <bsd.port.pre.mk>
@ -30,6 +31,10 @@ USE_SCONS= yes
BROKEN= Does not compile on alpha
.endif
.if ${OSVERSION} < 600020
BROKEN= Requires MSG_NOSIGNAL
.endif
post-patch:
@${REINPLACE_CMD} -e 's,%%CFLAGS%%,${CFLAGS},' ${WRKSRC}/SConstruct
@${REINPLACE_CMD} -e 's,%%QT_PREFIX%%,${QT_PREFIX},' ${WRKSRC}/detect.py

View File

@ -1,5 +1,15 @@
--- SConstruct.orig Tue Mar 27 22:35:53 2007
+++ SConstruct Tue Mar 27 22:36:54 2007
--- SConstruct.orig Fri Apr 23 07:51:57 2004
+++ SConstruct Mon Apr 9 19:20:43 2007
@@ -53,8 +53,8 @@
env.make_so = None
env.detect = detect.Detect()
+env['CXX'] = os.environ['CXX']
if os.environ.has_key('DISTCC_HOSTS'):
- env['CXX'] = os.environ['CXX']
env['ENV']['DISTCC_HOSTS'] = os.environ['DISTCC_HOSTS']
env['ENV']['HOME'] = os.environ['HOME']
@@ -87,7 +87,7 @@
env.optimize_resampler_hack=0

View File

@ -0,0 +1,14 @@
--- cheesetracker/trackercore/saver.cpp.orig Thu Apr 12 00:12:30 2007
+++ cheesetracker/trackercore/saver.cpp Thu Apr 12 00:13:52 2007
@@ -35,11 +35,8 @@
#include "saver.h"
-namespace Audio {
-
Saver::Saver(){
}
Saver::~Saver(){
}
-}; // end of namespace declaration

View File

@ -0,0 +1,11 @@
--- common/components/audio/resampler_manager.h.orig Thu Apr 12 00:03:58 2007
+++ common/components/audio/resampler_manager.h Thu Apr 12 00:04:14 2007
@@ -34,7 +34,7 @@
public:
- static Resampler_Manager * Resampler_Manager::get_resampler_manager();
+ static Resampler_Manager * get_resampler_manager();
int get_resampler_count();
Resampler * get_resampler(int p_index);

View File

@ -0,0 +1,11 @@
--- common/components/data/property_bridges.h.orig Wed Apr 11 23:57:19 2007
+++ common/components/data/property_bridges.h Thu Apr 12 00:02:25 2007
@@ -41,7 +41,7 @@
*/
#define BRIDGE_COPY_VALUE(T) \
- virtual bool T::copy_value(const Property_Bridge& rvalue) {\
+ virtual bool copy_value(const Property_Bridge& rvalue) {\
T* rcast = dynamic_cast<T*>((T*)&rvalue);\
if (rcast) {\
set(rcast->get());\

View File

@ -0,0 +1,11 @@
--- common/drivers/posix/sound_driver_jack.h.orig Thu Apr 12 00:09:04 2007
+++ common/drivers/posix/sound_driver_jack.h Thu Apr 12 00:09:21 2007
@@ -72,7 +72,7 @@
int jack_callback_nframes;
- Sound_Driver::Status Sound_Driver_JACK::process();
+ Sound_Driver::Status process();
static int process_jack_callback(jack_nframes_t nframes,void *arg);
static int jack_set_mixfreq(jack_nframes_t nframes,void *arg);