Add new port graphics/gimageview - a GTK+ based image viewer.
PR: 35125 Submitted by: TATEISHI Katsuyuki <katsu@iec.hiroshima-u.ac.jp>
This commit is contained in:
parent
941e35a708
commit
9934f8fb79
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55001
@ -75,6 +75,7 @@
|
||||
SUBDIR += gifsicle
|
||||
SUBDIR += giftool
|
||||
SUBDIR += giftrans
|
||||
SUBDIR += gimageview
|
||||
SUBDIR += gimp-manual-html
|
||||
SUBDIR += gimp-manual-pdf
|
||||
SUBDIR += gimp-manual-ps
|
||||
|
27
graphics/gimageview/Makefile
Normal file
27
graphics/gimageview/Makefile
Normal file
@ -0,0 +1,27 @@
|
||||
# New ports collection makefile for: gimageview
|
||||
# Date Created: 5 Feb 2002
|
||||
# Whom: TATEISHI Katsuyuki <katsu@iec.hiroshima-u.ac.jp>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gimageview
|
||||
PORTVERSION= 0.1.98
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gtkmmviewer
|
||||
|
||||
MAINTAINER= katsu@iec.hiroshima-u.ac.jp
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_IMLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's/DATADIRNAME=lib/DATADIRNAME=share/g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/gimageview/distinfo
Normal file
1
graphics/gimageview/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (gimageview-0.1.98.tar.gz) = d0fad95ef53f203221af41eab418792a
|
25
graphics/gimageview/files/patch-ltmain.sh
Normal file
25
graphics/gimageview/files/patch-ltmain.sh
Normal file
@ -0,0 +1,25 @@
|
||||
--- ltmain.sh.orig Sat Nov 17 07:22:26 2001
|
||||
+++ ltmain.sh Wed Feb 20 16:21:57 2002
|
||||
@@ -2690,6 +2690,9 @@
|
||||
# Absolute path.
|
||||
rpath="$rpath$dir:"
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Relative path: add a thisdir entry.
|
||||
rpath="$rpath\$thisdir/$dir:"
|
||||
@@ -3360,10 +3363,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
1
graphics/gimageview/pkg-comment
Normal file
1
graphics/gimageview/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Yet another GTK+ based image viewer
|
11
graphics/gimageview/pkg-descr
Normal file
11
graphics/gimageview/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
GImageView is a GTK+ based image viewer.
|
||||
|
||||
It support tabbed browsing, thumbnail table views, directory tree views,
|
||||
drag and drop, reading thumbnail cache of other famous image viewers,
|
||||
and flexible user interface.
|
||||
|
||||
WWW: http://gtkmmviewer.sourceforge.net/
|
||||
Authors: Takuro Ashie <ashie@homa.ne.jp>, Nyan2 <t-nyan2@nifty.com>
|
||||
|
||||
--
|
||||
TATEISHI Katsuyuki <katsu@iec.hiroshima-u.ac.jp>
|
101
graphics/gimageview/pkg-plist
Normal file
101
graphics/gimageview/pkg-plist
Normal file
@ -0,0 +1,101 @@
|
||||
bin/gimv
|
||||
lib/gimageview/archiver/libarc_lha_ext.so
|
||||
lib/gimageview/archiver/libarc_rar_ext.so
|
||||
lib/gimageview/archiver/libarc_tar_ext.so
|
||||
lib/gimageview/archiver/libarc_zip_ext.so
|
||||
lib/gimageview/image_saver/libpng_saver.so
|
||||
lib/gimageview/image_saver/libpnm_saver.so
|
||||
lib/gimageview/image_saver/libxvpics_saver.so
|
||||
lib/gimageview/thumbnail/libee_thumb.so
|
||||
lib/gimageview/thumbnail/libgimv_thumb.so
|
||||
lib/gimageview/thumbnail/libgqview_thumb.so
|
||||
lib/gimageview/thumbnail/libkonq_old_thumb.so
|
||||
lib/gimageview/thumbnail/libkonqueror_thumb.so
|
||||
lib/gimageview/thumbnail/libnautilus_thumb.so
|
||||
lib/gimageview/thumbnail/libxvpics_thumb.so
|
||||
share/gimageview/doc/html/ja/gimageview-1.html
|
||||
share/gimageview/doc/html/ja/gimageview-10.html
|
||||
share/gimageview/doc/html/ja/gimageview-11.html
|
||||
share/gimageview/doc/html/ja/gimageview-12.html
|
||||
share/gimageview/doc/html/ja/gimageview-2.html
|
||||
share/gimageview/doc/html/ja/gimageview-3.html
|
||||
share/gimageview/doc/html/ja/gimageview-4.html
|
||||
share/gimageview/doc/html/ja/gimageview-5.html
|
||||
share/gimageview/doc/html/ja/gimageview-6.html
|
||||
share/gimageview/doc/html/ja/gimageview-7.html
|
||||
share/gimageview/doc/html/ja/gimageview-8.html
|
||||
share/gimageview/doc/html/ja/gimageview-9.html
|
||||
share/gimageview/doc/html/ja/gimageview.css
|
||||
share/gimageview/doc/html/ja/gimageview.html
|
||||
share/gimageview/doc/text/C/COPYING
|
||||
share/gimageview/doc/text/ja/COPYING.jp
|
||||
share/gimageview/doc/text/ja/ChangeLog.jp
|
||||
share/gimageview/doc/text/ja/INSTALL.jp
|
||||
share/gimageview/doc/text/ja/README.jp
|
||||
share/gimageview/doc/text/ja/TIPS.jp
|
||||
share/gimageview/doc/text/ja/gimageview.txt
|
||||
share/gimageview/pixmaps/default/alert.xpm
|
||||
share/gimageview/pixmaps/default/archive.xpm
|
||||
share/gimageview/pixmaps/default/back.xpm
|
||||
share/gimageview/pixmaps/default/close.xpm
|
||||
share/gimageview/pixmaps/default/dotfile.xpm
|
||||
share/gimageview/pixmaps/default/eject.xpm
|
||||
share/gimageview/pixmaps/default/ff.xpm
|
||||
share/gimageview/pixmaps/default/folder-go.xpm
|
||||
share/gimageview/pixmaps/default/folder-link-open.xpm
|
||||
share/gimageview/pixmaps/default/folder-link.xpm
|
||||
share/gimageview/pixmaps/default/folder-open.xpm
|
||||
share/gimageview/pixmaps/default/folder-up.xpm
|
||||
share/gimageview/pixmaps/default/folder.xpm
|
||||
share/gimageview/pixmaps/default/folder48.xpm
|
||||
share/gimageview/pixmaps/default/forward.xpm
|
||||
share/gimageview/pixmaps/default/fullscreen.xpm
|
||||
share/gimageview/pixmaps/default/gimageview.xpm
|
||||
share/gimageview/pixmaps/default/home.xpm
|
||||
share/gimageview/pixmaps/default/image.xpm
|
||||
share/gimageview/pixmaps/default/leftarrow.xpm
|
||||
share/gimageview/pixmaps/default/next_t.xpm
|
||||
share/gimageview/pixmaps/default/nfolder.xpm
|
||||
share/gimageview/pixmaps/default/no_zoom.xpm
|
||||
share/gimageview/pixmaps/default/paper.xpm
|
||||
share/gimageview/pixmaps/default/pause.xpm
|
||||
share/gimageview/pixmaps/default/play.xpm
|
||||
share/gimageview/pixmaps/default/prefs.xpm
|
||||
share/gimageview/pixmaps/default/prev_t.xpm
|
||||
share/gimageview/pixmaps/default/question.xpm
|
||||
share/gimageview/pixmaps/default/refresh.xpm
|
||||
share/gimageview/pixmaps/default/resize.xpm
|
||||
share/gimageview/pixmaps/default/rightarrow.xpm
|
||||
share/gimageview/pixmaps/default/rotate.xpm
|
||||
share/gimageview/pixmaps/default/rw.xpm
|
||||
share/gimageview/pixmaps/default/search.xpm
|
||||
share/gimageview/pixmaps/default/skip.xpm
|
||||
share/gimageview/pixmaps/default/small_archive.xpm
|
||||
share/gimageview/pixmaps/default/small_close.xpm
|
||||
share/gimageview/pixmaps/default/small_home.xpm
|
||||
share/gimageview/pixmaps/default/small_refresh.xpm
|
||||
share/gimageview/pixmaps/default/small_up.xpm
|
||||
share/gimageview/pixmaps/default/stop.xpm
|
||||
share/gimageview/pixmaps/default/stop2.xpm
|
||||
share/gimageview/pixmaps/default/up.xpm
|
||||
share/gimageview/pixmaps/default/zoom.xpm
|
||||
share/gimageview/pixmaps/default/zoom_fit.xpm
|
||||
share/gimageview/pixmaps/default/zoom_in.xpm
|
||||
share/gimageview/pixmaps/default/zoom_out.xpm
|
||||
share/locale/ja/LC_MESSAGES/gimageview.mo
|
||||
@dirrm lib/gimageview/archiver
|
||||
@dirrm lib/gimageview/image_saver
|
||||
@dirrm lib/gimageview/thumbnail
|
||||
@dirrm lib/gimageview
|
||||
@dirrm share/gimageview/doc/html/ja
|
||||
@dirrm share/gimageview/doc/html
|
||||
@dirrm share/gimageview/doc/text/ja
|
||||
@dirrm share/gimageview/doc/text/C
|
||||
@dirrm share/gimageview/doc/text
|
||||
@dirrm share/gimageview/doc
|
||||
@dirrm share/gimageview/pixmaps/default
|
||||
@dirrm share/gimageview/pixmaps
|
||||
@dirrm share/gimageview
|
||||
@unexec rmdir %D/share/locale/ja/LC_MESSAGES 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale/ja 2>/dev/null || true
|
||||
@unexec rmdir %D/share/locale 2>/dev/null || true
|
Loading…
Reference in New Issue
Block a user