Fix multi-screen size handling, and fix test for wxWidgets

wx was imported in setup just to test if it was installed, then the script
prompted the user to continue.  Comment this out.

The screen size was not properly checked.  This caused issues on
multi-monitor systems.  Fixed.

Reported by:	db
This commit is contained in:
Stephen Hurd 2019-04-22 05:45:17 +00:00
parent ab25fb765b
commit 9915e9aa4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=499604
3 changed files with 29 additions and 5 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= quisk
PORTVERSION= 4.1.26
PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= CHEESESHOP

View File

@ -1,4 +1,4 @@
--- quisk.py.orig 2019-04-19 15:47:26 UTC
--- quisk.py.orig 2018-11-23 17:50:38 UTC
+++ quisk.py
@@ -21,6 +21,13 @@ os.chdir(os.path.normpath(os.path.dirnam
if sys.path[0] != "'.'": # Make sure the current working directory is on path
@ -14,3 +14,16 @@
import wx, wx.html, wx.lib.buttons, wx.lib.stattext, wx.lib.colourdb, wx.grid, wx.richtext
import math, cmath, time, traceback, string, select, subprocess
import threading, pickle, webbrowser
@@ -3609,9 +3616,9 @@ class App(wx.App):
self.file_play_timer = 0
self.file_play_source = 0 # 10 == play audio file, 11 == play I/Q sample file, 12 == play CQ message
# get the screen size - thanks to Lucian Langa
- x1, y1, x2, y2 = wx.Display().GetGeometry()
- self.screen_width = x2 - x1
- self.screen_height = y2 - y1
+ dispGeo = wx.Display().GetGeometry()
+ self.screen_width = dispGeo.width
+ self.screen_height = dispGeo.height
self.Bind(wx.EVT_IDLE, self.OnIdle)
self.Bind(wx.EVT_QUERY_END_SESSION, self.OnEndSession)
# Restore persistent program state

View File

@ -1,9 +1,14 @@
--- setup.py.orig 2018-11-22 14:56:57 UTC
+++ setup.py
@@ -18,18 +18,18 @@ if sys.platform != "win32":
except ImportError:
print ("Please install the package python-wxgtk3.0 or later")
missing = True
@@ -13,23 +13,23 @@ fp.close()
if sys.platform != "win32":
missing = False
- try:
- import wx
- except ImportError:
- print ("Please install the package python-wxgtk3.0 or later")
- missing = True
- if not os.path.isfile("/usr/include/fftw3.h"):
- print ("Please install the package libfftw3-dev")
- missing = True
@ -16,6 +21,11 @@
- if not os.path.isdir("/usr/include/pulse"):
- print ("please install the package libpulse-dev")
- missing = True
+# try:
+# import wx
+# except ImportError:
+# print ("Please install the package python-wxgtk3.0 or later")
+# missing = True
+# if not os.path.isfile("/usr/include/fftw3.h"):
+# print ("Please install the package libfftw3-dev")
+# missing = True