Add textproc/py-readchar

Library to easily read single chars and key strokes.  The idea is to have a
portable way to read single characters and key-strokes.

WWW: https://github.com/magmax/python-readchar
This commit is contained in:
Mateusz Piotrowski 2020-11-18 17:50:25 +00:00
parent 9168a83626
commit 99096adb1c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=555653
6 changed files with 63 additions and 0 deletions

View File

@ -1372,6 +1372,7 @@
SUBDIR += py-qt5-xml
SUBDIR += py-qt5-xmlpatterns
SUBDIR += py-rdflib
SUBDIR += py-readchar
SUBDIR += py-recommonmark
SUBDIR += py-regex
SUBDIR += py-reno

View File

@ -0,0 +1,31 @@
# $FreeBSD$
PORTNAME= readchar
PORTVERSION= 2.0.0
CATEGORIES= textproc devel
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= 0mp@FreeBSD.org
COMMENT= Python library to read characters and key strokes
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/README.rst
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
USES= dos2unix localbase python:3.6+
DOS2UNIX_GLOB= *.py
# CHEESESHOP does not seem to work so far.
USE_GITHUB= yes
GH_ACCOUNT= magmax
GH_PROJECT= python-${PORTNAME}
USE_PYTHON= autoplist distutils
do-test:
@(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1605719262
SHA256 (magmax-python-readchar-2.0.0_GH0.tar.gz) = 503c96fbdaa5e96162535dc0a8fb8525582a18a42214909d751f150c8029d694
SIZE (magmax-python-readchar-2.0.0_GH0.tar.gz) = 6046

View File

@ -0,0 +1,11 @@
--- readchar/readchar.py.orig 2020-11-18 17:42:51 UTC
+++ readchar/readchar.py
@@ -9,6 +9,8 @@ if sys.platform.startswith('linux'):
from .readchar_linux import readchar
elif sys.platform == 'darwin':
from .readchar_linux import readchar
+elif sys.platform.startswith('freebsd'):
+ from .readchar_linux import readchar
elif sys.platform in ('win32', 'cygwin'):
import msvcrt
from .readchar_windows import readchar

View File

@ -0,0 +1,13 @@
--- setup.py.orig 2020-11-18 17:14:13 UTC
+++ setup.py
@@ -75,7 +75,7 @@ setup(
],
install_requires=[
],
- setup_requires=[
- 'flake8',
- ],
+ #setup_requires=[
+ # 'flake8',
+ #],
)

View File

@ -0,0 +1,4 @@
Library to easily read single chars and key strokes. The idea is to have a
portable way to read single characters and key-strokes.
WWW: https://github.com/magmax/python-readchar